Is Quicken Mac compatible with the new Mac OS 10.12 (Sierra)?

Quicken KathrynQuicken Kathryn Administrator
Yes.  Both Quicken Mac 2015 and 2016 have been tested and will work on the new Sierra OS.  

Mac 2007 should work on Sierra, however, it has not been fully tested with the new OS.  See this FAQ for more information on Mac 2007 support policies.

Quicken Essentials, a discontinued product, has not been tested with Sierra, but early reports from users indicate that it is not working with Sierra.  In this case, we'd recommend not upgrading to Sierra until you upgrade your Quicken Mac product.

If you have Quicken Essentials and have already upgraded to Sierra, you can install Quicken 2016 for Mac and easily migrate your Essentials file to Quicken 2016.
Quicken Kathryn
Community Administrator

Comments

Sign In or Register to comment.