Home Quicken for Windows File Conversion and Backup (Windows)
Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

2017 R4 won't release USB drive

Brian ZielkeBrian Zielke Member ✭✭
Quicken 2017 on win7 and win10 locks any USB drive used for backup or restore. This has happened on R-3 and R-4. If I don't use Quicken the USB drive works fine

Comments

  • UnknownUnknown Member
    edited February 2017
    Are you using the USB device as a backup drive for your Quicken Data File (QDF) or to hold your production QDF?
  • Brian ZielkeBrian Zielke Member ✭✭
    edited October 2018
    As a back-up and to transfer to backup computer. It only locks the USB drive on restore, the backup function works correctly and does not lock it up. This lock up continues even after exit from Quicken. The lock-up happens only after a restore, even if it is on the original computer. R6 is still doing this. I won't talk about R5. I did a mondo reversal to R4 and when R6 came out R4 still updated to R5. I had to do a mondo update to R6; very depressing! I won't get into the "pat me on the back" email I just got a few days ago about how well Quicken(R5) was working and enjoyed by all! I'm still using 2014 on an old XP box and it still works great.
  • UnknownUnknown Member
    edited April 2017

    As a back-up and to transfer to backup computer. It only locks the USB drive on restore, the backup function works correctly and does not lock it up. This lock up continues even after exit from Quicken. The lock-up happens only after a restore, even if it is on the original computer. R6 is still doing this. I won't talk about R5. I did a mondo reversal to R4 and when R6 came out R4 still updated to R5. I had to do a mondo update to R6; very depressing! I won't get into the "pat me on the back" email I just got a few days ago about how well Quicken(R5) was working and enjoyed by all! I'm still using 2014 on an old XP box and it still works great.

    The file most likely needs to be on the primary hard drive itself.
    Restoring from anything but a local file usually has a very low success rate which is why quicken recommends having the files locally.
    Take the file out onto the computer and try restoring from your desktop and see if that works.
     Hope this helps! have a great day
  • Brian ZielkeBrian Zielke Member ✭✭
    edited April 2017

    As a back-up and to transfer to backup computer. It only locks the USB drive on restore, the backup function works correctly and does not lock it up. This lock up continues even after exit from Quicken. The lock-up happens only after a restore, even if it is on the original computer. R6 is still doing this. I won't talk about R5. I did a mondo reversal to R4 and when R6 came out R4 still updated to R5. I had to do a mondo update to R6; very depressing! I won't get into the "pat me on the back" email I just got a few days ago about how well Quicken(R5) was working and enjoyed by all! I'm still using 2014 on an old XP box and it still works great.

    Yea that works but it is poor programming and an extra step. That code to release should be put into the restore function! I won't store on the quicken cloud. Just like R5, I don't want a work-around. I want the program to work properly. By the way, restoring from the USB drive works fine(high success rate).
  • splashersplasher SuperUser ✭✭✭✭
    edited April 2017

    As a back-up and to transfer to backup computer. It only locks the USB drive on restore, the backup function works correctly and does not lock it up. This lock up continues even after exit from Quicken. The lock-up happens only after a restore, even if it is on the original computer. R6 is still doing this. I won't talk about R5. I did a mondo reversal to R4 and when R6 came out R4 still updated to R5. I had to do a mondo update to R6; very depressing! I won't get into the "pat me on the back" email I just got a few days ago about how well Quicken(R5) was working and enjoyed by all! I'm still using 2014 on an old XP box and it still works great.

    I routinely backup and restore directly from network and thumb drives in Win7 and Win10 without issue.

    Are you sure that something else is not getting in the way of the release?
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list

  • Brian ZielkeBrian Zielke Member ✭✭
    edited April 2017

    As a back-up and to transfer to backup computer. It only locks the USB drive on restore, the backup function works correctly and does not lock it up. This lock up continues even after exit from Quicken. The lock-up happens only after a restore, even if it is on the original computer. R6 is still doing this. I won't talk about R5. I did a mondo reversal to R4 and when R6 came out R4 still updated to R5. I had to do a mondo update to R6; very depressing! I won't get into the "pat me on the back" email I just got a few days ago about how well Quicken(R5) was working and enjoyed by all! I'm still using 2014 on an old XP box and it still works great.

    Other than the fact that I am using Win 7 and it does this on both 32 and 64bit computers, I would have no idea. It locks up the usb drive even on a Win 10 box that I built. If I restart the computer the USB drive safely removes as it should. I am open for any ideas as to why quicken 2017 locks my usb drive.
  • Brian ZielkeBrian Zielke Member ✭✭
    edited May 2017

    As a back-up and to transfer to backup computer. It only locks the USB drive on restore, the backup function works correctly and does not lock it up. This lock up continues even after exit from Quicken. The lock-up happens only after a restore, even if it is on the original computer. R6 is still doing this. I won't talk about R5. I did a mondo reversal to R4 and when R6 came out R4 still updated to R5. I had to do a mondo update to R6; very depressing! I won't get into the "pat me on the back" email I just got a few days ago about how well Quicken(R5) was working and enjoyed by all! I'm still using 2014 on an old XP box and it still works great.

    This is still a problem with R-6. If the Qdata backup is copied to desktop it does not happen. I have done enough programming in Assembler language to know this is a programming error
This discussion has been closed.