Tax Planner Problem

My question below was archived so I am posting it again.

I have 2017 Quicken Premier for Windows with R4.  Since 1/1/2017 Tax planner will no longer use scheduled transactions (none of them) for year end tax projections.  The option to select "Scheduled Bills and Deposits" under "Quicken Data (from 2017) - Source for projected amount"  is grayed out and cannot be selected. This is true for all the detail windows for every category in the Tax Planner even if the category has recurring scheduled transactions (such as income - Paycheck or deductions - Mortgage Payment / Interest or future Estimated Tax Payments).  There are no red transactions showing up on the details lists in any of the transactions on the details lists in the Tax Planner.  This makes the tax projection year end total way off.  I have also noticed that the scheduled transactions are no longer being entered automatically into any of my account registers even though they are set up that way in the Manage Reminders tab.  I have to enter them manually after they show in red as "overdue" on the scheduled transactions lists.  I suspect these are related issues.  I see a new tab on the register windows that allows future scheduled transactions to be shown in registers as pending for various time periods.  I suspect I could manually enter all future transactions into my registers and make the Tax Planner work that way but this would clutter up my registers.  I don't believe this is a problem with my data files but rather with the program.  I have used quicken for tax planning for many years - this is the reason I purchase the new versions every year.  2017 is the first version that has not worked correctly for tax planning.  Suggestions? 

Comments

  • mistertheplaguemistertheplague Member ✭✭
    edited February 2017
    I'm using the same version/release as you, and I'm not seeing what you're seeing. In my file, I have paycheck set up as a scheduled transaction, and in Wages and Salaries our salary is projected for 2017 based on the scheduled transactions that have already occurred this year. Projected salary is selectable in my file under Scheduled Bills and Deposits.

    Detail lists throughout my Tax Planner show projections for dividends, interest income, withholding, etc. based on already-occurred 2017 transactions. 

    I don't have our paycheck set up to enter automatically, however. I'll go in and change that and see if it affects anything in the Tax Planner. 
  • mistertheplaguemistertheplague Member ✭✭
    edited February 2017

    I'm using the same version/release as you, and I'm not seeing what you're seeing. In my file, I have paycheck set up as a scheduled transaction, and in Wages and Salaries our salary is projected for 2017 based on the scheduled transactions that have already occurred this year. Projected salary is selectable in my file under Scheduled Bills and Deposits.

    Detail lists throughout my Tax Planner show projections for dividends, interest income, withholding, etc. based on already-occurred 2017 transactions. 

    I don't have our paycheck set up to enter automatically, however. I'll go in and change that and see if it affects anything in the Tax Planner. 

    No change. I modified our scheduled paycheck to enter automatically and returned to the Tax Planner. Wages and Salary>Quicken Data (from 2017) still projects from Actual YTD, and Scheduled Bills and Deposits is still active and selectable. In Wages and Salary as well as Withholding, Actual YTD and Scheduled is still scrollable, and scheduled (red) transactions still appear. 

    I'm running QW17 Premier R4 Build 26.1.4.5
  • Dave LynchDave Lynch Member
    edited October 2018
    Now I am even more frustrated.  I spent an hour on the phone with Quicken Support validating and supervalidating my files and trying whatever else.  I gave up when the support person went to find a higher up and left me on hold for 15 minutes.  This problem started 1/1/2017 and I have searched high and low in the 2017 program for something to switch or turn on to get my scheduled transactions to automatically enter into my registers and to allow me to select "scheduled bills and deposits" under "source for projected amount" in the Tax Planner.   This option remains grayed out.  AAAhhhh.  
  • QPWQPW Member ✭✭✭✭
    edited February 2017

    Now I am even more frustrated.  I spent an hour on the phone with Quicken Support validating and supervalidating my files and trying whatever else.  I gave up when the support person went to find a higher up and left me on hold for 15 minutes.  This problem started 1/1/2017 and I have searched high and low in the 2017 program for something to switch or turn on to get my scheduled transactions to automatically enter into my registers and to allow me to select "scheduled bills and deposits" under "source for projected amount" in the Tax Planner.   This option remains grayed out.  AAAhhhh.  

    If you believe it is the program and not your data file, then creating a new data file and seeing what happens in it will tell you which it is.
  • Dave LynchDave Lynch Member
    edited January 11
    You're correct.  I set up a new test file with a checking account and  a scheduled paycheck with deductions and some  scheduled charitable deductions and scheduled mortgage payment with interest and all showed up in the tax planner including all future entries listed in red as they should be.  This all worked for my 2016 data with Quicken Premier 2016.  When I installed Premier 2017 in the fall of 2016 it still worked for the remainder of 2016.  As of 1/1/2017 none of my previous scheduled income or bill transactions are being entered or tracked by the tax planner and the option to include them remains grayed out.  Nothing else is changed.  I am still at a loss.  I tried deleting and re-entering a paycheck a couple days ago and still no help. 
  • QPWQPW Member ✭✭✭✭
    edited February 2017

    You're correct.  I set up a new test file with a checking account and  a scheduled paycheck with deductions and some  scheduled charitable deductions and scheduled mortgage payment with interest and all showed up in the tax planner including all future entries listed in red as they should be.  This all worked for my 2016 data with Quicken Premier 2016.  When I installed Premier 2017 in the fall of 2016 it still worked for the remainder of 2016.  As of 1/1/2017 none of my previous scheduled income or bill transactions are being entered or tracked by the tax planner and the option to include them remains grayed out.  Nothing else is changed.  I am still at a loss.  I tried deleting and re-entering a paycheck a couple days ago and still no help. 

    Well I don't really have any good suggestions on how to fix this.  I have seen some very strange behaviors from the Tax Planner over the years so I don't know what would trigger this.  There certainly isn't any kind of option.  I thought maybe at first it might be that you were using the project view or that it was because of selecting a year other than 2016.  But when I selected not to use projected, it doesn't show the details at all.  And when I selected 2016 it didn't have the problem you described.

    One thought is to see what it would be in Quicken 2016.  For the first time ever Quicken 2016 can read a Quicken 2017 data file.

    So you could uninstall Quicken 2017 and reinstall Quicken 2016 to see what it does.
    Another data point, I'm not sure it will help anything though.  But why you were there you could try validate and repair and then going back to Quicken 2017 if that makes any difference.
  • markus1957markus1957 SuperUser ✭✭✭✭✭
    edited February 2017

    You're correct.  I set up a new test file with a checking account and  a scheduled paycheck with deductions and some  scheduled charitable deductions and scheduled mortgage payment with interest and all showed up in the tax planner including all future entries listed in red as they should be.  This all worked for my 2016 data with Quicken Premier 2016.  When I installed Premier 2017 in the fall of 2016 it still worked for the remainder of 2016.  As of 1/1/2017 none of my previous scheduled income or bill transactions are being entered or tracked by the tax planner and the option to include them remains grayed out.  Nothing else is changed.  I am still at a loss.  I tried deleting and re-entering a paycheck a couple days ago and still no help. 

    Have you tried resetting to defaults in Tax Planner menu? Also, verify 2017 is selected in Planner rather than 2016. Did you perform a Quicken Copy via File>File Operations>Copy, prior to the validations? If not, that might help
  • Dave LynchDave Lynch Member
    edited February 2017
    I read that the planner uses some sort of hierarchy to determine where data comes from to make projections.  Maybe I just need to wait a while and see what happens.  I also am working on 2016 taxes with Turbo Tax and I am close to being finished.  I imported the tax file into quicken and now the planner is using more of the 2016 data from my tax file to make projections for 2017.  Maybe it's getting closer - seems to have a mind of it's own (or it is infected with Borg nanoprobes).   
  • mistertheplaguemistertheplague Member ✭✭
    edited January 11
    Well, I just got hit with this bug. QW17 R4. The option to use scheduled paycheck projections for federal and state withholding are now greyed out like the OP's file, the formerly apparent red transactions in Scheduled Bills and Deposits are missing, and the Tax Planner's average estimates are really wrong. This worked like it has for years last time I checked, which would have been a week ago.

    I performed a Quicken Copy via File>File Operations>Copy, validated, super-validated, reset to default, checked the year, used strong language: no joy.

    The workaround I employed for the time being was to calculate withholding and manually enter the amounts in the Tax Planner. Obviously this is no good if you have irregular pay periods and/or amounts.
  • markus1957markus1957 SuperUser ✭✭✭✭✭
    edited February 2017

    Well, I just got hit with this bug. QW17 R4. The option to use scheduled paycheck projections for federal and state withholding are now greyed out like the OP's file, the formerly apparent red transactions in Scheduled Bills and Deposits are missing, and the Tax Planner's average estimates are really wrong. This worked like it has for years last time I checked, which would have been a week ago.

    I performed a Quicken Copy via File>File Operations>Copy, validated, super-validated, reset to default, checked the year, used strong language: no joy.

    The workaround I employed for the time being was to calculate withholding and manually enter the amounts in the Tax Planner. Obviously this is no good if you have irregular pay periods and/or amounts.

    Have you verified that the Category assigned in the scheduled paycheck for federal withholding is associated with the tax line used in the Withholding section of tax planner? Once the paycheck is entered in the register, are the YTD tax withholdings appearing in Tax Planner?

    FYI, I entered a test paycheck via the wizard and all scheduled withholding entries showed up in tax planner as expected. As mentioned above, use a test file to determine if this is a software issue or a data file corruption issue. Not all data file corruption is repaired by the validation process. You could also test on a copy of your file by removing all scheduled transactions, close and open Quicken, then re-enter a paycheck to see if the scheduled transactions table is corrupted.
  • mistertheplaguemistertheplague Member ✭✭
    edited February 2017

    Well, I just got hit with this bug. QW17 R4. The option to use scheduled paycheck projections for federal and state withholding are now greyed out like the OP's file, the formerly apparent red transactions in Scheduled Bills and Deposits are missing, and the Tax Planner's average estimates are really wrong. This worked like it has for years last time I checked, which would have been a week ago.

    I performed a Quicken Copy via File>File Operations>Copy, validated, super-validated, reset to default, checked the year, used strong language: no joy.

    The workaround I employed for the time being was to calculate withholding and manually enter the amounts in the Tax Planner. Obviously this is no good if you have irregular pay periods and/or amounts.

    Fixed it. I went into the Edit Future Paycheck (series) screen, scrolled down to Taxes and discovered that all tax withholding categories were empty. I repopulated them as before, closed out the edit paycheck screen, returned to the Tax Planner and voila: all was well. The Tax Planner's withholding calculations based on scheduled transactions were available and the estimated amount was correct.

    As I said, this has worked correctly for years until a week ago. I'm diligent about setting up our paychecks and their various tax line items correctly. The only thing I can figure that happened was when I went in a week ago to change the Track Paycheck setting from a reminder to automatically enter, Quicken cleared the tax withholding categories, and when I changed it back, it didn't repopulate them. Weirdly, the pre-tax deduction field (FSAs, Medical Insurance) remained untouched.

    Anyway, thank you markus1957 for your help in this matter and for everything you've done to improve Quicken's Tax Planner. You're a bona fide asset to Quicken users.
Sign In or Register to comment.