Quicken for Mac 2017: Workaround for Transfers not Appearing in Reports (Includes New Loan Module)

Note: Mac user Snoopy FC deserves any and all credit for this workaround.

One potentially show-stopping limitation of QM17 is that transfers will not appear in reports or budgets. (I've never used budgets in Quicken Mac or Windows, so this workaround only addresses reports).

As a long-time user of Quicken for Windows -- in which most reports will register transfer transactions, even if they get stuck in a Transfer ghetto at the bottom of the report -- this limitation initially rendered QM17 unusable for me.

I returned the product, but repurchased it after learning the following workaround in the forum from Snoopy FC.

Be forewarned that this workaround will offend your sense of propriety: it's ugly, ridiculous, and requires double-entry (and even triple-entry for an escrow account). It will also clog up your Bill Reminders screen with scheduled transactions.

However, it's also clever and it works, so Snoopy FC deserves no less credit for having come up with it. I've updated it to show how it can work with the new loan module introduced in QM17 4.5x. 

So, here's the existential dilemma:

Although QM17 has the potentially exciting ability to categorize transfers, this ability doesn't seem to have any practical purpose (at least none that I could figure out), because if a transaction contains a transfer in either the category field or the transfer field (highlighted in screenshot below), that transaction is invisible to QM17's reports (and, I've gathered, budgets). 

image

The workaround, then, is to create a separate scheduled transaction for each account involved in any payment which includes a transfer. Here are the steps:

1. Create a scheduled transaction out of the cash account. The scheduled transaction is categorized only, with no transfers:

image

The transactions will then show up in your reports:

image
However, these transactions aren't linked to your transfer account, so the balance of that account will remain unaffected. So:

2. Create a separate scheduled transaction for the transfer amount out of your loan or escrow account. This transaction should have the same date as the first scheduled transaction out of the cash account. 

The new loan module adds a variable to all of this. Unfortunately, the new loan module doesn't rectify the transfers/reports-budgets limitation. The principal amount created by the wizard is strictly fixed as a transfer transaction, and isn't modifiable from within the wizard.

Here's the screen created in my Dummy Mortgage account by the new loan wizard, post-interview. Take note of the Principal amount, since we'll need it shortly:

image

Now we need to get the loan wizard off the field, where it can do no harm. So,

3. Turn off the loan wizard's Bill Reminder, because we're going to create our own:

image

Then click Save. (Okay, I forgot to add it to the screenshot. My four-year old was running around the house with a bunch of bananas on his head. I got distracted.)

4. Back in Bill Reminders, create a scheduled transaction out of your loan account (same date) with the transfer amount (in this case, Mortgage:Principal). Leave it uncategorized. 

Note: If you escrow your property taxes and HO insurance with your monthly mortgage payment, you'll need to create a scheduled transaction (or two, depending on how you have it whacked up) out of your Escrow account.

Here's our mortgage account post-scheduling:

 image

Notice the account balance lowers with each scheduled principal "transfer." Awesome, right? 

Wrong.

As soon as you mark a scheduled transaction as paid, QM will create an offsetting adjustment:

image

At this point a **** of profanity escaped my mouth. Then I had an idea (it does happen). And unlike most of them, it worked.

Just delete the adjustment, and you're golden:

image

Best part is (if such a thing can be said for this wretched process), the next time you mark a scheduled transaction as paid, QM will not throw up another adjustment. At least I think it won't.  

That's it. Note that you will have to manually adjust these amounts every month in their respective accounts.

Honestly, that doesn't faze me too much. I've tracked two mortgages in QW (manually, of course) and it was rare that I didn't have to go in every month or so and tweak the splits QW created for principal, interest, and even escrow.  

Time to eat those bananas, if any are left. Good night and good luck. 

Comments

  • Snoopy FCSnoopy FC Member
    edited May 2017
    Thanks for the update.  I've been wondering what to do with this under 4.5.2.  Look forward to trying this.  Really looking forward to Quicken fixing it so this ridiculous workaround isn't necessary.  
    QMac Subscription - iMac - Quicken Mac user since 1995
  • edited May 2017
    Snoopy FC said:

    Thanks for the update.  I've been wondering what to do with this under 4.5.2.  Look forward to trying this.  Really looking forward to Quicken fixing it so this ridiculous workaround isn't necessary.  

    Amen to that. And you're more than welcome ...
  • mshigginsmshiggins SuperUser
    edited May 2017
    Nice write up.
    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • edited May 2017
    mshiggins said:

    Nice write up.

    thx mshiggins!
  • seanjaySDseanjaySD Member
    edited January 2018
    If I read Quicken's mind correctly, I think that the reason they have "Transfers not Appearing in Reports" is that transfers themselves are inherently neither income nor expense items, just movement of cash between your accounts. With this in mind, I build my reports so that if I want to see a transfer (for example, mortgage payments), I leave the mortgage account out of the report. The report includes the bank account from which the mortgage payments are made, and since the mortgage account is not included in the report, the report shows the mortgage payments (transfers). 
  • John KeatingJohn Keating Member
    edited January 2
    I've also found that in QM19, items that are categorized as just "transfer" (i.e. with no associated transfer account) will appear as a total in the Category Summary report, under "Transfer".  And if they don't have a tag, they don't appear as transactions, only in the total. The problems with this are:
    1. Transfers should not appear in the Money In/Out sections of the report at all and shouldn't affect their totals. They should only appear in the report's Transfers ghetto at the bottom.
    2. If you don't include a tag on the transfer, there's no way to locate it in the ledger. You can't isolate them in a search, and you there's nothing to click-on in the Summary Report to take you there.
Sign In or Register to comment.