Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

QMac 2017: Locate transactions associated with a security

Dorothy H
Dorothy H Member ✭✭
edited October 2018 in Investing (Mac)
Using QM2017 - I would like to delete a security from security list.  When I try to delete, following message appears: "Unable to Delete Securities:  These securities are used by active transactions and cannot be removed."  I don't think this security is anywhere in my transactions.  Is there a report I can run to see if it is?  If the security is not in any transactions, is there a way to delete it?

Comments

  • RickO
    RickO SuperUser, Mac Beta Beta
    edited October 2018
    Click the Investing heading in the sidebar. Then click the Transactions tab and make sure all filters are reset/cleared. Then type the name (not symbol) of the security in the search box in the upper right. This should show you any transactions involving this security anywhere in the file.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • J_Mike
    J_Mike SuperUser ✭✭✭✭✭
    edited June 2017
    RickO said:

    Click the Investing heading in the sidebar. Then click the Transactions tab and make sure all filters are reset/cleared. Then type the name (not symbol) of the security in the search box in the upper right. This should show you any transactions involving this security anywhere in the file.

    Note that you will need to have all investment accounts visible - no Hidden investment accounts.
    QWin & QMac (Deluxe) Subscription
    Quicken user since 1991

  • Dorothy H
    Dorothy H Member ✭✭
    edited June 2017
    Thanks.  That way to search was new to me and an easy way to check all investment accounts in one fell swoop.  Confirmed that there are no instances of this security.  Is there a way to delete it from the security list even though I am getting the message about it being "in use" ? 
  • RickO
    RickO SuperUser, Mac Beta Beta
    edited June 2017
    Dorothy H said:

    Thanks.  That way to search was new to me and an easy way to check all investment accounts in one fell swoop.  Confirmed that there are no instances of this security.  Is there a way to delete it from the security list even though I am getting the message about it being "in use" ? 

    I don't know of any trick to force-delete a security.

    I would do the same check as above, but use the "All Transactions" register in case somehow the security is used in a non-investment transaction. And double check that you have unhidden ALL accounts beforehand (menu Accounts > Hide and Show Accounts).

    If that doesn't work, my only other thought is that you could merge the one you want to delete with another active security that you're keeping. This can be done in the Securities window.

    If you go this route... first make a COPY of your data file to work in. Turn off automatic quote download. Check the value of your investment accounts and net worth before doing anything. Check the quantity and value of the security you are going to merge into. (If quotes get updated, not that big a deal -- main thing is to check that the quantity of the resulting security remains correct.)

    Then merge the securities and edit the resulting one to have the correct name and symbol if they got changed. Then re-check the balances/quantities and make sure all is good. Only then, quit Quicken, delete the old file, and rename the copy back to the original file name.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • Concordman
    Concordman Mac Beta Beta
    edited November 2017
    This is a bug in QM I first observed this when I converted from QW13,to. QM 16. All I could do & what I advise is go thru each of these securities and disable quote downloads for these securities, if there was a method to hide the securities that would help. In general since QM has so many issues in the investment areas anything downloaded from QW as it relates to investment s is going to be an issue
This discussion has been closed.