Quicken Home and Business 2017 Occasionally my register has a math error.

Occasionally my register has a math error. The last entry will ADD instead of SUBTRACT the last entry or visa versa. Why is that? If I close my program and reopen it then the answer is correct. Messes up my end of the month reports........

Comments

  • NotACPANotACPA ✭✭✭✭✭ SuperUser ✭✭✭✭✭
    edited October 2018
    Sharon, the next time that this happens, it would help if you could provide a snapshot of the pertinent info.

    Without a whole lot more than you have provided, so far, it's about impossible to diagnose ... especially for those of us who haven't had such a problem ... and I'm running H&B2017 also.
    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • Sharon BannonSharon Bannon Member
    edited August 2017

    Sharon, the next time that this happens, it would help if you could provide a snapshot of the pertinent info.

    Without a whole lot more than you have provided, so far, it's about impossible to diagnose ... especially for those of us who haven't had such a problem ... and I'm running H&B2017 also.

    Here is the JPEG of the Math Error.
  • Sharon BannonSharon Bannon Member
    edited October 2018
    image
  • volvogirlvolvogirl ✭✭✭✭ SuperUser ✭✭✭✭
    edited August 2017

    image

    I remember a very long time ago there was a problem with it subtracting the amount from the line above again. See, it's not even the right amount but using the $97.00 again.
  • volvogirlvolvogirl ✭✭✭✭ SuperUser ✭✭✭✭
    edited August 2017

    image

    I wonder if the date in the future has anything to do with it?
  • Sharon BannonSharon Bannon Member
    edited August 2017

    image

    You are correct about the figure that is being subtracted/added. It is the previous figure.....hummmmm.  And it is a future date that is usually involved.
  • NotACPANotACPA ✭✭✭✭✭ SuperUser ✭✭✭✭✭
    edited August 2017

    image

    Have you tried validating your Q data file?  It's a 2 step process:
    1) FILE, File Operations, Copy.  Leave all of the default settings alone.  THEN, using the copy
    2) FILE, File Operations, Validate and Repair ... being SURE to check both "Validate file" and "Rebuild Investing Lots" before you click OK.
    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • Sharon BannonSharon Bannon Member
    edited August 2017

    image

    I did the validation steps with the tech the other day. No change in the problem though. 
  • UKRUKR ✭✭✭✭✭ SuperUser ✭✭✭✭✭
    edited October 2018

    I'm on Q 2017 R6, too and I can confirm that there's a definite bug in the Register Report (CTRL-P from the account register).

    After the first future - dated transaction, the math is off. And, in my test, a transaction dated in the year 2009 appeared in the middle of all the future - dated 2017 transactions.

  • NotACPANotACPA ✭✭✭✭✭ SuperUser ✭✭✭✭✭
    edited August 2017
    UKR said:

    I'm on Q 2017 R6, too and I can confirm that there's a definite bug in the Register Report (CTRL-P from the account register).

    After the first future - dated transaction, the math is off. And, in my test, a transaction dated in the year 2009 appeared in the middle of all the future - dated 2017 transactions.

    There's more to this puzzle than a bug ... because I'm not exhibiting such a bug, when using CTRL-P in a recently opened credit card account into which I've input a fictional future dated payment.
    image

    What's also odd is that my actual account register shows "Charge" and "Payment" columns ... yet this Print Register converted them to an "Amount" column.

    And, why does Sharon's report show the funky line wrap?  Even when I shrink my paper size down to 3.5 wide (portrait mode), it doesn't do a line wrap.
    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • UKRUKR ✭✭✭✭✭ SuperUser ✭✭✭✭✭
    edited August 2017
    UKR said:

    I'm on Q 2017 R6, too and I can confirm that there's a definite bug in the Register Report (CTRL-P from the account register).

    After the first future - dated transaction, the math is off. And, in my test, a transaction dated in the year 2009 appeared in the middle of all the future - dated 2017 transactions.

    The problem appears to occur when your future - dated transactions contain a mix of already entered register transactions and scheduled reminder transactions that have not been turned into "real" register transactions yet.
    At that point in time, the report generator loses its marbles and lists bogus transactions instead of the reminder transactions that should be there.
    Because an incorrect transaction is listed, the running balance appears to be incorrect, but it is in fact taken from the real register running balance where it is correct.

    NotACPA,
    I keep forgetting ... what Q version are you running? I'm on 2017 R6.

    "Funky line wrap" ... Sharon redacted Payee Names and apparently other details by whitening them out, hence the "funky wrap" appearance.

    I've tried to run this problem report "up the chain" to the programmers. Let's see what happens.
    {Superusers, Moderators: please see my bug report in the Lounge.}

This discussion has been closed.