Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

After installing the Mac version 5.5.3, you can no longer specify what lots to sell in the investmen

Unknown
Unknown Member
edited February 2018 in Investing (Mac)
MAC 2018 version 5.5.3 - Unable to specify tax lots of investment transaction stock sales.

Comments

  • John_in_NC
    John_in_NC SuperUser, Mac Beta Beta
    edited February 2018
    What is preventing you from doing such? I can still enter a Sell transaction, the security, and then specify lots.
  • Unknown
    Unknown Member
    edited February 2018
    If you have installed the 5.5.3 update, then not all of the available lots show up on the list so that you can’t pick and choose.



    Again, this was working until the most recent update was installed
  • John_in_NC
    John_in_NC SuperUser, Mac Beta Beta
    edited February 2018

    If you have installed the 5.5.3 update, then not all of the available lots show up on the list so that you can’t pick and choose.



    Again, this was working until the most recent update was installed

    I am not seeing this issue.

    You can submit this as a problem to the developers via Help:Report a Problem
  • Unknown
    Unknown Member
    edited February 2018

    If you have installed the 5.5.3 update, then not all of the available lots show up on the list so that you can’t pick and choose.



    Again, this was working until the most recent update was installed

    Thank you. It has been submitted.
  • Quicken Marcus
    Quicken Marcus Administrator, Employee ✭✭✭✭
    edited February 2018

    If you have installed the 5.5.3 update, then not all of the available lots show up on the list so that you can’t pick and choose.



    Again, this was working until the most recent update was installed

    William, can you look at your account to help us better understand what is going on.  It sounds like you don't see the corresponding buys in the explicit lot assignment dialog but can you see the transactions that relate to each of the buys in the investment account register or did they disappear as well?  Is this a connected account?  Do you see the lots correctly in the portfolio view?  As you can tell by the response, it doesn't sound like this is a widespread issue but something specific to your data so we're going to need more detailed information to figure out the issue and fix.  
  • Unknown
    Unknown Member
    edited February 2018

    If you have installed the 5.5.3 update, then not all of the available lots show up on the list so that you can’t pick and choose.



    Again, this was working until the most recent update was installed

    Thank you for your response.  

    In my portfolio view (As of 1/31/2018), I show 25 shares of the stock that I am having trouble with).  Those shares were purchased in 5 blocks as follows:

    10/11/17 2 shares
    9/22/17 10 shares
    9/11/17 7 shares
    4/17/17 3 Shares
    10/25/16  3 Shares

    These blocks were based on Quicken using a FIFO method.  However, my brokerage statement used a specific lot allocation rather than FIFO.  So on my brokerage account the dates and shares are as follows:

    9/22/17 9 shares
    9/11/17 7 shares
    4/17/17 6 shares
    10/25/16 3 shares

    I had a sell transaction on 8/9/17 for 9 shares that were allocated by quicken as follows

    shares purchased 10/7/16 - 4
    Shares purchased 10/4/16 - 5

    This transaction is ok with me since I don't own either of these blocks of shares as of 1/31/18.

    I had an additional sell transaction on 12/12/17  for 6 shares that were allocated by quicken as follows

    10/11/16 - 5 shares
    10/7/16 for - 1 share

    Again, this is not an issue for me, but please note that when I click on specify lots, the only lots that show up on the screen are the two lots to which shares were allocated as shown above.  There is no option to allocate those shares to any other lots that I had purchased.  So I cannot see in the dialogue box the 10/25/16 block, the 10/11/17 block, the 9/22/17, 9/11/17 or the 4/17/17 do not show up even though I still would have owned those shares on 12/12/17.

    My next sell transaction was dated 1/12/18 for 11 shares. Quicken allocated that sale to the following:

    3/10/17 - 8 shares
    4/17/17 - 3 shares

    This is where I have a problem, because I don't want to sell the 4/17/17 shares, but I cannot see any other options when I click on the specify lots button.  The in open dialogue only shows the 3/10 and 4/17 blocks, but does not show the 10/26/16 block or either of the September blocks.  Therefore, I cannot change the allocation.

    My next sale transaction was on 2/7/18 for 14 shares.  Quicken allocated as follows:

    10/25/16 - 3 shares
    4/17/17 - 3 shares
    9/11/17 - 7 shares
    9/22/17 - 1 Share

    So I wanted to sell 6 4/17/17 shares instead of 3, but only 3 show up in the dialogue box due to the allocation that was done by quicken on the 1/12/18 sell transaction. In addition, I wanted to sell 2 of the 10/11/17 shares and one of the 9/22/17 shares so that my records agree with brokerage statement.

    Now that I have walked through this, I see what the problem is.  Since there were sale transactions after 1/31/18 where quicken had allocated to lots based on FIFO, those blocks of shares were no longer able to be allocated in my January sale transaction.  So to fix this in my system, I had to delete the sale transaction on 2/7/18, then go back to the sale transaction on 1/12/18.  when I did this and clicked not the specify lots button, the blocks were then visible to do the allocation.  After allocating the way I wanted, I went in and manually reentered the Sale transaction on 2/7/18.  So I guess the system works, but it would be great if the available lots would show up based on the date of sale so that you would not need to manually delete and reenter a later transaction.

    Hope this helps.  
  • Quicken Marcus
    Quicken Marcus Administrator, Employee ✭✭✭✭
    edited February 2018

    If you have installed the 5.5.3 update, then not all of the available lots show up on the list so that you can’t pick and choose.



    Again, this was working until the most recent update was installed

    This is perfect.  Thanks.  I'll try to recreate your lots and see what I get.
  • Quicken Marcus
    Quicken Marcus Administrator, Employee ✭✭✭✭
    edited February 2018

    If you have installed the 5.5.3 update, then not all of the available lots show up on the list so that you can’t pick and choose.



    Again, this was working until the most recent update was installed

    Thanks.  I'm seeing some issues too.  We'll get this fixed.
  • Quicken Marcus
    Quicken Marcus Administrator, Employee ✭✭✭✭
    edited February 2018

    If you have installed the 5.5.3 update, then not all of the available lots show up on the list so that you can’t pick and choose.



    Again, this was working until the most recent update was installed

    As I play with this more, I'm seeing strange behavior when the share balance goes negative in a future transaction.  The future transaction appears to impact the explicit lot assignment of a previous sale.  The first thing to try is to turn on the Share Balance column in the transaction view by clicking on the Columns button on the bottom toolbar.  Then search for just the payee you describe above so then you'll just be looking at the transactions for this one security.  When I enter in your transactions, I get a -1 share balance with the sale on 1/12/18.  You had 10 shares after you sold 6 on 12/12/17.  Selling 11 on 1/12/18 gives you a negative -1 balance.  If I delete the sale of 11 shares, the sale on 12/12/17 appears to work properly.  When I add back the sale transaction on 1/12, I only see 1 lot appear.  Previously, I saw 2. I'm guessing your example above might be missing some shares or I'm misunderstanding the sequence. Can you give this a try and let us know what you find out.  Also, why do you have a negative share balance?  Are you doing short sales or did I just get my math wrong?
  • Unknown
    Unknown Member
    edited February 2018

    If you have installed the 5.5.3 update, then not all of the available lots show up on the list so that you can’t pick and choose.



    Again, this was working until the most recent update was installed

    Mine does not go negative.  I am afraid I did not give you all the info you needed.  My buy transactions were as follows

    10/4/16 - 5 shares
    10/7/16 -5 shares (10 cumulative)
    10/11/16 - 5 shares (15 cumulative)
    10/25/16 - 3 shares (18 cumulative)
    3/10/17 - 8 shares (26)
    4/17/17 6 shares (32)
    8/9/17 sell 9 shares (23)
    9/11/17 buy 7 (30)
    9/22/17 buy 10 (40)
    10/11/17 buy 2 (42)
    12/12/17 sell 6 (36)
    1/12/18 sell 11 (25)
    2/7/18 sell 14 (11)
    2/8/18 sell 11 (0)
    So you can see that at the end, there are zero shares remaining.  It never goes negative.  So what happens in the system, is the blocks are allocated based on the default of FIFO.  But after the two sales in February 2018, I cannot go back and change the lot assignments in the 1/12/18 sales without first deleting the 27/18 and the 2/8/18.  If I delete those, then change the lot assignment in the 1/12/18 transaction then manually re-enter the February sales, I can achieve the desired result.

    So I don't know if there is a way to allow the system to re-allocate the lots based on the date of the sale transaction followed by using the default method for the sales at a later date.  Does that make sense
Sign In or Register to comment.