Extremely Slow One Step Update: may be related to "Updating financial institution information..." of

QW H&B 2016 under Windows 10:

When I do a One Step Update (total of 34 logins), it can take MANY HOURS or even ALL DAY (ans OVERNIGHT)!.  It usually completes eventually.  Watching the OSU Progress window, it seems like the problem may be in "Updating financial institution information...".  Each login takes a long time in this state, then a somewhat shorter time in "Sending Online Instructions...", then finishes updating reasonably quickly.

When I do an update of an individual account (as opposed to OSU on all accounts), each account updates quickly!

Most of my accounts are Direct Connect (including the ones that seem to take the longest in "Updating financial institution information..." state).  A few are Express Web Connect. and seem to process much more quickly..

I've tried file validation and code re-installation numerous times.  My network is reliable and the bandwidth is >100Mbps.  I suspect the problem is in the server(s).

Please FIX!

By the way, why isn't the information for all financial institutions updated at one time?  Why do each separately?

Comments

  • mshigginsmshiggins SuperUser ✭✭✭✭✭
    edited August 2018
    Are you only downloading transactions during OSU or are you doing other tasks, like downloading quotes or syncing to mobile?
    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • Rick GumpertzRick Gumpertz Member
    edited August 2018
    No syncs.  Tranaction Download is definitely the bottleneck, most probably in the :Updating financial institution information,,," state, followed to a lesser extent by "Sending Online Instructions...".

    The only other thing I do in my OSU is download Quotes and Investment Information and download Currency Exchange Rates.  These two seem to be completed last and take next to no time at all.
  • UKRUKR SuperUser ✭✭✭✭✭
    edited September 2018
    How is your computer connected to the Internet? Ethernet cable to your home router? Or WiFi to your home router?
    If Ethernet cable, is your WiFi also enabled? If yes, try disabling WiFi so everything goes via Ethernet cable only.
    If WiFi only, is it possible that you have a weak or overloaded WiFi connection causing data packet losses or collisions?
    Is somebody else hogging your home router with video or game streaming?

    What time of day do you usually run OSU? Can you try at a different time of day?
  • SherlockSherlock SuperUser ✭✭✭✭✭
    edited October 2018
    If you haven't already, I suggest you enter ipconfig /flushdns in a command prompt window to clear the DNS cache.
    Quicken user since 1997 
    Premier on Windows 7 
  • Rick GumpertzRick Gumpertz Member
    edited January 11
    My computer is hardwired to my router and cable modem.  WiFi is disabled.  Speedtest.net test show 95ms Ping, 355.55Mbps download, and 23.06Mbps upload.  All Internet interactions other than Quicken OSU run fine.  No, the issue is not sharing bandwidth.

    By the way, slow OSU also arises with (fast) Wifi aenabled and no wired internet connected.

    Again, "Updating financial institution information,,," state followed to a
    lesser extent by "Sending Online Instructions..." seem to be the bottleneck.  The remaining states seem to run quickly.

    Updating a single FI (using Update Now in an account) also seems to run quickly.

    I tried ipconfig /displaydns and it looked reasonable.  I also tried ipconfig /flushdns as you suggested.  No improvement.

    I have noticed some variation according to time of day, but have detected no particular pattern.  I usually start a routine OSU around either between 04:00 and 10:00 Pacific Time.


  • SherlockSherlock SuperUser ✭✭✭✭✭
    edited August 2018

    My computer is hardwired to my router and cable modem.  WiFi is disabled.  Speedtest.net test show 95ms Ping, 355.55Mbps download, and 23.06Mbps upload.  All Internet interactions other than Quicken OSU run fine.  No, the issue is not sharing bandwidth.

    By the way, slow OSU also arises with (fast) Wifi aenabled and no wired internet connected.

    Again, "Updating financial institution information,,," state followed to a
    lesser extent by "Sending Online Instructions..." seem to be the bottleneck.  The remaining states seem to run quickly.

    Updating a single FI (using Update Now in an account) also seems to run quickly.

    I tried ipconfig /displaydns and it looked reasonable.  I also tried ipconfig /flushdns as you suggested.  No improvement.

    I have noticed some variation according to time of day, but have detected no particular pattern.  I usually start a routine OSU around either between 04:00 and 10:00 Pacific Time.


    As the individual updates appear fast, you might try unchecking financial institutions on the One Step Update Settings window to see if you can determine which financial institution's server(s) may be having issues.
    Quicken user since 1997 
    Premier on Windows 7 
  • markus1957markus1957 SuperUser ✭✭✭✭✭
    edited August 2018

    My computer is hardwired to my router and cable modem.  WiFi is disabled.  Speedtest.net test show 95ms Ping, 355.55Mbps download, and 23.06Mbps upload.  All Internet interactions other than Quicken OSU run fine.  No, the issue is not sharing bandwidth.

    By the way, slow OSU also arises with (fast) Wifi aenabled and no wired internet connected.

    Again, "Updating financial institution information,,," state followed to a
    lesser extent by "Sending Online Instructions..." seem to be the bottleneck.  The remaining states seem to run quickly.

    Updating a single FI (using Update Now in an account) also seems to run quickly.

    I tried ipconfig /displaydns and it looked reasonable.  I also tried ipconfig /flushdns as you suggested.  No improvement.

    I have noticed some variation according to time of day, but have detected no particular pattern.  I usually start a routine OSU around either between 04:00 and 10:00 Pacific Time.


    Your Connection and OFX logs timestamp the interaction with every server during OSU. You should review those to look for a problem server relative to the send/receive time gap. Optimal connections have responses measured in seconds or fractions of a second.

    Windows Resource Monitor, Network tab will show open/recent Quicken connections and whether they are actively sending/receiving and at what data rate.  You might be able to discern whether the connections are slow or in a long wait period. The sever ID's will also be shown.

    A long while back, there was a problem with a server sending an FI update file at a very slow data rate; measured in several minutes rather than hours though.

    Adding- 95ms latency, if consistent is on the almost terrible side for that speed class.
  • Rick GumpertzRick Gumpertz Member
    edited August 2018

    My computer is hardwired to my router and cable modem.  WiFi is disabled.  Speedtest.net test show 95ms Ping, 355.55Mbps download, and 23.06Mbps upload.  All Internet interactions other than Quicken OSU run fine.  No, the issue is not sharing bandwidth.

    By the way, slow OSU also arises with (fast) Wifi aenabled and no wired internet connected.

    Again, "Updating financial institution information,,," state followed to a
    lesser extent by "Sending Online Instructions..." seem to be the bottleneck.  The remaining states seem to run quickly.

    Updating a single FI (using Update Now in an account) also seems to run quickly.

    I tried ipconfig /displaydns and it looked reasonable.  I also tried ipconfig /flushdns as you suggested.  No improvement.

    I have noticed some variation according to time of day, but have detected no particular pattern.  I usually start a routine OSU around either between 04:00 and 10:00 Pacific Time.


    Typo.  That was supposed to be 15ms.
  • markus1957markus1957 SuperUser ✭✭✭✭✭
    edited August 2018

    My computer is hardwired to my router and cable modem.  WiFi is disabled.  Speedtest.net test show 95ms Ping, 355.55Mbps download, and 23.06Mbps upload.  All Internet interactions other than Quicken OSU run fine.  No, the issue is not sharing bandwidth.

    By the way, slow OSU also arises with (fast) Wifi aenabled and no wired internet connected.

    Again, "Updating financial institution information,,," state followed to a
    lesser extent by "Sending Online Instructions..." seem to be the bottleneck.  The remaining states seem to run quickly.

    Updating a single FI (using Update Now in an account) also seems to run quickly.

    I tried ipconfig /displaydns and it looked reasonable.  I also tried ipconfig /flushdns as you suggested.  No improvement.

    I have noticed some variation according to time of day, but have detected no particular pattern.  I usually start a routine OSU around either between 04:00 and 10:00 Pacific Time.


    It's back to the logs then. Yours's is a unique case. 
  • Rick GumpertzRick Gumpertz Member
    edited August 2018

    My computer is hardwired to my router and cable modem.  WiFi is disabled.  Speedtest.net test show 95ms Ping, 355.55Mbps download, and 23.06Mbps upload.  All Internet interactions other than Quicken OSU run fine.  No, the issue is not sharing bandwidth.

    By the way, slow OSU also arises with (fast) Wifi aenabled and no wired internet connected.

    Again, "Updating financial institution information,,," state followed to a
    lesser extent by "Sending Online Instructions..." seem to be the bottleneck.  The remaining states seem to run quickly.

    Updating a single FI (using Update Now in an account) also seems to run quickly.

    I tried ipconfig /displaydns and it looked reasonable.  I also tried ipconfig /flushdns as you suggested.  No improvement.

    I have noticed some variation according to time of day, but have detected no particular pattern.  I usually start a routine OSU around either between 04:00 and 10:00 Pacific Time.


    You said "A long while back, there was a problem with a server sending an FI
    update file at a very slow data rate; measured in several minutes rather
    than hours though."

    Please tell me more about this.  Remember that I am still using QW H&B 2016.

    I'm working my way through the logs to figure out what they mean...
  • markus1957markus1957 SuperUser ✭✭✭✭✭
    edited August 2018

    My computer is hardwired to my router and cable modem.  WiFi is disabled.  Speedtest.net test show 95ms Ping, 355.55Mbps download, and 23.06Mbps upload.  All Internet interactions other than Quicken OSU run fine.  No, the issue is not sharing bandwidth.

    By the way, slow OSU also arises with (fast) Wifi aenabled and no wired internet connected.

    Again, "Updating financial institution information,,," state followed to a
    lesser extent by "Sending Online Instructions..." seem to be the bottleneck.  The remaining states seem to run quickly.

    Updating a single FI (using Update Now in an account) also seems to run quickly.

    I tried ipconfig /displaydns and it looked reasonable.  I also tried ipconfig /flushdns as you suggested.  No improvement.

    I have noticed some variation according to time of day, but have detected no particular pattern.  I usually start a routine OSU around either between 04:00 and 10:00 Pacific Time.


    Fidir.txt and FIBlueprint.xml get updated periodically. The file update was being transmitted at a very low bit rate. It's a once every few days event so not likely tied to your problem.

    But reading your other post with 3477 memorized payees got me thinking maybe Quicken is choking on that list for each transaction being downloaded.
  • QPWQPW Member ✭✭✭✭
    edited August 2018

    My computer is hardwired to my router and cable modem.  WiFi is disabled.  Speedtest.net test show 95ms Ping, 355.55Mbps download, and 23.06Mbps upload.  All Internet interactions other than Quicken OSU run fine.  No, the issue is not sharing bandwidth.

    By the way, slow OSU also arises with (fast) Wifi aenabled and no wired internet connected.

    Again, "Updating financial institution information,,," state followed to a
    lesser extent by "Sending Online Instructions..." seem to be the bottleneck.  The remaining states seem to run quickly.

    Updating a single FI (using Update Now in an account) also seems to run quickly.

    I tried ipconfig /displaydns and it looked reasonable.  I also tried ipconfig /flushdns as you suggested.  No improvement.

    I have noticed some variation according to time of day, but have detected no particular pattern.  I usually start a routine OSU around either between 04:00 and 10:00 Pacific Time.


    Note I first read about the problem in Rick's other thread where he posted some connection logs, which shows extremely slow network performance.
    https://getsatisfaction.com/quickencommunity/topics/mouse-click-ahead?topic-reply-list[settings][filter_by]=all&topic-reply-list[settings][reply_id]=19704574#reply_19704574

    In that case just fetching a very simple INI file took 33 seconds.

    And given the added information about Rick's network speed in this thread, I'm guessing that the test I suggest of pulling up that URL will result in it coming up in a blink of an eye.

    Which if that is true, then I would start looking at your anti-virus program getting in the way of Quicken accessing the Internet (just a guess).
  • Rick GumpertzRick Gumpertz Member
    edited August 2018

    My computer is hardwired to my router and cable modem.  WiFi is disabled.  Speedtest.net test show 95ms Ping, 355.55Mbps download, and 23.06Mbps upload.  All Internet interactions other than Quicken OSU run fine.  No, the issue is not sharing bandwidth.

    By the way, slow OSU also arises with (fast) Wifi aenabled and no wired internet connected.

    Again, "Updating financial institution information,,," state followed to a
    lesser extent by "Sending Online Instructions..." seem to be the bottleneck.  The remaining states seem to run quickly.

    Updating a single FI (using Update Now in an account) also seems to run quickly.

    I tried ipconfig /displaydns and it looked reasonable.  I also tried ipconfig /flushdns as you suggested.  No improvement.

    I have noticed some variation according to time of day, but have detected no particular pattern.  I usually start a routine OSU around either between 04:00 and 10:00 Pacific Time.


    I tried turned off my firewall; no improvement.  Also, why would the firewall treat Quicken differently than a browser?
  • Rick GumpertzRick Gumpertz Member
    edited August 2018

    My computer is hardwired to my router and cable modem.  WiFi is disabled.  Speedtest.net test show 95ms Ping, 355.55Mbps download, and 23.06Mbps upload.  All Internet interactions other than Quicken OSU run fine.  No, the issue is not sharing bandwidth.

    By the way, slow OSU also arises with (fast) Wifi aenabled and no wired internet connected.

    Again, "Updating financial institution information,,," state followed to a
    lesser extent by "Sending Online Instructions..." seem to be the bottleneck.  The remaining states seem to run quickly.

    Updating a single FI (using Update Now in an account) also seems to run quickly.

    I tried ipconfig /displaydns and it looked reasonable.  I also tried ipconfig /flushdns as you suggested.  No improvement.

    I have noticed some variation according to time of day, but have detected no particular pattern.  I usually start a routine OSU around either between 04:00 and 10:00 Pacific Time.


    I would love to reduce the memorized payments (I know a bunch to delete) but as reported in a different thread, my MPL is displaying empty.  Sigh.
  • QPWQPW Member ✭✭✭✭
    edited August 2018

    My computer is hardwired to my router and cable modem.  WiFi is disabled.  Speedtest.net test show 95ms Ping, 355.55Mbps download, and 23.06Mbps upload.  All Internet interactions other than Quicken OSU run fine.  No, the issue is not sharing bandwidth.

    By the way, slow OSU also arises with (fast) Wifi aenabled and no wired internet connected.

    Again, "Updating financial institution information,,," state followed to a
    lesser extent by "Sending Online Instructions..." seem to be the bottleneck.  The remaining states seem to run quickly.

    Updating a single FI (using Update Now in an account) also seems to run quickly.

    I tried ipconfig /displaydns and it looked reasonable.  I also tried ipconfig /flushdns as you suggested.  No improvement.

    I have noticed some variation according to time of day, but have detected no particular pattern.  I usually start a routine OSU around either between 04:00 and 10:00 Pacific Time.


    I didn't say "firewall" I said anti-virus. Anti-virus software looks at all the reads and writes programs make to make sure they aren't "doing bad things".  That can sometimes get in the way of a program doing its job.  Anything from slowing it down, to not working at all.

    As for the memorized payees, I have posted a suggestion in one of your other threads.  I'm sure you will see that soon.
  • Rick GumpertzRick Gumpertz Member
    edited August 2018

    My computer is hardwired to my router and cable modem.  WiFi is disabled.  Speedtest.net test show 95ms Ping, 355.55Mbps download, and 23.06Mbps upload.  All Internet interactions other than Quicken OSU run fine.  No, the issue is not sharing bandwidth.

    By the way, slow OSU also arises with (fast) Wifi aenabled and no wired internet connected.

    Again, "Updating financial institution information,,," state followed to a
    lesser extent by "Sending Online Instructions..." seem to be the bottleneck.  The remaining states seem to run quickly.

    Updating a single FI (using Update Now in an account) also seems to run quickly.

    I tried ipconfig /displaydns and it looked reasonable.  I also tried ipconfig /flushdns as you suggested.  No improvement.

    I have noticed some variation according to time of day, but have detected no particular pattern.  I usually start a routine OSU around either between 04:00 and 10:00 Pacific Time.


    I did a lot of OSU downloads last night with various combinations of enabling and disabling Firewall and Anti-Virus.  Neither affected my OSU times significantly.

This discussion has been closed.