Can't delete a blank transaction from register

I am using Quicken Premier 2017.  While entering transactions (manually) a blank transaction appeared with no date or data.  The transaction line is white and it won't delete.  I tried to use the transaction and put data in it, but it won't save the transaction.  It just goes back to the date.  When I leave the transaction a message appears that says, "You have changed the transaction. Save it now?" If I say yes, it just goes back to the transaction date.  If I say cancel, the transaction I entered disappears.  The line turns white, and it goes to the next blue shaded line (where I enter the transactions.)

I don't know if my file is corrupted or what is going on.  

Has anyone else had this problem and if you did, what did you do about it?
 
Thanks
Judy

Comments

  • NotACPANotACPA SuperUser ✭✭✭✭
    edited October 2018
    Is this transaction at the very bottom of your Account Register?  If so, it's intended to be there ... it's where you can manually input your next transaction.

    And, have you tried selecting this "phantom" transaction, RIGHT-clicking it, and clicking Delete?
    Q user since DOS version 5
    Now running Quicken Windows Subscription
    Retired "Certified Information Systems Auditor"
  • Rick GumpertzRick Gumpertz Member
    edited October 2018
    I have the same problem in ONE account register only.  The extra transaction is indeed at the bottom BUT there is another blank transaction below (that can be used for entering new transactions).  Other than being visually annoying, I have yet to find any real harm being done by the spurious transaction.
  • UKRUKR SuperUser ✭✭✭✭
    edited October 2018

    I have the same problem in ONE account register only.  The extra transaction is indeed at the bottom BUT there is another blank transaction below (that can be used for entering new transactions).  Other than being visually annoying, I have yet to find any real harm being done by the spurious transaction.

    Rick,
    Is that a totally blank transaction or is there garbage in one of the fields?
    Can you edit this transaction and put some test data into it, e.g., a valid date?
    Have you tried right-click and delete this transaction?
    Have you tried the fine-tooth-comb Copy + Validate + Supervalidate procedure that I keep posting all the time?
  • Rick GumpertzRick Gumpertz Member
    edited October 2018

    I have the same problem in ONE account register only.  The extra transaction is indeed at the bottom BUT there is another blank transaction below (that can be used for entering new transactions).  Other than being visually annoying, I have yet to find any real harm being done by the spurious transaction.

    It appears to be totally blank (unless there are hidden fields I don't see)

    Here it is after I chose (using the calendar) 10/31/2018 as a date and entered a check number and a payee:  (Notice the bogus date)


    Here it is after I typed in a date and all other (visible) fields:


    Even after clicking the SAVE button, if I click on another transcation QWH&B 2016 asks me if I want to "Save transaction".  If I click Save, cursor moves to date field in the bogus transaction.  If I click Cancel, the blank transaction returns to totally blank:


    Right-Click Delete does nothing.  So does Right-Click Cut Transaction.

    The blank transaction below the messed up one works as normal for entering new transactions.
  • SherlockSherlock SuperUser ✭✭✭✭
    edited October 2018

    I have the same problem in ONE account register only.  The extra transaction is indeed at the bottom BUT there is another blank transaction below (that can be used for entering new transactions).  Other than being visually annoying, I have yet to find any real harm being done by the spurious transaction.

    Rick Gompertz: If you haven't already, you may want to review: https://www.quicken.com/support/advanced-data-file-troubleshooting-correct-problems-quicken-windows

    If the issue persists, I suggest creating a new account, moving the good transactions from the original account to the new account, reseting the appropriate reminders and memorized payees, and deleting the original account.
    Quicken user since 1997 
    Premier on Windows 7 
  • Judy LeoneJudy Leone Member
    edited October 2018

    I have the same problem in ONE account register only.  The extra transaction is indeed at the bottom BUT there is another blank transaction below (that can be used for entering new transactions).  Other than being visually annoying, I have yet to find any real harm being done by the spurious transaction.

    Rick this is the exact problem I had.  I found the solution.

    File
    File Operations
    Validate and Repair
    Select "Validate File" and press OK

    If you haven't done it before, it might take a while.

    Let me know if this helps.

    PS After i checked to make sure it worked I backed up my file.  You might want to do that as well.
  • Judy LeoneJudy Leone Member
    edited October 2018
    This is the solution that worked for me:

    File
    File Operations
    Validate and Repair
    Select "Validate File" and press OK

    If you haven't done it before, it might take a while.

    Good luck.
  • Judy LeoneJudy Leone Member
    edited October 2018

    Is this transaction at the very bottom of your Account Register?  If so, it's intended to be there ... it's where you can manually input your next transaction.

    And, have you tried selecting this "phantom" transaction, RIGHT-clicking it, and clicking Delete?

    I manually input transactions all the time.  This one was right above it. And nothing i did would enter a transaction into the fields or delete the transaction itself.  

    I posted a solution at the bottom.

    Thanks for your help!
  • edited January 22
    I had something similar where there a bunch of transactions that did not belong in one account with dates that did not sequence properly.   The transactions were entered on another account.    I ran a backup in prep for the solution that Judy posted.   After the backup, the register for the corrupted account appeared to be correct.
This discussion has been closed.