Quicken 2019 keeps crashing. File size is over 144M and the # of transactions is over 28k.

I need to find a way to reduce the file size, memorized transactions, etc so my file doesn't keep crashing.  it started in version 2014 and has been happening more frequently as the file gets bigger.

Comments

  • Matthew SinnoMatthew Sinno Member
    edited November 2018
    I have been using Quicken since 1994, and upgrade every other year.  there are a LOT of old information I'd love to archive and delete, but I don't know how.
  • Arctic Hare (H&B 2019 Canadian)Arctic Hare (H&B 2019 Canadian) SuperUser ✭✭✭
    edited December 2018
    @Matthew: to start with, when was the last time that you performed a validation on your data file (File-->File_Operations-->Validate_&_Repair)?
  • markus1957markus1957 SuperUser ✭✭✭✭✭
    edited January 11
    I've got more than 30K transactions in a 94Mb file so I don't think the number of transactions is an issue. Hold the Ctrl key while clicking Help>About Quicken to get the number of transactions, memorized payees, securities and internal file size. Report back with those numbers.

    Memorized payees can be deleted in bulk using the Shift key. Try deleting them all and then verify you have zero reported in About Quicken. Any left are an indication of memorized investment transactions which are a hidden table and now little used.

    If you aren't storing attachments, that is a larger file size than would be typical for 30K transactions. After cleaning up the tables, you might try the Copy/Validate process from this Quicken KB article https://www.quicken.com/support/advanced-data-file-troubleshooting-correct-problems-quicken-windows
  • Arctic Hare (H&B 2019 Canadian)Arctic Hare (H&B 2019 Canadian) SuperUser ✭✭✭
    edited November 2018

    I've got more than 30K transactions in a 94Mb file so I don't think the number of transactions is an issue. Hold the Ctrl key while clicking Help>About Quicken to get the number of transactions, memorized payees, securities and internal file size. Report back with those numbers.

    Memorized payees can be deleted in bulk using the Shift key. Try deleting them all and then verify you have zero reported in About Quicken. Any left are an indication of memorized investment transactions which are a hidden table and now little used.

    If you aren't storing attachments, that is a larger file size than would be typical for 30K transactions. After cleaning up the tables, you might try the Copy/Validate process from this Quicken KB article https://www.quicken.com/support/advanced-data-file-troubleshooting-correct-problems-quicken-windows

    With the current US release, some users are getting a File_NOT_Copied error when they attempt to use the File-->File_Operations_Copy function. That is why I hesitated to recommend the copy|validate iterative process.
  • Matthew SinnoMatthew Sinno Member
    edited November 2018

    @Matthew: to start with, when was the last time that you performed a validation on your data file (File-->File_Operations-->Validate_&_Repair)?

    Thank you for the advice.  I really don't know if I ever have.  I just did.  The validation found 5 errors (3 were corrected automatically. and 2 it is suggesting I delete the transactions and re-create them from scratch).  It also corrected 58 Stock share transactions from my 401k account.  How often should this be done?  Is this something that is only done after a crash?  Appreciate the help.
  • Matthew SinnoMatthew Sinno Member
    edited November 2018

    I've got more than 30K transactions in a 94Mb file so I don't think the number of transactions is an issue. Hold the Ctrl key while clicking Help>About Quicken to get the number of transactions, memorized payees, securities and internal file size. Report back with those numbers.

    Memorized payees can be deleted in bulk using the Shift key. Try deleting them all and then verify you have zero reported in About Quicken. Any left are an indication of memorized investment transactions which are a hidden table and now little used.

    If you aren't storing attachments, that is a larger file size than would be typical for 30K transactions. After cleaning up the tables, you might try the Copy/Validate process from this Quicken KB article https://www.quicken.com/support/advanced-data-file-troubleshooting-correct-problems-quicken-windows

    image
  • Matthew SinnoMatthew Sinno Member
    edited November 2018

    I've got more than 30K transactions in a 94Mb file so I don't think the number of transactions is an issue. Hold the Ctrl key while clicking Help>About Quicken to get the number of transactions, memorized payees, securities and internal file size. Report back with those numbers.

    Memorized payees can be deleted in bulk using the Shift key. Try deleting them all and then verify you have zero reported in About Quicken. Any left are an indication of memorized investment transactions which are a hidden table and now little used.

    If you aren't storing attachments, that is a larger file size than would be typical for 30K transactions. After cleaning up the tables, you might try the Copy/Validate process from this Quicken KB article https://www.quicken.com/support/advanced-data-file-troubleshooting-correct-problems-quicken-windows

    this is AFTER the file validation process step followed from the previous suggestion.
  • Arctic Hare (H&B 2019 Canadian)Arctic Hare (H&B 2019 Canadian) SuperUser ✭✭✭
    edited November 2018

    @Matthew: to start with, when was the last time that you performed a validation on your data file (File-->File_Operations-->Validate_&_Repair)?

    I suppose there are a range of opinions on how often one should run file validation. IMHO, it should be run frequently, e.g. monthly. I recommend recreating the transactions it is recommending. You should run validate with the rebuild investing lots option.
  • miklkmiklk SuperUser ✭✭✭✭✭
    edited November 2018
    You may want to try fixing the securities/Max ref pointers which seem out of whack

    https://getsatisfaction.com/quickencommunity/topics/what-is-securities-max-ref
  • Matthew SinnoMatthew Sinno Member
    edited November 2018
    miklk said:

    You may want to try fixing the securities/Max ref pointers which seem out of whack

    https://getsatisfaction.com/quickencommunity/topics/what-is-securities-max-ref

    image
  • Matthew SinnoMatthew Sinno Member
    edited November 2018
    miklk said:

    You may want to try fixing the securities/Max ref pointers which seem out of whack

    https://getsatisfaction.com/quickencommunity/topics/what-is-securities-max-ref

    I have cleaned up the Securities/Max ref using the previous recommendation.  This seemed to have cleaned up the securities and renumbered the number of total securities.  Thanks!!!
  • Matthew SinnoMatthew Sinno Member
    edited November 2018

    I've got more than 30K transactions in a 94Mb file so I don't think the number of transactions is an issue. Hold the Ctrl key while clicking Help>About Quicken to get the number of transactions, memorized payees, securities and internal file size. Report back with those numbers.

    Memorized payees can be deleted in bulk using the Shift key. Try deleting them all and then verify you have zero reported in About Quicken. Any left are an indication of memorized investment transactions which are a hidden table and now little used.

    If you aren't storing attachments, that is a larger file size than would be typical for 30K transactions. After cleaning up the tables, you might try the Copy/Validate process from this Quicken KB article https://www.quicken.com/support/advanced-data-file-troubleshooting-correct-problems-quicken-windows

    This seems to have also helped.  Thanks for helping out.
This discussion has been closed.