How can Quicken 2016 be corrected on startups to not ask "Select your existing data file to get star

Windows 8.1 
Quicken 2016 Home & Business Version R18.4  Build 25.1.18.4

After my computer has been shutdown or quicken 2016 has been exited,
when I initiate quicken start, the logo comes on and then goes to a
quicken screen that says "Select your existing data file to get started'
and then gives three options 1) Open a data  file on this computer, 2)
Restore a data file I've backed up to a CD, to a disk or to online,
& 3)  Start over & create a new data file. 

My data files location C:/users/frozenfire/documents/quicken/qdata1111.QDF

This started after I created a copy of my data file using File/File Operations/Copy File. I did this based on a Rocket J Squirrels suggestion below:

"The closest thing to a database
compact tool in Quicken is File > File Operations > Copy.


This operation lifts the data records out of the database and drops them into a
fresh new database. In the process, it leaves behind deleted items which can
accumulate because they are only marked deleted and not truly expunged. You
should end up with a copy which is somewhat smaller than the original. There is
no guarantee this will speed up your program close, but it's worth a try. Leave
all Copy settings at defaults." - Rocket J Squirrel

I gave the new copy a new name and I changed the name of the previous data file to qdata1111old.QDF

I then changed the new data file back to qdata1111.QDF

It seems that Quicken has forgotten where the data file is located and I have to choose the first option each time that I open Quicken.

Comments

  • Rich_MRich_M SuperUser
    edited January 22
    That is interesting.  I would check the list of recent file paths at the bottom of the File menu to see if your current file is listed first and what else is shown there for more clues.

    You may also want to try opening your data file by double-clicking it rather than launching Quicken first to see if that resolves the issue.
    Quicken 2017 Premier - Windows 10
  • AndrewAndrew Member
    edited December 2018
    Or create a link on your home screen that explicitly uses the file you wish (you can have multiples of those with different files). And click that to start Q. Or pin Q to the task bar (you can have multiple files that you can pull down to start which ever one you wish. I do that for my multiple Q files to select (I have 8 of them! ).
  • frozenfirefrozenfire Member
    edited December 2018
    @Rich M -  When I double click on the data file, Quicken opens asking for password, when I enter password, data file opens and everything is fine.  When I exit Quicken and then click on the Quicken icon on my desktop, I get the "Select your existing data file to get started" again.

    When I click on "File" menu,  I see my data file as the first option.  Below it are other data files.  When I open the other data files, enter the password, data file opens and when I close Quicken,  I get the same "Select your existing data file to get started".  It doesn't matter which data file that I open, I get the same result when trying to open Quicken with the desktop Quicken icon.

    I also did a restore backup file and I get the same results when trying to re-open Quicken.

    I will probably try to reinstall Quicken as my next step.

    On second thought, instead of attempting to uninstall and then reinstall Quicken, I will instead restore my computer to an image backup that I did on November 30, 2018. 
  • splashersplasher SuperUser ✭✭✭✭
    edited December 2018
    For some reason, it sounds like your QUSER.ini file is not being updated.  This is a hidden Windows file, so you will need to change your Windows hidden file settings to find it.

    That file can be found at :  C:\users\Windows username\AppData\Roaming\Quicken\Config

    Check to make sure that in the [RecentFiles] section that the correct file (with complete path) is in the #1 slot.  If it isn't, it sounds like the Windows account you are using doesn't have permissions to update that file.
    -splasher  using Q since 1996 -  QW2016, 2017 & Subscription  -  Win7/Win10
    -Questions? Check out the  Quicken Windows FAQ list

  • frozenfirefrozenfire Member
    edited December 2018
    @Splasher - Bingo!  That was it!

    A few months ago, I modified the QUSER.ini file to prevent Quicken from showing the Update Nag screen on startup.  I then made the file "Read Only" so Quicken could not change it.

    You saved me a lot of work.  Thanks!!!
  • splashersplasher SuperUser ✭✭✭✭
    edited December 2018

    @Splasher - Bingo!  That was it!

    A few months ago, I modified the QUSER.ini file to prevent Quicken from showing the Update Nag screen on startup.  I then made the file "Read Only" so Quicken could not change it.

    You saved me a lot of work.  Thanks!!!

    Glad to hear that mystery is solved.  Be sure to put this at the top of your troubleshooting list for next time.
    -splasher  using Q since 1996 -  QW2016, 2017 & Subscription  -  Win7/Win10
    -Questions? Check out the  Quicken Windows FAQ list

  • UKRUKR SuperUser ✭✭✭✭
    edited December 2018
    All users please note: Depending on your Quicken version, the file QUSER.INI can be either in
    • C:\users\username\AppData\Roaming\Quicken\Config
      or, for older versions, in
    • C:\users\username\AppData\Roaming\Intuit\Quicken\Config
This discussion has been closed.