Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

command J not working

Yesterday I used 'Command J' to write checks on my MacBook Pro.  Today it doesn't work. No 'check' appears.  The 'Transaction' button on the toolbar turns blue momentarily but that's it - nothing happens.  Need help to resolve.

Best Answer

  • Unknown
    Unknown Member
    edited December 2018 Accepted Answer
    Aha!!!!!!! I found that alongside ANY STATUS (a drop down menu) there resided a red X for 'clearing all filters'.  I don't have any idea where it came, being sick of spending a good part of the day working on the problem, I 'pressed' the button.  Suddenly COMMAND J works again.  In fact, I had to clear about 50 checks from the register showing no amounts (a result of pressing 'Write Check' over the course of working on the problem.) So, again, it's now working as it should.  Thanks for all of the suggestions.

Answers

  • Unknown
    Unknown Member
    edited December 2018
    I called Quicken support and explained the situation.  The fellow who I spoke with suggested that, rather than use the HOT keys as I had been using, I use the 'New' function and enter the information in order to write a check.  Yes, I can do this but addresses no longer auto fill and when I try to 'Print Checks' there're no check to print.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    edited December 2018
    Just for grins ... have you tried stopping and restarting Quicken? Have you tried rebooting your Mac after stopping Quicken?
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    edited December 2018
    Mark, first I'd do what @UKR suggests: reboot. Failure of a command key could be a macOS issue rather than a Quicken issue.

    If that doesn't work, could you verify whether the Write Check command on the Transactions menu still shows Command-J to the right of the text? If not, that suggests a possible macOS issue we could address separately.

    Also, you say that starting a New transaction doesn't have a check to print. You needs to enter PRINT in the Check Number field when you enter a transaction this way in order for Quicken to know there are checks to print.

    But instead of using New transaction, what if you select Write Check on the Transactions menu? This should do exactly the same think as Command-J: open a check image and let you fill it in (including autofilling address information). Does this work correctly? If so, and only the command-key shortcut works, you at least have a viable workaround of a menu command instead of a keyboard command to do what you need.

    If the keyboard command still isn't working, you can try to create it via macOS. the operating systems lets users define keyboard shortcuts for all or any applications, a cool trick may Mac users aren't aware of. And it's easy to do:
    • Open System Preferences under the Apple menu.
    • Click on Keyboard.
    • Click on the Shortcuts tab.
    • On the left side, click on App shortcuts.
    • On the right side, click the + icon.
    • In the drop-down pane, click on "All Applications" and select Quicken from the drop-down menu.
    • For Menu Title, type: Write Check (you must spell it and capitalize it exactly as it appears in the program's menu).
    • In the Keyboard shortcut field, type the shortcut you want, such as Command-J.
    • Click Add.

    You should see something like this:


    The should be it. Switch to Quicken and try it. If Command-J still doesn't work, go back to System Preferences and try changing it to something else, like Command-Shift-J or any other keyboard command which isn't currently used in Quicken.

    Post back here if you're still having problems.


    Quicken Mac Subscription • Quicken user since 1993
  • Unknown
    Unknown Member
    edited December 2018
    UKR said:

    Just for grins ... have you tried stopping and restarting Quicken? Have you tried rebooting your Mac after stopping Quicken?

    Yes, I've done both numerous times.
  • Unknown
    Unknown Member
    edited December 2018
    Thanks for tip.  I've done what you've said and used shift - command - J and it has no effect on Quicken.  It's interesting to note that command N does work but command J does not work. 
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    edited December 2018
    Make sure you entered “Write Check” exactly as it appears on the menu. I can’t imagine a new command key like Command-Shift-J not working, as it’s controlled by macOS.



    Let’s step back a second. Have you tried selecting Write Check from the Transactions menu? Does it work as expected, or does it not work? Perhaps we are chasing the wrong problem...
    Quicken Mac Subscription • Quicken user since 1993
  • Unknown
    Unknown Member
    edited December 2018
    Yes, I tried that initially and found that when that method was attempted it didn't work either.  What does work is this: 'COMMAND N' brings down a new transaction.  From there I can go to 'EDIT DETAILS' and then click on 'CHECKS' and a check appears that I can fill in and 'write'.  Another problem then occurs which is that the auto-fill for the address (for a check that I'd written numerous times before) doesn't auto-fill any longer.  So the short of it is that I can still write checks today but it certainly is a lot more difficult than it was yesterday.

  • jacobs
    jacobs SuperUser, Mac Beta Beta
    edited December 2018

    Yes, I tried that initially and found that when that method was attempted it didn't work either.  What does work is this: 'COMMAND N' brings down a new transaction.  From there I can go to 'EDIT DETAILS' and then click on 'CHECKS' and a check appears that I can fill in and 'write'.  Another problem then occurs which is that the auto-fill for the address (for a check that I'd written numerous times before) doesn't auto-fill any longer.  So the short of it is that I can still write checks today but it certainly is a lot more difficult than it was yesterday.

    Yes, I understand Command-N works. That's simply the shortcut for a new transaction, check or otherwise.

    But what you've established here is that the problem is definitely NOT the Command-J shortcut, but the Write Check menu option. (That's why defining a different keyboard shortcut didn't work -- like Command-J, it's a shortcut to a menu command that's not working.)

    Just to make sure of something, is the Write Check grayed out on the Transactions menu, or does it appear normal? Are you sure you have selected your checking account in the left sidebar? Not the "Cash" subgroup or "Banking" or "All Transactions"? Write Check will only work if you have a single checking account selected in the left sidebar.

    I don't print checks in Quicken, so if that's not it, I can't figure out what might make that menu command not work. Hopefully one of the other Mac folks here might have a clue. Paging @RickO, @John in NC...  ;)
    Quicken Mac Subscription • Quicken user since 1993
  • Unknown
    Unknown Member
    edited December 2018

    Yes, I tried that initially and found that when that method was attempted it didn't work either.  What does work is this: 'COMMAND N' brings down a new transaction.  From there I can go to 'EDIT DETAILS' and then click on 'CHECKS' and a check appears that I can fill in and 'write'.  Another problem then occurs which is that the auto-fill for the address (for a check that I'd written numerous times before) doesn't auto-fill any longer.  So the short of it is that I can still write checks today but it certainly is a lot more difficult than it was yesterday.

    Yes, the WRITE CHECK tab is bold and black (not grey), yes, I'm working within the same checking account that I've used for years.  I've got another checking account for a church where I'm the treasurer, and the Command J DOES, indeed, work on that account.
  • Unknown
    Unknown Member
    edited December 2018 Accepted Answer
    Aha!!!!!!! I found that alongside ANY STATUS (a drop down menu) there resided a red X for 'clearing all filters'.  I don't have any idea where it came, being sick of spending a good part of the day working on the problem, I 'pressed' the button.  Suddenly COMMAND J works again.  In fact, I had to clear about 50 checks from the register showing no amounts (a result of pressing 'Write Check' over the course of working on the problem.) So, again, it's now working as it should.  Thanks for all of the suggestions.
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    edited December 2018

    Aha!!!!!!! I found that alongside ANY STATUS (a drop down menu) there resided a red X for 'clearing all filters'.  I don't have any idea where it came, being sick of spending a good part of the day working on the problem, I 'pressed' the button.  Suddenly COMMAND J works again.  In fact, I had to clear about 50 checks from the register showing no amounts (a result of pressing 'Write Check' over the course of working on the problem.) So, again, it's now working as it should.  Thanks for all of the suggestions.

    Great! I wasn't aware that setting a filter would inhibit being able to write a check, but what you've described makes sense. (And explains why it could be different today versus yesterday.) Glad the mystery is solved and you're back in business. :)
    Quicken Mac Subscription • Quicken user since 1993
  • RickO
    RickO SuperUser, Mac Beta Beta
    edited December 2018

    Aha!!!!!!! I found that alongside ANY STATUS (a drop down menu) there resided a red X for 'clearing all filters'.  I don't have any idea where it came, being sick of spending a good part of the day working on the problem, I 'pressed' the button.  Suddenly COMMAND J works again.  In fact, I had to clear about 50 checks from the register showing no amounts (a result of pressing 'Write Check' over the course of working on the problem.) So, again, it's now working as it should.  Thanks for all of the suggestions.

    I don't think the filter prevented writing a check. Just that whichever filter was set was preventing them from showing after they were created. That's why he had to delete 50 essentially blank check transactions created in all his punching of Cmd-J.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    edited December 2018

    Aha!!!!!!! I found that alongside ANY STATUS (a drop down menu) there resided a red X for 'clearing all filters'.  I don't have any idea where it came, being sick of spending a good part of the day working on the problem, I 'pressed' the button.  Suddenly COMMAND J works again.  In fact, I had to clear about 50 checks from the register showing no amounts (a result of pressing 'Write Check' over the course of working on the problem.) So, again, it's now working as it should.  Thanks for all of the suggestions.

    @RickO, yeah, I actually understood that, but see that my post above didn't express it that way. In any case, I'm glad the mystery is solved and Mark is back in business.
    Quicken Mac Subscription • Quicken user since 1993
  • Yesterday I used 'Command J' to write checks on my MacBook Pro.  Today it doesn't work. No 'check' appears.  The 'Transaction' button on the toolbar turns blue momentarily but that's it - nothing happens.  Need help to resolve.
    I had the same thing happen to me.  I finally realized that my date was set on 'Last Year' instead of all dates.  I was only seeing 2018 transactions.  When I changed the pull down menu to 'All Dates', I saw all of my 'Command J' entries.  There were 6 of them.  User error 😂
This discussion has been closed.