One step update forgets which accounts to download transactions for

Starting around November, one of my data files started having the following problem with One Step Update:
I have bank, credit, and investment accounts at three different institutions set up for one step update.  When I first open the file in Quicken, and click the One Step Update button, I am asked for my vault password.  When I provide the password, the One Step Update Progress window pops up, with only "download quotes and headlines" as an action.  The Summary also only shows the quotes and investing headlines as having been completed, no other actions.

When I click One Step Update again, I get the One Step Update Settings menu.  Under Download transactions and balances, all of my financial institutions are shown, but none are marked.  If I mark them and select Apply, then Update Now, the One Step Update Progress window shows a download task for each institution, plus the download quotes task.  However, the Update Summary does not show results for the transaction downloads, only showing quotes and headlines updated.  But if there are transactions to download, they do get downloaded.

If I close Quicken and start up again in the same data file, I get the exact same behavior described above.  Selecting accounts and clicking Apply in the One Step Update Settings window does not result in those settings being remembered in the next session.

I have tried disabling all online links and re-linking the accounts.  That does not change the behavior.

I dug up a backup file from October, which did not exhibit the problem after disabling the accounts and re-linking them.  Then I spent the morning bringing the file up to date.  Once it was up to date, I deleted the buggy file and renamed the repaired file with the original name.  And just like that, the problem was back!

Comments

  • John StimsonJohn Stimson Member
    edited January 9
    Follow-up: Renaming the fixed file to the old filnename was not what triggered the problem.  I pulled up an automatic backup of the fixed file before it got renamed, and that also exhibits the problem.
  • John StimsonJohn Stimson Member
    edited January 9
    At the beginning of November, I was using Quicken Premier 2016 for Windows.  After this problem showed up, I bought and installed Quicken Deluxe 2019 for Windows, in the hope that this bug was fixed in Q2019, or that I could at least get tech support.  I migrated the file to Q2019 and the problem has continued.
  • John StimsonJohn Stimson Member
    edited January 10
    I have gone through this problem with Quicken phone support.  They are aware of the problem happening to multiple customers and are working on a fix for a future update.
  • I have same problem. Hope fix comes soon. Very frustrating having to update multiple times.
  • sahuffsahuff Member
    I have the same problem and updated twice from 2016 to 2018 then to 2019... Still have the problem... 
  • bawalshbawalsh Member
    I had this problem for a while, started sometime last year with 2016 after some update I think. I upgraded to 2019 and the problem did not go away. I had tried all the troubleshooting all the old posts said to try. Super validate, delete the vault... Nothing worked.

    I think I finally got it working for me. I just made a copy of the file. File > File Operations > Copy. Then open the new copy. Click on the one step update. Enter your vault password. Click settings. Click "all" to select accounts. Then update.

    The new file keeps the selected accounts for each update.

    If I have the new file open then switch to the old file (after doing an update), the old file will update once with all the accounts selected. Any update after that has all the accounts unchecked. If I reopen the new file, update my accounts and then go back to the old file. It does it again. The old file will update all accounts once then have all accounts unchecked on the next update. Whatever. Abandoning the old file.
This discussion has been closed.