Transferring Tax information to TurboTax does not work as documented by Quicken

According to this Quicken tech note I should be able to customize the tax report before exporting to create a TXF file with only the line items in the customized tax report.  I am using Quicken Mac 5.11. 

That said, I love what the Quicken for Mac team is doing but the ROI on Quicken Mac is very low for me if the very basic Tax reporting features are missing.  I enter and categorize my data all year long to make tax reporting easier but that is not the case for the revamped Quicken for Mac.  I ran into this for the first time last year after switching over from Quicken 2011 and have had to rely to downloading data from financial sites and using spreadsheets to compute my tax return line items because I simply can't massage the reports to produce the datum that I needed in TurboTax.  In this case, a spreadsheet isn't a solution because I can't save the information in TXF format.  I have thousands of mutual fund transactions that need to be entered on form 1099-B/8949 to satisfy IRS reporting.

After having used Quicken since 1986 and living through the transition to the new Quicken for Mac, I strongly suggest that the Quicken for Mac team hire a Product Expert fluent in Investment and Tax strategies/requirements to improve the effectiveness and value of the product in this arena.  All the data is in Quicken, it just isn't available in a form conducive to filing a tax return and shouldn't be a huge effort to close the gap.  In fact, if the simple TXF export above worked as documented, it would solve a host of problems...

Comments

  • jacobsjacobs SuperUser
    The note you linked to is labeled as Quicken Windows 2016 and 2017, not Quicken Mac. So I wouldn't use that note at all. 

    So, the question is: what issues are you having in generating a usable, accurate tax report?

    In short, if you are using Quicken's pre-defined categories for all your transactions, most or all of your tax information should appear correctly on the Tax Report, which can be exported as a .txf file for TurboTax. If you use categories of your own creation, you need to edit those categories (Window > Categories), make sure the "Tax-Related" box is checked, and then Assign that Category to the correct IRS Schedule and Tax Line in the dialog box. Once your categories are properly set up, you should be able to get an accurate Tax Report.

    Post back here what issues you are having. 


    QMac 2007 & QMac Subscription • Quicken user since 1993
  • J_MikeJ_Mike SuperUser
    Hopegully the OP will come back with specifics.

    I am aware of one major issue with the TXF file.
    From the menu bar File > Export Tax Report generates a TXF file.
    Examining the file using TextEdit shows this file erroneously includes activity in tax deferred accounts - dividends, cap gain/loss, etc.

    One can also generate the Tax Schedule Report and then, from the face of the report, select Export TXF...
    This TXF file appears to be okay - it does not include tax deferred accounts.

    I have not checked any deeper for other issues.

    Problems with the TXF file date back to Beta2015, IIRC. Bug reports were submitted at various times - typically as tax season loomed. I recently (2-3 most ago?) posted a reminder of this issue in one of Quicken Marcus' new release threads but do not recall any response.
    QWin & QMac (Deluxe) Subscription User
  • brucelbrucel Member
    The issue with Quicken Mac, is that you can not export a "customized" tax report in TXF format.  Choosing Export Tax Report, exports all tax related categories, not just the items listed in the "customized" tax report.  This is either a bug or an oversight...
  • jacobsjacobs SuperUser
    @brucel That's not what I'm seeing. If I open the Tax Report and click Export TXF on the upper right of that screen, it exports everything. Then I go to customize and un-check one of my investment accounts, and the report on-screen updates showing the transactions from that account are now missing. Again, I click on the Export TXF button at the upper right, and when I open the .txf report in a text editor, it matches the "customized" version on-screen; it does not include the account I excluded. So I conclude that the Export TXF button on the Tax Report screen does, indeed, export the report however you have customized it. So if you're seeing something different, please provide more details, because to me, it seems to be working as expected.

    As @J_Mike says above, there is a difference between the "Export TXF" button in the top of the Tax Report screen and the "Export Tax Report…" function on the File menu. Export Tax Report is always available; if you have your checking account open, for instance, you can still do Export Tax Report -- and it will always export all tax-related transactions. But if you open the Tax Report and customize it, then you can export the customized report you've created.
    QMac 2007 & QMac Subscription • Quicken user since 1993
  • brucelbrucel Member
    @jacobs, are you using Quicken Mac or Quicken Windows?  I am using Quicken Mac and the only way to export TXF information is using the File->Export Tax Report... menu item after which I am presented with a dialog to pick the year.  Quicken then proceeds to export the entire tax report for all accounts and all taxable categories, not the customized tax report.  
  • jacobsjacobs SuperUser
    edited March 16
    Quicken Mac. Go to Reports > Tax Report and customize the report in anyway that you wish. Then look on the upper right part of the screen for the button for Export TXF.
    QMac 2007 & QMac Subscription • Quicken user since 1993
  • brucelbrucel Member
    Quicken Mac does not  have an "Export TXF" button.


  • jacobsjacobs SuperUser
    Actually, it does...


    Are you sure you're running version 5.11.0? That's what I'm running here.
    QMac 2007 & QMac Subscription • Quicken user since 1993
  • jacobsjacobs SuperUser
    edited March 16
    In fact, I just checked and this export button existed back in Quicken 2016, so I'm really puzzled by why it's missing from yours.
    QMac 2007 & QMac Subscription • Quicken user since 1993
  • brucelbrucel Member

    Are you running Deluxe?
  • jacobsjacobs SuperUser
    I actually have Premier. But I was under the impression from Quicken folks that there were no functional differences between Deluxe and Premier. Very odd.
    QMac 2007 & QMac Subscription • Quicken user since 1993
  • brucelbrucel Member
    Interesting.  If you "customize" your report to "only transactions with selected categories", you loose the export function.  Your report also showed "Summarize by:" that I didn't have so I tried changing the customization features and voila, I have an export button!  Doesn't make a lot of sense to me (bug?) but thanks for your persistent responses.


  • jacobsjacobs SuperUser
    Fascinating! By trial-and-error, I found that at least one of five specific sub-categories MUST be included, or the export options disappear:
    • Investment:Dividend Income
    • Investment:Interest Income
    • Investment:Reinvest Dividend
    • Taxes:Medicare
    • Taxes:SDI
    I can't think of any logical reason for requiring one of those five categories, but not many others which appear on a Tax Report, so I'm thinking this must be a bug. I'm going to report it via Report a Problem in the Quicken Help menu; you might want to do so, too.
    QMac 2007 & QMac Subscription • Quicken user since 1993
  • Hello @brucel ;

    Thank you for taking the time to report this issue to the Community.  Based on the information exchanged between yourself and @jacobs I was able to confirm that this behavior is indeed a bug that our Product Team is aware of.

    I'm also happy to confirm that the fix for this bug is currently slated to be included in the next release for Quicken for Mac 2019, although, please be aware that if any issues or problems are found with the fix during testing it may be delayed to another release.

    I hope this information is helpful and again thank you for reporting this bug.

    Sarah
Sign In or Register to comment.