Error encountered setting up Bank of America

I have recently begun to set up downloads for Bank of America.  I used to have downloads set up years ago but for some reason they stopped working quite some time ago.  Didn't really bother me so much as I rarely use my Bank of America credit card.  But I have started using the card again and would like to have the transactions downloaded but Quicken cannot complete the setup.  Is there something else that needs to be done?

I followed this path: Tools > Account List > BofA > Activate Downloads

The following screens appear:

Activate One Step Update
            I select Bank of America

Activate One Step Update
            Enter your account information.  -> I enter my user name and password for Bank of America

Bank of America - Quicken Account Access
            Select an e-mail address to receive your code.
            -> I select the e-mail address associated with my B of A account
            -> A code is sent to my address from B of A

Bank of America - Quicken Account Access
            Enter authorization code, card expiration date and security code from card
            -> I enter all that information in

Error Message Received
            -> Sorry we've encountered an error.  (It's not your fault.)
            -> Quicken is having trouble connecting to Bank of America.

Best Answer

Answers

  • Quicken HaroldQuicken Harold Moderator ✭✭✭✭
    Hello amb1979i. Appreciate the information that you have provided.

    Did you get a CC-### or an HTTP-### number when you finished through this process?

    Please let us know so that we can best help you.

    Respectfully,
    ~ Quicken Harold.
    Quicken Harold
    Community Moderator
  • Hello, I did not receive any CC or HTTP number.  Is there anything in the log files you would like to know?  Below is a screen capture of the last message received.


  • mshigginsmshiggins SuperUser ✭✭✭✭
    From C. D. Bales:

    Leave that "Sorry. We encountered an error." message on your screen.

    Use your browser to logon to your BofA account, where you should be presented with another message that looks like this:




    Click OK on the BofA message, then continue to your BofA account(s).

    Then return to Quicken and select "Try again now" and click "Next".

    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • I just went through the process again.  Unfortunately, Quicken is now crashing.  I am getting all the usual screens to enter in all information but instead of receiving the error screen I previously posted, Quicken is crashing and I am asked to send an error report.  I have attempted this three times with the same result, I rebooted my PC after the second attempt.  Unless there are some suggestions as to what I should do about this new screen, I will wait and try again later.


  • Tried it again now.  Quicken did not crash.  I got to the "Try it again" message.  I left that message displayed.  I then logged into my account.  I did not receive a message from Bank of America to confirm access by Quicken, only the normal home screen.  I decided to click on the "try it again" option on Quicken and it just started the process again where I have to request an access code.
  • mshigginsmshiggins SuperUser ✭✭✭✭
    From C. D. Bales:

    "I did not receive a message from Bank of America to confirm access by Quicken, only the normal home screen."

    Try again and this time do not provide any access code (*). If that displays the "Sorry .... " message, try the steps I posted again. 


    [ (*) I have gotten the offer to supply an access code, but BofA only allows me to choose to have a text message sent to my landline, so I couldn't supply an access code, if I wanted to. When I'm asked how I want to receive my code, I click Cancel. I then get the "Sorry ...." message again. At that point, I manually logon to BofA and get the "One final step ...." message.]


    [I don't know why Quicken is crashing on you, but that may indicate some other problem (corrupted data?) ... which could possibly interfere with this problem.]


    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • Rocket J SquirrelRocket J Squirrel SuperUser ✭✭✭✭
    I believe B of A’s “one final step” screen only appears for Direct Connect users. It doesn’t make tons of sense to present it to Express Web Connect users.
    Quicken user since version 2 for DOS.
    Now using QWin Premier subscription version on Win7 Pro.
  • Thank you all for your help with this.  I contacted Bank of America and according to them they do not support direct connect and I will have to download transactions manually.
  • thecreatorthecreator SuperUser ✭✭✭✭
    amb1979i said:
    Thank you all for your help with this.  I contacted Bank of America and according to them they do not support direct connect and I will have to download transactions manually.
    HI  @amb1979i ,

    No, you have two choices with Bank of America. Express Web Connect which uses Quicken Servers or Web Connect, which is downloading your transactions manually.



    Also, you haven't mention anything about Quicken. See this post:  https://community.quicken.com/discussion/7803899/add-your-quicken-information-to-your-posts-plus-how-you-are-connected-to-the-internet#latest

    thecreator - User of Quicken Subscription R18.16 & Quicken 2017 HBRP
  • nelaconelaco Member
    I get the same exact thing.  If I create a NEW file and then add the account, it works.  I rather not have to re do all of my accounts (over 30).  Do you have a fix yet?  I've tried all the usual "fixes" and also waited at least 48 hours in between....validating afterwards with no errors.  Appreciate any help Quicken can provide.  Thank you.
  • thecreatorthecreator SuperUser ✭✭✭✭
    nelaco ,

    Okay, in a New File, you proved it works, but not in the existing file.

    1. Do a Manual Backup of your Quicken Data File and store it off of current operating system and Documents partition.
    2. Next, Perform this procedure:   https://community.quicken.com/discussion/7844658/installing-reinstalling-windows-quicken-subscription-editions 
    3. Stop before you reinstall Quicken,
    4. Now either delete your Quicken Data Folder or create a new Folder called Quicken Subscription Data.
    5. Rerun CCleaner Free, Cleaner portion and Registry Portion (twice).
    6. Now reinstall Quicken Subscription.
    7. When it asks if you are New or Upgrading, select I'm Upgrading.
    8. When it asks where to restore your Quicken Data File, to, select Quicken Subscription Data.
    9. Now remember you are working with Copy of your Quicken Data File, so if it does not work, or you made a mistake, you can start over.
    10. Now you can try Deactivating and Set up Now or since you proved it worked in a New File, don't rename or Hide the Bank of America Accounts, but delete them from the File.
    11. Run Validation after removing Bank of America.
    12. Now, re-add Bank of America Accounts to your Data File.
    13. Quite possible a Quicken Log File became corrupted, before you try anything. Thus, we / I deleted those logs.
    14. This way, you have your Other Accounts and now Bank of America, without creating a Brand New Quicken Data File.
    15. Remember, you don't need to go with the Default Quicken Data File Name, but you can change the name to Nelaco 2019 as an example.
    16. Questions?
    thecreator - User of Quicken Subscription R18.16 & Quicken 2017 HBRP
  • nelaconelaco Member
    Thank you!  I'll try this and report back.  I had actually upgraded from Q2016 to Q2019 just in case it would solve the problem but it made no difference.  Thank you again!
  • nelaconelaco Member
    I've decided NOT to try the above solution since the one account with issues is linked to a bunch of other accounts and it would mess up reports that I have that are important.  I'll just keep manually downloading until hopefully there is a fix to this BUG.  Thank you again for offering this solution.
This discussion has been closed.