When archiving investment register , new archive account created is wrong currency!

questionsforever
questionsforever Member ✭✭
[rant redacted]

Problem: There is now a feature in an account register to 'archive' closed transactions. I have a US DOLLAR investment account. When I use this feature it creates a new archived investment account but the new one is in the wrong currency, screwing up the entire reports and data. The new archived account is generated in CAD instead of the same USD as the original transactions. I opened the archived account info page and it says CAD as the currency!

[rant redacted]

Anyway this needs to be fixed fast. Maybe the next bug update.

Answers

  • UKR
    UKR SuperUser ✭✭✭✭✭
    Until somebody from Quicken responds to your problem, please
    - retain this bad data file for possible analysis by Quicken programmers
    - restore your data file to pre-archive condition from a backup taken before you started the archive process, so you can continue doing your daily tasks.
  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    From C. D. Bales:

    Assuming CAD is your Home currency, you can try this (backup first):

    - Change your home currency to $US

    - Archive your $US account

    - Change your home currency back to CAD


    If you find anything not to your liking, restore the backup.


    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • How do you change home currency? I haven't seen this before. Thanks.
  • smayer97
    smayer97 SuperUser, Mac Beta, Canada Beta ✭✭✭✭✭
    edited March 2019
    Assuming you are using QWin, unfortunately, in QWin-CA you cannot change the home currency as it is locked.

    If you are using QMac, you can go to General Preferences and change it there.
    Have Questions? Help Guide for Quicken for Mac
    FAQs: Quicken Mac Quicken Windows Quicken Mobile

    Add your VOTE to Quicken for Mac Product Ideas

    Object to Quicken's business model, using up 25% of your screen? Add your vote here:
    Quicken should eliminate the LARGE Ad space when a subscription expires

    (Canadian user since '92, STILL using QM2007)
  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    From C. D. Bales:

    "How do you change home currency?"

    I have the U.S. version of Quicken, so I can only speak for that.

    Tools > Currency List.

    Select the desired Home currency and click the Home button (near the foot of the List).


    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    From C. D. Bales:

    If you have the Canada Quicken for Windows version, you can try another approach: plan to turn your existing investment account into the archive account. It's not really the same thing as the new feature; but if you have been experiencing sluggish performance due to an investment account with lots of transactions, it could provide similar relief.

    Manually create a New investment account with the correct currency.

    In the old (the pre-existing) investment account, initiate a series of "Shares transferred between account" transactions (one security - one Shares Transferred transaction - at a time), to move the current holdings of the securities whose positions are still open, from the old account to the new account. All the transactions, as of the time you initiate the process, will remain in the old account. But you can continue tracking your open positions (and any new holdings) in the new account.


    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
This discussion has been closed.