Quicken Premier 2019 SUPER SLOW!!

Long time Quicken user. Have been using Quicken Premier 2019 (currently version R18.16, build 27.1.18.16), since July 2018 and it has been painfully slow. Previous versions had worked well, but this one sucks! I had been hoping that Quicken would do something about all the negative community comments about this, but evidently NOT!

After entering the password for my file, it takes a good 20+ seconds before I can start working. Also, after entering a transaction or a bill payment, it takes 7-10 seconds before being responsive again.

I've tried the numerous suggestions on the community message board (validating database, making a copy, reducing the number of accounts and transactions, updating drivers, etc., etc.), but nothing helps! My computer is a Gateway with Intel i5-2300 CPU and 8 GB ram.

My subscription is up for renewal on July 1st and I would really like to get some satisfaction before wasting money on another year of, what I'm now considering, a useless product. I tagged this under "Known Issues" because this has been going on a long time.
Tagged:

Comments

  • NotACPANotACPA SuperUser ✭✭✭✭✭
    Do you have Q set to do One Step Update when you open Q?  That could explain the start-up 20+ seconds.
    What is the full path (including file name) to your Q data file?
    Are you using DropBox, OneDrive or any other 3rd party backup products?
    Have you tried trimming your Memorized Payee List (CTRL-T)?  And extensive list can also slow down Q. (You mentioned other items, but not this one).
    And, lastly, can you please do HELP, and hold down the CTRL key while you select About Quicken. Then take a snapshot of the resulting statistics dialog and post it here using the Landscape Icon above (NOT the "paper with a corner folded Icon").
    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • sdyndasdynda Member ✭✭
    The only time it does a One Step Update is when I manually tell it to.

    Path to data file:
    C:\users\owner\Documents\Quicken\Data\Owner's Quicken DataCpyCpy.QDF (Yes, it's a copy of a copy!)

    I used to use One Drive, but moved the data file back to local without improvement.

    Memorized Payee List trimmed down to last 12 months & set to 12 months in preferences.

    I've got the screen capture, but do not see any Landscape Icon (nor a "paper with a corner folded icon" for that matter.). Here's what it says:

    Size of file: 23531K
    Accounts: 28
    Categories: 461
    Mem Payees: 218
    Sec/Max ref: 58/58
    Transactions: 5587
    Avail Mem: 2097151K
    Total Mem: 2097151K

    Thanks for any help!
  • NotACPANotACPA SuperUser ✭✭✭✭✭
    Try renaming your Q data file.  Both the apostrophe and the spaces in your current file name can be problematic for Q.
    Q is REALLY more reliable with a filename in the old 8.3 format, such as NotACPA.qdf
    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • sdyndasdynda Member ✭✭
    Actually, I finally got upset enough to remove Q through the control panel then used QCleanUI per the article at , and then reinstalled Q. Really quite a marked improvement!! Startup went from 20+ seconds to about 6, and haven't notice the lag after saving a transaction. It's still too soon to be completely convinced, but I'm keeping my fingers crossed.

    I'll change my file names to the 8.3 format just in case.

    Thanks!!
  • sdyndasdynda Member ✭✭
    Message board wouldn't let me post the actual link so, in Quicken Support, search for "Using QcleanUI to resolve issues installing or uninstalling Quicken for Windows".
  • NotACPANotACPA SuperUser ✭✭✭✭✭
    Not sure why you couldn't post the link to QCleanUI ... but here it is: https://www.quicken.com/support/using-qcleanui-uninstall-quicken
    BTW, the Win uninstall wasn't needed.  QCleanUI would have done it all.
    Also, that the reinstall fixed things would indicate that you had a corrupted program install.


    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • sdyndasdynda Member ✭✭
    Couldn't post it because it told me I hadn't been a member long enough. Thanks for posting the link.
    Just got done balancing my accounts, and everything seems to be as it should. Whoo-Hoo!
    BTW: NOW I'm seeing the landscape thing. Only had the emoji menu earlier.
This discussion has been closed.