Why does CTL+<key> not work

This has been around for many versions but seems to be worse now since upgrading to 2019. It's not easy to come up with steps to reproduce but once it happens It's really difficult to correct with out closing the program and restarting. After a while the CTL+<key> shortcut keys will stop working and just chime but do nothing when pressed.

Comments

  • NotACPANotACPA SuperUser ✭✭✭✭✭
    Please do EDIT, Preferences, Setup.  Which "Keyboard Mapping" option is selected?
    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • sdunninsdunnin Member
    Windows Standard
  • Quicken SarahQuicken Sarah Administrator, Moderator ✭✭✭✭
    Hello @sdunnin

    Thank you for taking the time to report this issue to the Community, although I apologize that you have not yet received a follow-up response.

    Thank you for confirming which keyboard mapping option is selected.  If you haven't already, I would recommend temporarily changing the mapping to the "Quicken Standard" option.  Once changed, click OK and then close and re-open Quicken to force a refresh and ensure the change is logged.

    Once Quicken is open again, return to the Edit > Preferences > Setup and reselect the "Windows Standard" option.

    If this issue persists, please create a new data file for testing purposes only and let us know if this behavior persists in the new file.

    If not, I would recommend following the troubleshooting steps available here.

    Please let us know how it goes and if this behavior persists.

    Thank you,

    Sarah
  • Rocket J SquirrelRocket J Squirrel SuperUser ✭✭✭✭✭
    A while back, there was a bug which manifested because a change to the Windows operating system affected Quicken. After some amount of time, CTRL keys silently stopped working and only restarting Quicken would restore them.

    I don't believe this is what you are seeing. You mention that you hear a chime. I guess you mean the Windows "default beep" sound? This indicates the keystroke is being seen rather than discarded.

    This is often a symptom of the keyboard focus having been stolen by a dialog you can't see because it's hidden by another window. The next time this happens, move your windows around & minimize those unrelated to Quicken, and see whether there's a dialog underneath that wants your attention.
    Quicken user since version 2 for DOS.
    Now using QWin Premier subscription version on Win7 Pro x64.
  • Blake WimperisBlake Wimperis Member ✭✭
    Same problem in 2016 Home & Business - tried changing settings as suggested - same problem. Ctrl+Y works once then nothing. Ctrl+F never works have to use menu
  • Blake WimperisBlake Wimperis Member ✭✭
    This happens when Quicken is the only app running in Windows 10
  • Rocket J SquirrelRocket J Squirrel SuperUser ✭✭✭✭✭
    edited August 15
    On the off chance that you are experiencing the problem I mentioned a few posts earlier, you can try a modification to the Windows Registry which addresses this specific problem.
    Copy the following 4 lines exactly into a text file, including the blank line, and save it to your desktop with the name Timeout.reg:
    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Control Panel\Desktop]
    "LowLevelHooksTimeout"=dword:000003e8

    Double-click the desktop icon for that file, and it will increase the timeout to a level which should prevent the problem. Reboot your computer, run Quicken and see whether it helps.
    If you are curious why this happens, you can read about it here. Note the passage which says
    The value is in milliseconds. If the hook procedure times out, the system passes the message to the next hook. However, on Windows 7 and later, the hook is silently removed without being called. There is no way for the application to know whether the hook is removed.


    Quicken user since version 2 for DOS.
    Now using QWin Premier subscription version on Win7 Pro x64.
This discussion has been closed.