Transactions that appear in register and simple reports are missing from Comparison report

Greetings,

I wonder if the community can help with an issue of transactions not showing up on a comparison report, even though they appear in the register and in other reports.

When I run an Income and Expense Comparison by Category report on the last 12 months compared with the prior year period, for a single Class, only 3 out of 12 transactions in the Mort Int Category in the applicable time period appear in the report. If I run a simple transaction report with the same parameters, all 12 Mort Int transactions appear. And all 12 transactions appear in the register, correctly Categorized and Classed.

Quicken Support asked a couple questions and then concluded my file had too many years of data in it. They suggested I start a new file limited to 5 years of data. That seems to defeat a purpose of using Quicken.

Why do you think some of these Mort Int transactions would not appear in the Comparison report, while they appear everywhere else they are supposed to? Think I can fix this somehow, without starting a new file?

Thanks!
Dan
Running Quicken 2017 Home & Business on Windows 10.

Comments

  • UKR
    UKR SuperUser ✭✭✭✭✭
    Just a hunch ... are all the accounts and categories included properly in the Comparison Report's customization dialog?
    There are some transaction-based reports which don't show payments made directly from investment account registers, for example.
  • dwan
    dwan Member ✭✭
    Thanks, UKR. I did check that. The account with the transaction is an active checking account. I went into the customization window and even showed and included hidden account to make sure that wasn't the issue. Still, only three of the 12 transactions appear. Not sure if it's relevant, but these Mort Int transactions are part of a split transaction for a mortgage payment: The split includes the Mort Int as well as a transfer to the Mortgage account (resulting in a principal reduction).
  • UKR
    UKR SuperUser ✭✭✭✭✭

    Sometimes a picture is worth a thousand words …
    Can you please capture one or more images of the parts of your Quicken window showing the issue (Split Detail dialog of a transaction that works, one that won't and the page of the report), sensitive information blacked out as necessary to protect your privacy but annotated to describe the situation, and attach the image(s) here?
    The Windows Snipping Tool (available with Windows 7 and up) can be used to capture a partial screen image and save it to a file.  Microsoft Paint can be used to annotate the image.
    https://support.microsoft.com/en-us/help/13776/windows-use-snipping-tool-to-capture-screenshots
    To take a screenshot in Mac please see https://support.apple.com/en-us/HT201361
    Please create image files of type PNG, JPG or GIF only.
    To attach the image here, start composing your reply in the "Type your comment" box at the bottom of this webpage. Drag and drop the image or, at the top of the text entry window you'll see a row of icons beginning with B I S
    Click the "Attach image" icon (the one that looks like a tiny landscape with mountain and sun). It will allow you to select and upload the captured image file(s) from your computer. The captured image(s) will be inserted at wherever the cursor is located in the text.


  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    edited August 2019
    "for a single Class..." 
    You're speaking about "tags" in the current Quicken vernacular?  Anything about that earmark that might be causing the problem, like a very similar tag selected by mistake?
    "Not sure if it's relevant, but these Mort Int transactions are part of a split transaction for a mortgage payment:"
    But I assume ALL the transactions are entered in that manner?
    Are the dollar amounts for the 2 year's worth of transactions all the same?  Maybe a $ filter is in place?

  • dwan
    dwan Member ✭✭
    Thanks, UKR and Tom. Your helpful questions and requests for more information helped me find my error. I was erroneously expecting transactions from outside the date range -- I was confused by the fact the mortgage payments began mid-year, and that I was doing a YTD comparison to prior year period, instead of the full year.

    Tom, you're right, I was talking about Tags (not Class).

    UKR, thank you for the image request and helpful instructions -- I discovered my error while creating the screenshots.

    Great forum experience! Thank you for your time and help!
    Dwan
This discussion has been closed.