Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

4K Display, Blurry Text, DPI Settings Don't Fix Issue

A1MB1G
A1MB1G Member ✭✭
I'm running the latest Canadian version of Quicken Deluxe on a 4k display laptop and when launching Quicken, the text is so blurry. I've tried enabling the DPI setting to "Application" and although the text became perfectly clear throughout Quicken, other areas became completely unusable (see screenshot).

I recall there being a way in Windows 10 to edit the .EXE file's manifest but don't recall how to do it. Any ideas/suggestions? Why is this still an issue when 4k laptops are becoming more and more the norm?

Answers

  • A1MB1G
    A1MB1G Member ✭✭
    If I'm not mistaken, it sounds like the U.S version recently received a software update which addressed all the DPI and Display issues in Quicken where fonts were blurry.

    I've tried adjusting the DPI settings using the compatibility tab in for Quicken but the only one that makes the text look clear is the option to use "System (Enhanced" DPI settings but then that breaks other areas of the app. For example, the names of the months are missing from the Annual budget planner.

    Is there any hope to have an update on the app that makes Quicken into a user friendly 4K display app? Is that on the roadmap at least?
  • jr7107
    jr7107 SuperUser ✭✭✭✭
    I'm using the US version on 4K monitors, and have been for some time. Desktop, NVIDIA GTX 980s, no SLI config. Native resolution is 3840x2160. For some reason I'm remembering a modification to the shortcut, will have to dig around to see if I can find it.
    Quicken user since 1994.
    Quicken Forum/Community Contributor since 2005.
  • jr7107
    jr7107 SuperUser ✭✭✭✭
    Current shortcut config. Will dig through the Community posts, thought this was solved here.


    Quicken user since 1994.
    Quicken Forum/Community Contributor since 2005.
  • jr7107
    jr7107 SuperUser ✭✭✭✭
    Quicken user since 1994.
    Quicken Forum/Community Contributor since 2005.
  • A1MB1G
    A1MB1G Member ✭✭
    I've tried each of the DPI settings in the shortcut Compatibility tab and none of them resolve the issue. The best one in terms of making everything look clear and crisp was to select "Change High DPI Settings" and then choosing "Override High DPI" and selecting "System (Enhanced)".

    The problem with that setting is that it altered a lot of the other areas of the program where it became impossible to see all the numbers e.g. Budget - Annual View, all the numbers were squished together etc.

    None of these options (Application, System or System Enhanced) solves the problem. I'm running all the latest video drivers on my HP Spectre x360 4k 15" Laptop.
  • A1MB1G
    A1MB1G Member ✭✭
    > @jr7107 said:
    > And then another solution here:
    >
    > https://community.quicken.com/discussion/7600530/update-on-2016-quicken-today-fonts-are-now-so-small-on-my-4k-monitor-quicken-is-useless

    When I try to access this link is says Permission Denied, not sure if I have access to view this link?
  • jr7107
    jr7107 SuperUser ✭✭✭✭
    It is an archived post by @UKR one of the SU's:


    Quicken user since 1994.
    Quicken Forum/Community Contributor since 2005.
  • A1MB1G
    A1MB1G Member ✭✭
    @UKR Tried the settings you provided above but fonts still look squished in parts of the program when using the DPI override with "Application" as the setting. See screenshot below.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    I'm not sure, but the Canadian version of Quicken may not have caught up to all the changes made in the US version. You should be updating to R 19.37 and see if that helps resolve the issue.
    https://www.quicken.com/support/update-and-mondo-patch-20182019-release-quicken-windows-subscription-product

    Here's the latest version of my text about Font size issues:

    If you haven't rebooted Windows since the installation of the latest Quicken update, please do that first and try Quicken again.

    Font size problems? Display issues? (Windows)

    If you are using a version of Quicken at the Quicken 2019 US R 19.44 patch level or newer and you have previously made the following Compatibility change, please undo the change.
    Users of older Quicken versions please try the following:

    • Close Quicken !!! (This process won't work while Quicken is running!)
    • Check the Compatibility tab settings in your Quicken Desktop program icon:
    • In the Windows Start Menu right-click the Quicken icon. Select "Open File Location". This brings up a Windows File Explorer window. Right-click the highlighted Quicken shortcut line item.
      or
    • Go to the traditional Windows Desktop and right-click the Quicken program icon.
    • Now click Properties.
    • Select the Compatibility tab.
    • Uncheck all settings.
    • Windows 7, 8.1: Check "Disable display scaling on high DPI settings". 
      Windows 10:  Check "Override high DPI scaling behavior. Scaling performed by:" and select "Application"  (also try the other available options!)
    • Be sure to uncheck the "Run this program in compatibility mode for [older Windows version]" setting.
    • Click the "Change settings for all users" button.
    • Click Apply and exit.
    • Now start Quicken and see if that makes a difference.

    Some additional tuning suggestions:

    • Unless absolutely required, try not to use "View / Use large fonts"
    • Try setting the bank account registers to use a different font style or size: go to Edit / Preferences / Register, click the Fonts button and try different fonts.
    • Try adjusting the bank account registers' row height: go to Edit / Preferences / Register, choose among the available Row Height choices: Compact, Comfortable or Standard
    • If all else fails, try changing Windows Control Panel / Display options for "Make text and other items … smaller or larger" to use a different scaling level.
  • A1MB1G
    A1MB1G Member ✭✭
    > @UKR said:
    > I'm not sure, but the Canadian version of Quicken may not have
    > caught up to all the changes made in the US version. You should be
    > updating to R 19.37 and see if that helps resolve the issue.
    > https://www.quicken.com/support/update-and-mondo-patch-20182019-release-quicken-windows-subscription-product

    thanks for trying to assist with this... I think this might be a case of the Canadian version being behind the U.S version in terms of these fixes. I'm already running R19.37 and tried rebooting the computer and applying the adjustments you mentioned above but same result.

    Hopefully the team is watching these messages and will have a fix out soon.
This discussion has been closed.