Quicken Premier 2019 R21.17 (27.1.27.1) unresponsive as Quicken redraws its windows incorrectly

Someone asked me to help them with their Quicken Premier 2019 today. I installed the latest update today (R21.17) but the problem persisted.
====
Windows 7, 6G RAM (running in VMWare Fusion 11.1.1 on a Mac).
====

This person has run Quicken for years but starting a couple of weeks ago, when Quicken opens it looks ok for about 1-2 minutes then its main window redraws repeatedly (about once every 3 seconds) in layers with hollow content staggered about a 1/4" to the left and above the window underneath (like a deck of cards). Quicken is unresponsive during this, and Task Manager can't stop Quicken under Task Manager's Applications tab but does stop Quicken by ending the process qw.exe under the Processes tab.

The borders of Quicken's main window and the redrawn windows that are layered on top are missing the standard Windows upper-right icons like the close "X" and min/max button but the main normal window location sometimes flashes those icons for a couple of seconds (if I quickly click the close "X," Quicken might close within 5-10 seconds; otherwise, I have kill the qw.exe process).

In short, Quicken Premier 2019 is unusable. If I don't click an account in the left column, Quicken stays stable longer and I can click a pull down menu and menu item like Preferences or file operations or another, which is how I was able to run Validate and Super Validate ok, though that didn't help. But the window-redraw nuttiness starts again and Quicken becomes unresponsive.

====

Windows 7 is pristine: no other program (including no browser or email client are ever used there because Windows 7 is running in a VMWare Fusion virtual machine only used for running Quicken on this Mac. Several previous versions (2016-18) of Quicken ran fine in this Windows 7 virtual machine, as did the 2019 version until recently. All the latest Windows updates are installed. I also disabled 3D acceleration for this virtual machine in VMWare Fusion's settings but it didn't help.

NOTE: this Mac is a 2010 model with ATI Radeon graphics (512M) and otherwise runs perfectly, I also ran the Mac's disk FirstAid without problem and deleted the Mac's temp files (cache files). I also installed CCleaner in Windows 7 and ran it, including its registry cleaner, then removed CClearner entirely, then rebooted Winodws 7. This Windows virtual machine has 2 processor cores allocated and I increased its memory allocation from 4G to 6G but it didn't help.

Next week I'll a new Windows 10 virtual machine on the same Mac and see if Quicken 2019 runs fine there. In the mean time, this person can't use Quicken for Bill Pay.

Answers

  • QW26QW26 Member
    Thanks. I actually already submitted the problem directly to Quicken from within Premier 2019 yesterday but wanted to post the problem publicly, too, in case others have this problem.

    That'd be great if fixing the Quicken registry would fix the problem, though I'm skeptical since I don't see how it'd affect a lower-level programmic operation like refreshing and redrawing windows.

    But based on your idea I'll remove Quicken completely and use CCleaner to delete remnants including Quicken entries in the Windows registry then reinstall Quicken 2019 Premier cleanly and see if that fixes it.

    I'll try this next Thursday when I'm at that site again.

    Thanks for the idea!
  • QW26QW26 Member
    Ok, I was at this site again today.

    A clean install fixed it.

    I removed Quicken from Windows, then manually deleted remnant files and folders named quicken or intuit from program files, program files x86, common files, the Windows folder (one .ini file) and App Data (from all sub folders), then ran CCleaner's registry cleaner and removed stranded quicken and intuit keys with the registry cleaner.

    After rebooting and downloading the latest Quicken, I reinstalled it, signed in with the users credentials, opened the same data file and everything worked perfectly. We pounded on it and it behaved normally.

    Some part of Quicken must have become corrupt, coincidentally with a recent release. Perhaps from repeatedly putting the virtual machine containing Windows to sleep with Quicken still open.

    Ironically, though the comment spammer's since-deleted posting here didn't suggest a clean install, the comment triggered a light bulb to try it.

    ====

    PS

    I know numerous people using Quicken for Windows but they all use it on Macs running either VMWare Fusion, Parallels or CrossOver. I use Fusion (none in BootCamp).

    I only know two Mac users out of hundreds who run Quicken for Mac, which is a pale imitation of the Windows version. If Quicken for Windows were just replicated on the Mac, VMWare Fusion and Parallels sales would drop off a cliff.
Sign In or Register to comment.