Scheduled Updates Not Working

Recently, my scheduled updates (which I had set for daily @ 5 AM) have stopped working. Further, if I reboot, I'm no longer prompted for my Quicken Vault password (as configured) after logging in either. I've tried changing the time when the updates run but that hasn't seemed to help. While I can manually run the updates, I'd much prefer having my scheduled updates working again. Any ideas on what the underlying issue may be / suggested steps for trying to troubleshoot / resolve?

My Windows / Quicken versions are below

Windows - 1903 18362.356

Quicken - 2019 R21.17 Build 27.1.21.17

Bill

Answers

  • SherlockSherlock SuperUser ✭✭✭✭✭
    Quicken user since 1997 
    Premier on Windows 10 
  • @Sherlock - Thanks for the tips. Unfortunately, the background agent is configured to run at startup. Toggling the "Before each scheduled update" option didn't help either. Any other thoughts/ideas?
  • GeoffGGeoffG SuperUser ✭✭✭✭✭
    It seems the agent is updated when Quicken is updated as can been seen below. I suspect you may have an issue with the install. Unfortunately, this will require an uninstall and reinstall. You can use Windows uninstall, or if you have an issue, use this uninstaller.

    user since '92 | Quicken Windows Premier - Subscription | Windows 10 Pro version 1903
  • @GeoffG - Unfortunately, an uninstall / reinstall did not help either. The startup functionality / scheduled updates literally just broke out of the blue here so I'm really at a loss as to the cause and more so, how I can fix it at this point
  • GeoffGGeoffG SuperUser ✭✭✭✭✭
    Can you provide a screenshot of the agent in Task Manager? Maybe fresh eyes might see something?
    user since '92 | Quicken Windows Premier - Subscription | Windows 10 Pro version 1903
  • @GeoffG - Screenshot of Task Manager attached. One thing I did realize I left out is that I'm running Quicken in a Win 10 VM. That said, I've been doing this for years without any issues and definitely no issues of this nature
  • GeoffGGeoffG SuperUser ✭✭✭✭✭
    edited September 21
    One thing I did realize I left out is that I'm running Quicken in a Win 10 VM. That said, I've been doing this for years without any issues and definitely no issues of this nature
    That could be significant. v1903 has changed under-the-hood functions that used to work, and no longer do in my experience.
    Are you running VM because this is a Mac or for another reason? If not a Mac, can you run Quicken as standard Windows installation to test?
    user since '92 | Quicken Windows Premier - Subscription | Windows 10 Pro version 1903
  • Jim ShiffrinJim Shiffrin Member ✭✭
    I am having the same problem, which started a couple of weeks ago. I am running Version 23.14 (both qw.exe and bagent.exe) under Windows 10. It is set to run the update in the middle of the night. Instead, it prompts me for the password vault pasasword (even though it is set to only ask for that at Windows startup). The new kick on this is that since yesterday, the password dialog presented by bagent.exe will not recognize my password! If I start qw.exe and do the update manually, the password works just fine!
  • Jim ShiffrinJim Shiffrin Member ✭✭
    Since I posted this last week, the scheduled updates magically started working again! I am not sure anything changed on my end - I know I did not do anything explicitly!
Sign In or Register to comment.