Maximized QW window isn't fully maximized

When I maximize QW under Windows 10 the window is short a few pixels on the top and on the left. I can see the window behind the Quicken window at these locations. This has been going on for quite a while. I've reported this to Quicken Support many times but it hasn't been fixed.

I run at 3840x2160 (4K) with a DPI of 200%. This might be the cause. Anyone else seeing this issue?

Comments

  • UKR
    UKR SuperUser ✭✭✭✭✭

    If you haven't rebooted Windows since the installation of the latest Quicken update, please do that first and try Quicken again.

    Font size problems? Display issues? (Windows)

    If you are using a version of Quicken at the Quicken 2019 US R 19.44 patch level or newer and you have previously made the following Compatibility change, please undo the change.
    Users of other Quicken versions please try the following:

    • Close Quicken !!! (This process won't work while Quicken is running!)
    • Check the Compatibility tab settings in your Quicken Desktop program icon:
    • In the Windows Start Menu right-click the Quicken icon. Select "Open File Location". This brings up a Windows File Explorer window. Right-click the highlighted Quicken shortcut line item.
      or
    • Go to the traditional Windows Desktop and right-click the Quicken program icon.
    • Now click Properties.
    • Select the Compatibility tab.
    • Uncheck all settings.
    • Windows 7, 8.1: Check "Disable display scaling on high DPI settings". 
      Windows 10:  Check "Override high DPI scaling behavior. Scaling performed by:" and select "Application"  (also try the other available options!)
    • Be sure to uncheck the "Run this program in compatibility mode for [older Windows version]" setting.
    • Click the "Change settings for all users" button.
    • Click Apply and exit.
    • Now start Quicken and see if that makes a difference.

    Some additional tuning suggestions:

    • Try this workaround for 4k monitors
      https://www.quicken.com/support/work-around-display-issues-high-resolution-monitors
    • Unless absolutely required, try not to use "View / Use large fonts"
    • Try setting the bank account registers to use a different font style or size: go to Edit / Preferences / Register, click the Fonts button and try different fonts.
    • Try adjusting the bank account registers' row height: go to Edit / Preferences / Register, choose among the available Row Height choices: Compact, Comfortable or Standard
    • If all else fails, try changing Windows Control Panel / Display options for "Make text and other items … smaller or larger" to use a different scaling level.

  • streetwolf
    streetwolf Member ✭✭
    I tried all the things you mentioned if applicable to Windows 10. I don't use Quicken's large font option. Setting a different DPI is not an option as what I use is perfect for my monitor and I have no other applications that do the same thing when maximized.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    What Quicken version are you using?
    The programmers made a lot of changes in Quicken Subscription (aka Q 2020) to better support all types of single or multiple monitor installations.
    AFAIK, these changes were not retrofitted into Q 2017 or older
  • streetwolf
    streetwolf Member ✭✭
    I'm using the latest version of Quicken for Windows (Year 2020 Version R23.17 Build 27.1.23.17).
  • streetwolf
    streetwolf Member ✭✭
    Here's a portion of a screenshot showing the window underneath at the top and left side.
  • splasher
    splasher SuperUser ✭✭✭✭
    If I remember correctly, Quicken is a window in a window and I believe that what you are seeing is due to that and there is nothing you can do to correct it.
    If you watch closely as Quicken starts, you will see a shadow window above the eventual window for a short period of time if it is not maximized.
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
  • streetwolf
    streetwolf Member ✭✭
    You are certainly correct in that Quicken does some strange visual things when starting. Nevertheless it is still programming and should be able to be corrected. It's not the end of the world but all programs should be as polished as possible especially Quicken which has been around seemingly forever..
  • aiorfino
    aiorfino Member
    Same issue here on 2019 (was Windows 8.1 now Windows 10).
  • aiorfino
    aiorfino Member
    Found it! Not a fix, but a decent workaround. In the C:\Users\<user>\AppData\Roaming\Quicken\config\QUSER.INI file there is a setting for Left and Top Window position. Edit so it looks like this:

    [Window]
    State=Normal
    Left=0
    Top=0
    Height= <enter the max height of your monitor>
    Width= <enter the max width of your monitor>

    It will run in a window, not maximized, so be careful not to drag the title bar, but it looks right.
  • streetwolf
    streetwolf Member ✭✭
    Basically what changing quser.ini is doing is what you can do by setting the window in normal mode and resizing the window by dragging each side to the edge. Changing quser.ini to my monitor size always results in it being changed to something like 1920x1080 minus the left and top amounts. It never stays at my 4K size. Since it's not a maximized window as you stated you can move it around accidentally. Until Quicken fixes this issue I'd rather leave it maximized with the window not fully stretching to the top and left.
This discussion has been closed.