Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

When launching Quicken 2019 it doesn't load the data file.

When I launch Quicken 2019 I get a screen that asks me to select what data file to use. After selecting the current file Quicken will load. If I close Quicken and then go to relaunch I get the same screen asking me to select what data file to use. (The data file is located in the Quicken folder.)

Also, after Quicken opens, if I to File and select one of the recently used data files I get a message stating "Quicken cannot open the file you have selected. The file may be deleted or the location may have been changed...."

I have had Quicken loaded on my computer since December 2019 and the above problem has only appeared in the last couple of days. I uninstalled and reinstalled Quicken 2019 with no improvement.

Rick

Comments

  • Bob_L
    Bob_L SuperUser ✭✭✭✭✭
    edited January 2020
    "(The data file is located in the Quicken folder.)"

    Your Quicken data file should be in a sub-folder of Documents.  Is that where it is?

    To be sure you are always running the correct file, I recommend putting a shortcut on your desktop  pointing to your data file in the Documents sub-folder.(right click the data file in windows explorer and choose send to, create desktop shortcut.)

    Quicken Premier Subscription, Windows 10 Home
  • rmk28027
    rmk28027 Member ✭✭
    Yes, the Quicken folder is a sub-folder of Documents.

    Regarding setting up the desktop icon. Even without the icon shouldn't Quicken recognize what data file was previously used and reload that file?
  • Bob_L
    Bob_L SuperUser ✭✭✭✭✭
    Yes, but I was trying to give you a workaround which is a good way to run anyway.

    You could also windows explore to Users>YourName>Appdata>Roaming>Quicken>config.  Delete or rename the QUSER.INI file.
    Quicken Premier Subscription, Windows 10 Home
  • rmk28027
    rmk28027 Member ✭✭
    I did setup the short cut but each time I launch Quicken I still keep getting the screen asking me to select my data file. Quicken keeps acting like I am a new user even though I have an existing data file.
  • Bob_L
    Bob_L SuperUser ✭✭✭✭✭
    edited January 2020
    I see the 2 windows notifications in the lower right.  Any chance you have controlled folder access set up?  If so, whitelist via those notifications.
    Quicken Premier Subscription, Windows 10 Home
  • Bob_L
    Bob_L SuperUser ✭✭✭✭✭
    edited January 2020
    Will it open from the shortcut? Did you try deleting the QUSER.INI File?
    Quicken Premier Subscription, Windows 10 Home
  • GeoffG
    GeoffG SuperUser ✭✭✭✭✭
    rmk28027 said:
    I did setup the short cut but each time I launch Quicken I still keep getting the screen asking me to select my data file. Quicken keeps acting like I am a new user even though I have an existing data file.
    Have you recently turned on Ransomware protection for Win10? I have and received the same screen as you this AM. I rebooted and all is well. I did have Quicken white listed, but just added bagent when the blocked message appeared for it. If you are using scheduled updates, bagent is the app that controls this.
    user since '92 | Quicken Windows Premier - Subscription | Windows 10 Pro version 20H2
  • rmk28027
    rmk28027 Member ✭✭
    Bob L - It will launch if I open the shortcut. I have not tried deleting the QUSER.INI file. I checked and Controlled Folder Access activated.

    Geoff - I have not turned any Ransomware protections. I will try rebooting rebooting.
  • rmk28027
    rmk28027 Member ✭✭
    Bob L - I went in and renamed and renamed the QUSER.INI file launched Quicken and received the request to select the data file. After selecting the data file and having Quicken open I then closed Quicken and relaunched it. I received the request to select data file again.

    GeoffG - I reboot the system and no change in the request to select data file. I even rebooted the system in safe mood to see if that would make a difference. Again, same request to select data file.

    I use Kaspersky and am going to check and see if that might be affecting Quicken.
  • Bob_L
    Bob_L SuperUser ✭✭✭✭✭
    CFA is a part of Ransomware Protection.If you are running Windows Defender that may be your problem.  If so please go to windows settings by right clicking Start.  Then Update & security, Windows Security, virus & threat protection, manage ransomware protection.



    See the files I have protected and do the same.
    Quicken Premier Subscription, Windows 10 Home
  • rmk28027
    rmk28027 Member ✭✭
    > @Bob_L said:
    > CFA is a part of Ransomware Protection.If you are running Windows Defender that may be your problem.  If so please go to windows settings by right clicking Start.  Then Update & security, Windows Security, virus & threat protection, manage ransomware protection.
    >
    > (Image)
    >
    >
    > See the files I have protected and do the same.

    Since I am running Kaspersky, Windows Defender is switched off. As far as I can tell Kaspersky does not have a features similar to CFA.
  • Greg_the_Geek
    Greg_the_Geek SuperUser, Windows Beta ✭✭✭✭✭
    What is the path to the folder that contains your Quicken data file? Do you have Controlled Folder Access enabled in Windows Defender? Are you using OneDrive, Dropbox or Google Backup?
    Quicken Subscription HBRP - Windows 10
  • rmk28027
    rmk28027 Member ✭✭
    > @Greg_the_Geek said:
    > What is the path to the folder that contains your Quicken data file? Do you have Controlled Folder Access enabled in Windows Defender? Are you using OneDrive, Dropbox or Google Backup?

    The data file is located in the Quicken folder under Documents. I do not have Windows Defender activated.

    However, I did download Dropbox earlier last week. Would that be interfering with Quicken accessing the data file?
  • Greg_the_Geek
    Greg_the_Geek SuperUser, Windows Beta ✭✭✭✭✭
    Are you sure the Quicken folder (or Documents folder) is not being synced to some cloud? You could try booting your computer into Safe Mode with Networking and then starting Quicken to see if it will open a data file.
    Quicken Subscription HBRP - Windows 10
  • Ps56k2
    Ps56k2 SuperUser ✭✭✭✭✭
    edited January 2020
    might also check the Config sub-dir and the QUSER.INI file -
    - make sure it is NOT set to Read-Only
    - open it with Notepad, and see if the recent filenames are listed
    C:\Users\[WinUser]\AppData\Roaming\Quicken\Config\
    [Window]
    State=Normal
    Width=1048
    Height=646
    Left=57
    Top=37
    [Quicken]
    ExecNum=1341
    NewCatPrompt=0

    [RecentFiles]
    1=C:\Users\Owner\Documents\Quicken-Files\QDATA-z8
    2=C:\Users\Owner\Documents\Quicken-Files\QDATA-z8BKP
    3=C:\Users\Owner\Documents\Quicken-Files\tester
    4=C:\Users\Owner\Documents\Quicken-Files\QDATA-z8-TESTER
    [RecentBackupPaths]
    BackupPath5=
    BackupPath4=
    BackupPath3=C:\Users\Owner\Desktop\
    BackupPath2=C:\Users\Owner\Documents\Quicken_Files\BACKUP2x\
    BackupPath1=C:\Users\Owner\Documents\Quicken-Files\BACKUP2x\
    [ScheduleUpdate]
    File=C:\Users\Owner\Documents\Quicken-Files\QDATA-z8-TESTER.QDF
    Root=C:\ProgramData\Quicken\INET\QDATA\



    Quicken 2020 Deluxe - Subscription - Windows 10
  • rmk28027
    rmk28027 Member ✭✭
    ps56k: Here is a copy of the quser.ini file:

    [Quicken]
    ExecNum=5
    [Window]
    State=Maximized
    Height=1039
    Width=1919
    Top=1
    Left=1
    [RecentFiles]
    1=C:\Users\Rick\Documents\Quicken\1993-2020
    2=C:\Users\Rick\Documents\Quicken\1993-2020
    3=C:\Users\Rick\Documents\Quicken\1993-2020
    4=

    One interesting thing is that if I open the File prompt when Quicken is running and click on one of the files listed under recent I get a message stating "Quicken cannot open the file you have selected. The file may be deleted or the location has been changed..." If I proceed, there is a message saying that Quicken cannot open the file and it gives the current path to the current file.
  • Greg_the_Geek
    Greg_the_Geek SuperUser, Windows Beta ✭✭✭✭✭
    Have you tried just deleting the quser.ini file and then running Quicken?
    Quicken Subscription HBRP - Windows 10
  • rmk28027
    rmk28027 Member ✭✭
    > @Greg_the_Geek said:
    > Have you tried just deleting the quser.ini file and then running Quicken?

    I renamed the original quser.ini file, restarted Quicken with same results.
  • Bob_L
    Bob_L SuperUser ✭✭✭✭✭
    You mentioned earlier that you had controlled folder access activated, yet you do not  use Defender.  Try turning it off if it is on.
    Quicken Premier Subscription, Windows 10 Home
  • rmk28027
    rmk28027 Member ✭✭
    > @Bob_L said:
    > You mentioned earlier that you had controlled folder access activated, yet you do not  use Defender.  Try turning it off if it is on.

    My understanding is that Controlled folder access is a function of Windows Defender. Since I am not running Windows Defender how would I access Controlled Folder Access.
  • Bob_L
    Bob_L SuperUser ✭✭✭✭✭
    You said you were.  See my instructions earlier regarding it above and verify it is not turned on anyway.
    Quicken Premier Subscription, Windows 10 Home
  • rmk28027
    rmk28027 Member ✭✭
    My earlier comment stated "Since I am running Kaspersky, Windows Defender is switched off. As far as I can tell Kaspersky does not have a features similar to CFA."

    Sorry for the miscommunication.

    Am I correct in my belief that CFA require Windows Defender to be activated?
  • Bob_L
    Bob_L SuperUser ✭✭✭✭✭
    “Bob L - It will launch if I open the shortcut. I have not tried deleting the QUSER.INI file. I checked and Controlled Folder Access activated.”


    So please check like you did before.  Since I have Defender,I cannot verify If that is possible or not.
    Quicken Premier Subscription, Windows 10 Home
  • UKR
    UKR SuperUser ✭✭✭✭✭
    How about this?

    Quicken does not remember last used data file name

    • Looking at the Quicken folder with Windows File Explorer make sure that the data file name does NOT have a blank space at the end of the name portion, e.g. QDATA_.QDF (where the underscore represents a blank space)
    • Check to ensure that the file QUSER.INI  in
      C:\Users\your_username\AppData\Roaming\Quicken\Config
      (or C:\Users\your_username\AppData\Roaming\Intuit\Quicken\Config in older Quicken versions)
      is not set to Read Only. Your Windows User Account must have proper security access to this file and all subfolders and folders above it, all the way up to the root directory.
      This file contains the list of recently used file names.

  • Greg_the_Geek
    Greg_the_Geek SuperUser, Windows Beta ✭✭✭✭✭
    You could try booting your computer into Safe Mode with Networking and then starting Quicken to see if it will open a data file.
    Quicken Subscription HBRP - Windows 10
  • rmk28027
    rmk28027 Member ✭✭
    I rebooted in Safe Mode launched Quicken and had the same problem.

    However, I then decided to restore Windows to a previous version. After restoring to a week old system backup I launched Quicken and the problem was solved, SORT OF. When Quicken opened it opened a previous version of the .QDF file. I then opened a copy of the most recent version of the .QDF file, closed Quicken and when I went to launch Quicken again the old problem reappeared, i.e., the program asked for me to specify what data file to use.

    When I went back to the old .QDF I could close and open Quicken with no problem.

    My assumption therefore, is that the problems were caused by a corrupted data file.
  • NotACPA
    NotACPA SuperUser, Windows Beta Beta
    "My assumption therefore, is that the problems were caused by a corrupted data file. "
    That sounds like an AWFULLY good assumption.
    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
This discussion has been closed.