Home Quicken for Mac Errors and Troubleshooting (Mac)

Bug in Add New bill sequence

nwiknernwikner Member
There is an error when adding new bills / scheduled transactions. If the transaction frequency is not one month, then the default dates and frequencies displayed in the dialogs are incorrect. I went to the trouble of carefully documenting this with screen shots, but there appears to be no way to upload screen shots to this forum. So here is a link to the screenshots:

 [removed link/attached screenshots]

Comments

  • jacobsjacobs SuperUser ✭✭✭✭✭
    @nwikner  Thanks for the detailed documentation. If I understand correctly, what you're reporting is a cosmetic bug on the schedule panel prior to clicking the Save button, right? It actually works correctly in terms of scheduling an annual payment, and if you open the transaction after saving it, the Schedule window correctly shows annual payments for the next 5 years. The problem is just that the "Next 5 Payments" information doesn't update before you click Save, right? So it's disconcerting, but if you click Save, it does the right thing.

    I thought I saw the same thing initially, but when I tried a second time (and additional subsequent times) to replicate this, it worked exactly as I'd expect. I wonder if something need to get initialized and then it works fine?)Could you try repeating it now?

    Here's what I see. I clicked the Schedule button on my register and say I want to create a new transaction. When I get to the Schedule screen, it defaults to monthly starting today:

    I then changed the frequency to yearly:

    As expected, it now shows transactions starting today and over the next 4 years of today's date.

    I repeated this with an existing transaction and got the same result. I repeated this by first changing the start date to a different date, then changing frequency to yearly. In each case, it worked as expected. 

    As for what you said about it not picking the correct starting date, I think it's a toss-up whether it should assume starting today or one year from today. So I don't see what it did in your case as a bug. You manually changed the start date, then changed the frequency; it left the start date alone. Had you set the start date to what you wanted: either 3/29/19 is you hadn't already entered the transaction for this year, or 3/29/21 if you wanted to start the schedule next year, and then selected Yearly, I suspect it would have worked correctly.

    (P.S. Your screen shots are fine. The administrators of this site have made posting images inline, as I did above, a "privilege" you earn after you have 50 points, which comes with more posting. There used to be scam service providers who would post images with their phone number to call for Quicken support, even though they weren't the actual Quicken Support and would charge people significant money to fix their problems. This points-based privilege has stopped the scammers, at the cost of inconveniencing new posters a bit.)

    QMac 2007 & QMac Subscription • Quicken user since 1993
  • nwiknernwikner Member
    For me it defaulted to monthly with NEXT month starting date. When I changed to yearly it changed to yearly Starting one year PLUS one month from now, instead of 1 year from now. So it's more than cosmetic.
  • jacobsjacobs SuperUser ✭✭✭✭✭
    It depends if you're creating a new scheduled transaction, or scheduling an existing transaction (which you did). Try it, and you'll see what I mean: Click the Schedule icon and select New Schedule Transaction. It will default to monthly with the first date as today; change it to yearly, and it will be a year from today.

    But if you click the Schedule button and select Schedule Selected Transaction, it will default to monthly with the first date one month after the transaction you selected. That makes sense to me; if you've selected a transaction that already exists for today, the default starting date is a month from today. If you then change the schedule to yearly, it adds a year to that date; if you instead want it a year from today, you need to enter that date first, then select yearly, and it will not be off by a month. 
    QMac 2007 & QMac Subscription • Quicken user since 1993
  • nwiknernwikner Member
    I simply disagree. If one is using an existing transaction as the basis for a series of transactions, then the schedule should ALWAYS use the existing transaction's date as the base date for the schedule. So if I change the interval to yearly, the dialog should automatically change the date of the first scheduled transaction to be 1 year from the base transaction. This would be far more intuitive, and cause far fewer scheduling errors.
  • nwiknernwikner Member
    Of course that goes for every other possible scheduling interval.
  • jacobsjacobs SuperUser ✭✭✭✭✭
    @nwikner  I'm not disagreeing that the interface could be better. I was simply saying that there isn't a bug here, because there is logic to the way it works now. The product manager has indicated that they may tweak the interface of this panel in a future update, because the little triangle with all the additional scheduling options has proven to confuse a lot of users as well.

    Meanwhile, any time you want to schedule something, just enter the date of the next transaction first, and then select the frequency -- even though they appear in the opposite order on the screen.
    QMac 2007 & QMac Subscription • Quicken user since 1993
This discussion has been closed.