Visual audit - font and element clean up

YingDave Member ✭✭✭✭
Why can you specify the register font, but this does not update the investment accounts. Why do the fonts used on the register settings (see attachment) look so scratchy and 1980s compared to the rest of the menus. The Account bar seems to use a different font again.

Perhaps the register settings font is getting it from Windows non-Unicode display setting or something - but in this day and age it should not be that kind crappy font for menus anyway. There are other elements around the program that are also inconsistent.
1 votes

Implemented · Last Updated


  • UKR
    UKR SuperUser ✭✭✭✭✭
    Every screen, menu bar, popup view and the investment registers use Windows settings to control font size, style, etc. The only exception are the fonts you can choose for your bank register displays and report previews.
    Only a Quicken programmer could answer why the investment register display method differs from the bank registers.

    Font size problems? Display issues? (Windows)

    If you are using a version of Quicken at the Quicken 2019 US R 19.44 patch level or newer and you have previously made the following Compatibility change, please undo the change.
    Users of other Quicken versions please try the following:

    • Close Quicken !!! (This process won't work while Quicken is running!)
    • Check the Compatibility tab settings in your Quicken Desktop program icon:
    • In the Windows Start Menu right-click the Quicken icon. Select "Open File Location". This brings up a Windows File Explorer window. Right-click the highlighted Quicken shortcut line item.
    • Go to the traditional Windows Desktop and right-click the Quicken program icon.
    • Now click Properties.
    • Select the Compatibility tab.
    • Uncheck all settings.
    • Windows 7, 8.1: Check "Disable display scaling on high DPI settings". 
      Windows 10:  Check "Override high DPI scaling behavior. Scaling performed by:" and select "Application"  (also try the other available options repeating the entire procedure!)
    • Be sure to uncheck the "Run this program in compatibility mode for [older Windows version]" setting.
    • Click the "Change settings for all users" button.
    • Click Apply and exit.
    • Now start Quicken and see if that makes a difference.

    Some additional tuning suggestions:

    • Unless absolutely required, try not to use "View / Use large fonts"
    • Try setting the bank account registers to use a different font style or size: go to Edit / Preferences / Register, click the Fonts button and try different fonts.
    • Try adjusting the bank account registers' row height: go to Edit / Preferences / Register, choose among the available Row Height choices: Compact, Comfortable or Standard
    • If all else fails, try changing Windows Control Panel / Display options for "Make text and other items … smaller or larger" to use a different scaling level.

  • YingDave
    YingDave Member ✭✭✭✭
    Thanks UKR, I cycled through every setting for Windows 10 in the "High DPI scaling override" from Application, System, System (Enhanced) with Quicken not running, but it made no difference. Fonts for menus are clean, fonts for register settings, tab bar are scratchy looking. Appreciate the time to reply though...
  • UKR
    UKR SuperUser ✭✭✭✭✭
    Let's not forget that font support for investment accounts was introduced a while ago.
    Font support for the selection popups is, AFAIK, Windows version specific and also depends on screen size, screen resolution and display magnification settings. Looking at the image supplied by the OP, I suspect that he is/was on Windows 7 or older at the time of posting.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    I personally think this should be set to "Implemented".
    As @UKR said, the font selections do now affect the investment accounts, and when I compare the non investment account menus to the investment menus there isn't any difference in the fonts.

    This is my website:
This discussion has been closed.