Home Quicken for Windows Errors and Troubleshooting (Windows)

No text displayed for Register Context Menu items

There is no text displayed for the Register's Context menu (right click menu). This coincided with an upgrade to version R24.11 build 27.1.24.11. OS = Win 10. Issue first reported in Jan 25, 2020. Continues through Jun 25, 2020 with all Quicken updates including latest Version 27.24, Build 27.1.27.24. I suspect it has something to do with High DPI monitor but manipulation of Quicken Compatibility Properties has not been helpful. Any help out there ?

Comments

  • UKRUKR SuperUser ✭✭✭✭✭
    Can you capture a snapshot of what this looks like on your monitor and show us, please?
    Capture snapshot while menu is open using Shift-PrtScreen, then open MS Paint. Paste image into MS Paint. Redact image to black out sensitive parts, save to .PNG file and attach file to your comment.
  • rdemurordemuro Member ✭✭
    Thanks UKR for checking in. The problem I was having is shown in the attachment. I have since resolved the issue.

    Here's the full story:

    When I received my Win 10 laptop, Lenovo Thinkpad 20MES25V0G, I was unhappy with the Windows default display font. For reasons that I can't determine, selecting a different font is not possible as it was with Win 7 display settings. So I Googled & found a registry hack that allowed me to change the font.

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts]
    "Segoe UI (TrueType)"=""
    "Segoe UI Bold (TrueType)"=""
    "Segoe UI Bold Italic (TrueType)"=""
    "Segoe UI Italic (TrueType)"=""
    "Segoe UI Light (TrueType)"=""
    "Segoe UI Semibold (TrueType)"=""
    "Segoe UI Symbol (TrueType)"=""

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes]

    "Segoe UI"="Arial Bold"

    This provided the display font I wanted & the context menus of Quicken worked as expected (at least at I don't remember noticing). It wasn't until upgrading Quicken to R24.11 build 27.1.24.1, that I noticed a problem. By then I had been using the laptop for several months with my preferred font without noticing any issues for all other programs (Office 365, Adobe Acrobat, etc.), so it did not occur to me that the font change might be an issue.

    Shortly after my Jun 25 post I reverted back to to Segoe UI using a similar registry hack:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts]
    "Segoe UI (TrueType)"=""
    "Segoe UI Bold (TrueType)"=""
    "Segoe UI Bold Italic (TrueType)"=""
    "Segoe UI Italic (TrueType)"=""
    "Segoe UI Light (TrueType)"=""
    "Segoe UI Semibold (TrueType)"=""
    "Segoe UI Symbol (TrueType)"=""

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes]

    "Segoe UI"="Segoe UI Bold"

    This fixed the Quicken context menu issue and provided a display font that I could live with.

    It was painful but I'm glad to have it resolved.
Sign In or Register to comment.