BUG? memorized transaction with splits only enters first split line on existing transactions

Running R27.28

When editing an existing transaction with the name of a memorized split transaction only the first line of the split is entered. This is trust even if there is no category in the existing transaction.

If the same name is used for a NEW transaction all the splits are present in the new transaction.

This happens whether or not the memorized transaction is by % or not, locked or not.

I have validated my file.

Comments

  • splasher
    splasher SuperUser ✭✭✭✭
    I tried following your instructions and could not duplicate.  How about a more detailed description of the transaction's state before starting and what you are doing that displays the issue?
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited July 2020
    splasher said:
    I tried following your instructions and could not duplicate.  How about a more detailed description of the transaction's state before starting and what you are doing that displays the issue?
    I'm able to reproduce the described behavior (using R27.24):

    Save a transaction without a category to a register.
    Replace the current payee of the transaction with that of a split Memorized Payee.
    The transaction's category is automatically set to the category of the first entry of the split on the Memorized Payee.

    Note: If we select a non-split Memorized Payee, the transaction category is automatically set to the category of the Memorized Payee.

    Also note: Unless the transaction's category is empty, editing the payee does not reset the category.

    I think the expected behavior is changing the payee of an existing transaction should not alter any of the transaction's other fields - even an empty category.  I do not know if this is a new behavior.
  • Doubleplays
    Doubleplays Member ✭✭
    I think the issue is more direct and easily reproduced.

    After updating to R27.28, simply clicking on a new Downloaded Transaction which matches to a Split Memorized Payee causes QuickFill to enter it into the Register but the Category is no longer filled with "--Split--" like it used to but with the first Category in the Memorized Payee's split list of Categories.
  • I have the same issue for several months, now. Previously, when entering a transaction (manually) for a memorized payee, the splits would be available and a notice that the splits don't match would appear. A split dialogue would open and I could adjust the splits. Now, none of the split information populates and the split dialogue box is empty.
  • K109
    K109 Member ✭✭
    I am running R 29.12 and having the same issue as Claude Holley. I go to enter the memorized transaction, edit and verify all of the splits, yet when I hit enter, the transaction is entered without a category and the amount can change to something completely different.
  • jon
    jon Member ✭✭
    I'm still seeing this bug in R30.14
  • Quicken_Tyka
    Quicken_Tyka Alumni ✭✭✭✭
    Hello Jon,

    Thank you for the response although I apologize that you continue to experience this issue.

    I am currently trying to recreate this issue that you have described however I do not see this behavior.

    I have a memorized split-- I edit an existing transaction and apply this payee/split and I see all lines of the split applied.



    I have a few additional questions to help me isolate what you are experiencing further.

    First, do you have amounts set for the split lines? Next, is this an income or expense?

    How many split lines are there in this transaction? Last, is this a downloaded transaction that you are editing?

    You may also capture a screenshot and drag the screenshot to the comment box if that helps to explain what you are seeing.

    Please let me know!

    -Quicken Tyka

    ~~~***~~~
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited December 2020
    Hello Jon,

    Thank you for the response although I apologize that you continue to experience this issue.

    I am currently trying to recreate this issue that you have described however I do not see this behavior.

    I have a memorized split-- I edit an existing transaction and apply this payee/split and I see all lines of the split applied.



    I have a few additional questions to help me isolate what you are experiencing further.

    First, do you have amounts set for the split lines? Next, is this an income or expense?

    How many split lines are there in this transaction? Last, is this a downloaded transaction that you are editing?

    You may also capture a screenshot and drag the screenshot to the comment box if that helps to explain what you are seeing.

    Please let me know!

    -Quicken Tyka

    I continue to have no difficulty reproducing the described behavior in R30.14.

    The memorized payee's transaction I happened to use just now has 4 entries with amounts in the split and is an expense and the transaction without a category being edited is unmatched and manually entered.
Sign In or Register to comment.