Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Super Validate finds same errors every day

Ever since I installed Quicken Premier 27.28, I run Super Validate every day, and I get the errors under #1 below. The "ACCT_206 seems to increment - yesterday the errors were "ACCT_205".

After Super Validate completes successfully, I run it immediately, again. Then I get one of the errors under #2 below. 

Then I run Super Validate a third time, and it's totally clean.

I exit and immediately restart, and run Super Validate - clean.

I do a One Step Update, downloading all accounts, and pricing information. Once it's finished, I run Super Validate again, before trying anything - it's clean.

Then, today I had 4 or 5 transactions download on 2 credit cards. All I did was Accept one at  time on one credit card, then click done. Then on the Other card, I just clicked accept all. I changed the categories on 2 of the transactions as I recall.

Then, I ran Super Validate again, and errors have returned, as in #3 below! Now it now says ACCT_207.

Is this a bug or something I can look for/provide more information for?

1. Errors:
QDF:
Validating your data.
Quicken repaired damaged transaction index.  No action required.
Quicken found an invalid transaction and removed it. "ACCT_206"  0/ 0/1900
Quicken repaired some transaction information.  No action required.
 "ACCT_206"  0/ 0/1900
Quicken found an invalid transaction and removed it. "ACCT_206"  0/ 0/1900
Quicken repaired some transaction information.  No action required.
 "ACCT_206"  0/ 0/1900
Quicken found an invalid transaction and removed it. "ACCT_206"  0/ 0/1900
Quicken repaired some transaction information.  No action required.
 "ACCT_206"  0/ 0/1900
Quicken found an invalid transaction and removed it. "ACCT_206"  0/ 0/1900
Quicken repaired some transaction information.  No action required.
 "ACCT_206"  0/ 0/1900

2. Error:
QDF:
Validating your data.
Repaired your data file by removing a damaged category. Please check your category list for missing categories by going to Tools>Category List.

3. Errors:
QDF:
Validating your data.
Quicken repaired damaged transaction index.  No action required.
Quicken found an invalid transaction and removed it. "ACCT_207"  0/ 0/1900
Quicken repaired some transaction information.  No action required.
 "ACCT_207"  0/ 0/1900
Quicken found an invalid transaction and removed it. "ACCT_207"  0/ 0/1900
Quicken repaired some transaction information.  No action required.
 "ACCT_207"  0/ 0/1900
Quicken found an invalid transaction and removed it. "ACCT_207"  0/ 0/1900
Quicken repaired some transaction information.  No action required.
 "ACCT_207"  0/ 0/1900
Quicken found an invalid transaction and removed it. "ACCT_207"  0/ 0/1900
Quicken repaired some transaction information.  No action required.
 "ACCT_207"  0/ 0/1900
Quicken found an invalid transaction and removed it. "ACCT_207"  0/ 0/1900
Quicken repaired some transaction information.  No action required.
 "ACCT_207"  0/ 0/1900
Quicken found an invalid transaction and removed it. "ACCT_207"  0/ 0/1900
Quicken repaired some transaction information.  No action required.
 "ACCT_207"  0/ 0/1900
«13

Answers

  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited August 2020
    I suspect your Quicken file may not be repairable.  

    Note: Before performing the Validate and Repair, you should perform a File > File Operations > Copy... and perform the Validate and Repair on the copy.  If the Copy... fails because the Quicken file is corrupt, we may allow Quicken to attempt to step over the corruption by pressing the Ctrl and Shift keys when we select File > File Operations > Copy....

    Also note: Validate and Repair will not detect and correct all corruption.  The safest way recover from corruption is to restore a backup: https://www.quicken.com/support/advanced-data-file-troubleshooting-correct-problems-quicken-windows
  • Don Awalt
    Don Awalt Member ✭✭✭✭
    edited July 2020
    @Sherlock thanks for the reply (btw my fave movies of all time are Basil Rathbone and Nigel Bruce as Sherlock Holmes/Dr. Watson, I have them all on DVD haha!).

    When I closed out Quicken prior, I had not run a super validate - so I suspect the ACCT_xxx errors were still there.

    I did the Copy - then said use the new file.  The Copy completed fine. I chose all the default settings for date range and check boxes.

    I ran the Super Validate - it just reported this, and all else was clean:
    Repaired your data file by removing a damaged category. Please check your category list for missing categories by going to Tools>Category List.

    I decided to exit, restart, and do ANOTHER Copy. All completed fine, I used the new copy. I ran Super Validate - it was fine. I also did a Repair investing lots and repair price history, no errors were found.

    I did a One Step Update -- EDIT: transactions came down from Dec 2019! I seem to remember this being reported on the forums back then. I got about 12 capital gain transactions from T Rowe Price mutual funds that downloaded, must have been triggered either by the copy, the price rebuild, or the investing lot rebuild? The transactions all had Dec 2019 dates on them. 

    EDIT2: I deleted all the incoming mutual fund transactions without accepting them, reran Super Validate, all is still clean. Since before the problem seemed to occur with a credit card transaction, I guess I'll have to wait a day or two.

    This could still be a bug right? Accepting a credit card transaction could be inserting something wrong into the data file?






  • Don Awalt
    Don Awalt Member ✭✭✭✭
    @Sherlock and everyone else interested, the error occurred again this morning, with a new "ACCT_" number. But I have some more information for you now.

    I was doing a Super Validate after each step, as well as before I started. This time, I did an accept of one deposit and one bill payment that was downloaded to my checking account, one at a time. After that, the same thing - first the ACCT_ errors shown below as error #1, then the category error shown below as error #2. After that, SV is clean each time it is run.

    So then I took your advice, and started checking backups. I had to go back to my June 20 backup to find a file that did not have the "ACCT" error #1 below in it!

    So, I restored to the June 20 backup version, then I ran SV - clean. I then downloaded transactions - of course a bunch came down for all accounts - I ran SV - clean. I went into my checking account, I accepted only two transactions of all the ones that downloaded, and then I ran SV again - the ACCT errors appeared in a formerly clean file from June 20! So, imho, THIS IS A BUG!

    What can we do to get Quicken to notice this thread? Doesn't this sound like a bug???

    ======================
    The error #1:
    QDF:
    Validating your data.
    Quicken repaired damaged transaction index.  No action required.
    Quicken found an invalid transaction and removed it. "ACCT_208"  0/ 0/1900
    Quicken repaired some transaction information.  No action required.
     "ACCT_208"  0/ 0/1900
    Quicken found an invalid transaction and removed it. "ACCT_208"  0/ 0/1900
    Quicken repaired some transaction information.  No action required.
     "ACCT_208"  0/ 0/1900
    Quicken found an invalid transaction and removed it. "ACCT_208"  0/ 0/1900
    Quicken repaired some transaction information.  No action required.
     "ACCT_208"  0/ 0/1900
    Quicken found an invalid transaction and removed it. "ACCT_208"  0/ 0/1900
    Quicken repaired some transaction information.  No action required.
     "ACCT_208"  0/ 0/1900

    Summary:
    Quicken repaired 1 accounts.  No action required.

    The error #2:
    QDF:
    Validating your data.
    Repaired your data file by removing a damaged category. Please check your category list for missing categories by going to Tools>Category List.
  • Greg_the_Geek
    Greg_the_Geek SuperUser, Windows Beta ✭✭✭✭✭
    What is the full path to the folder that contains your Quicken data file? Are you using OneDrive, Dropbox or Google Backup?
    Quicken Subscription HBRP - Windows 10
  • Don Awalt
    Don Awalt Member ✭✭✭✭
    @Greg_the_Geek I have used Dropbox, but through all of this I have had it turned off. The full path of my data file is C:\Users\Don\Dropbox\Quicken. I actually don't use the Windows 10 laptop for anything other than Quicken and light browsing with Edge. Nothing is installed on it outside of Office 365.
  • Don Awalt
    Don Awalt Member ✭✭✭✭
    @Greg_the_Geek as a test to ensure no conflicts with Dropbox from anywhere, even though I am sure it has not been running (as it can conflict if it has Quicken files open when Quicken tries to do a file operation as you probably know!), I did a restore of the good June 20 backup to a QDF file on my desktop - not part of the Dropbox file hierarchy at all. I then downloaded transactions, accepted to of the many, ran SV, and it had the same ACCT errors I have been reporting.  

    This sure seems like a bug to me...
  • Don Awalt
    Don Awalt Member ✭✭✭✭
    I just reported the problem to Quicken via Help, sent all the files including a sanitized data file. Is there anything else anyone wants me to try? I also added a link to this thread for the dev team to check. I sure hope they look at this!!
  • markus1957
    markus1957 SuperUser, Windows Beta Beta
    https://community.quicken.com/discussion/comment/20104060#Comment_20104060

    You may be seeing something similar to the issue in this post.  The under the hood temp accounts are not getting properly flushed when downloaded transactions are partially accepted.

    Hopefully the developers will take interest.
  • Don Awalt
    Don Awalt Member ✭✭✭✭
    Thanks @markus1957, I read that thread but didn't see any suggestions other than the copy process I did. Was there anything I missed in flushing the temp files or anything, that I should do? Or at this point it's time to just leave it the Quicken dev staff?
  • markus1957
    markus1957 SuperUser, Windows Beta Beta
    I think it's up to the devs now.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Has anyone submitted this as a problem? (Help -> Submit a problem)
    Couldn't hurt to help get their attention.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Don Awalt
    Don Awalt Member ✭✭✭✭
    I did, and I included a link to this thread.
  • Don Awalt
    Don Awalt Member ✭✭✭✭
    Note if anyone cares, this problem still occurs in Quicken Premier/Windows R28.10. It takes two Super Validates and then the file is clean. Do anything other than Accept All with Banking/Credit accounts on downloaded transactions, and it immediately appears. I sent my cleansed file to Quicken in July, but it still occurs.
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    Sherlock said:
    I suspect your Quicken file may not [be] repairable. 
    So do I. I suspect there is something corrupted deep the file which manifests when certain conditions occur. As opposed to there being a new bug in Quicken.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • markus1957
    markus1957 SuperUser, Windows Beta Beta
    I don't think it is unrepairable.  It appears that the under the hood temp files that normally get cleared after accepting transactions, do not get completely deleted when Accept All is not used.  That is, if a user goes back and forth between account registers and accepts individual transactions.

    The validation routines appear to clear out the temp accounts but when the user repeats the behavior of moving between accounts, the temp accounts get left as residuals.  Performing validation again will clean out the temp accounts.

    So, it's a repeatable error condition but not fatal to the file.  Until Quicken acknowledges the issue and fixes it, it's probably a good idea to run the validations frequently.  The other option would be to use Accept All for each account and avoid the issue entirely.
  • Don Awalt
    Don Awalt Member ✭✭✭✭
    @markus1957 I agree with your theory. The file is not corrupted. I have validated my file for years regularly, this is a bug that crept in. It's a shame Quicken doesn't even acknowledge there's an issue to look in to. Very frustrating for a subscription service, how hard can that be...
  • markus1957
    markus1957 SuperUser, Windows Beta Beta
    In each account, after accepting the last transaction in the download register, do you click the "Done" button?  Just wondering out loud, if in your use case, that "Done" might spawn the cleanup routine?  There is something going on when that button is clicked as it takes a few seconds to minimize the download register.
  • Don Awalt
    Don Awalt Member ✭✭✭✭
    Hi @markus1957, thanks for the reply. Yes I always click done if I do accept downloaded transactions individually! Good thought though.
  • Roper9456
    Roper9456 Member
    I have the same issue. I believe it is a bug as well.
  • Quicken_Tyka
    Quicken_Tyka Moderator mod
    Hello all,

    Thank you for taking the time to visit the Community to post your issue.

    Please navigate to Help > Report a Problem to send a problem report detailing what you are experiencing. 

    Please ensure all of the logs are checked to send as well as a sanitized data file if you are comfortable with doing so.

    You will not receive a response, for the submission, however, this information will be forwarded to our development team for research. 


    Thank you,
    -Quicken Tyka
    ~~~***~~~
  • Don Awalt
    Don Awalt Member ✭✭✭✭
    Thank you @Quicken_Tyka for the reply, but I used "Report a Problem", with logs, and even with a sanitized file, weeks ago. And you are right, I have not received any response and the problem can still be duplicated on the latest release.
  • Don Awalt
    Don Awalt Member ✭✭✭✭
    Quicken Premier/Windows R29.20...these bugs have been in Quicken for a long time and still are not fixed.

    1) I had a credit card payment transaction download today, which was not in my register - it auto pays from the credit card web site. I accepted it, and the Transfer reminder in Bills Income & Transfers did not recognize it to mark this month's transaction paid. I had to do it manually again. The Payee name matches perfectly, it was due today so the date was ok, there was nothing in Memo or Tag fields. Matching bills is just unreliable.

    2) As an experiment to test if this bug was still present, the same credit card payment transaction was used. I ran a Super Validate, file is clean. I did "Accept All" of the transaction, ran Super Validate again, all is clean. I went back to last night's backup and loaded that - downloaded my transactions again, Ran Super Validate - clean. I did "Accept" of the particular transaction, then "Done". Ran Super Validate, and as usual when "Accept" is used, it took two tries of Super Validate to clean everything up. Log says this:

    Quicken repaired damaged transaction index.  No action required.
    Quicken found an invalid transaction and removed it. "ACCT_22c"  0/ 0/1900
    Quicken repaired some transaction information.  No action required.
     "ACCT_22c"  0/ 0/1900
    Quicken found an invalid transaction and removed it. "ACCT_22c"  0/ 0/1900
    Quicken repaired some transaction information.  No action required.
     "ACCT_22c"  0/ 0/1900
    Quicken found an invalid transaction and removed it. "ACCT_22c"  0/ 0/1900
    Quicken repaired some transaction information.  No action required.
     "ACCT_22c"  0/ 0/1900

    Summary:
    Quicken repaired 1 accounts.  No action required.

    Then I run it a second time:
    Repaired your data file by removing a damaged category. Please check your category list for missing categories by going to Tools>Category List.

    Then it's clean.

    So the Accept button remains worthless. The file is FINE. There is no evidence of any problems otherwise. Something in my file causes the Accept of credit card or banking transactions to get corrupted. It's easily duplicatable. I have in the past sent sanitized file to Quicken to investigate, never heard a word. These are both long standing bugs that Quicken should FIX. Please.

    I know they will ignore this, I'll keep posting it from time to time until they acknowledge it, or until I just get tired of this and move on to a better product.
  • Roger Snook
    Roger Snook Member ✭✭
    Me too Me too! I ALWAYS get the "Repaired your data file by removing a damaged category. Please check your category list for missing categories by going to Tools>Category List." and OCCASIONALLY get the ""ACCT_NNN" 0/ 0/1900" error. And this was AFTER a clean make of a file to cut down my history to only 10 years.
  • Roger Snook
    Roger Snook Member ✭✭
    > @Roger Snook said:
    > Me too Me too! I ALWAYS get the "Repaired your data file by removing a damaged category. Please check your category list for missing categories by going to Tools>Category List." and OCCASIONALLY get the ""ACCT_NNN" 0/ 0/1900" error. And this was AFTER a clean make of a file to cut down my history to only 10 years.

    Of course, of course - now that I post that, I ran a SECOND super val and that error goes away?!?!?!!!! Geesh.
  • Don Awalt
    Don Awalt Member ✭✭✭✭
    > @Roger Snook said:
    > Me too Me too! I ALWAYS get the "Repaired your data file by removing a damaged category. Please check your category list for missing categories by going to Tools>Category List." and OCCASIONALLY get the ""ACCT_NNN" 0/ 0/1900" error. And this was AFTER a clean make of a file to cut down my history to only 10 years.

    Of course, of course - now that I post that, I ran a SECOND super val and that error goes away?!?!?!!!! Geesh.
    Yes it takes to the third time for all the errors to clear- every time for me. I never got a reply from bug submission either. Deplorable.
  • I get the same type of error. I am having trouble during One Step Update by it ending before all accounts have been downloaded. I run Update on the accounts that were listed as still running when the Update window closed and it downloads transactions for those accounts if there are any. Even when it appears to have completed successfully I sometimes run it again on the checking account knowing there have to be transactions. Sure enough there are transactions to download. The last time I downloaded all the accounts and then just the checking account I got no transactions. I decided to run a Validate and Repair to see what might turn up. I got the same type of report mentioned above but mine had 59 occurrences of ( Quicken found an invalid transaction and removed it. "ACCT_811" 0/0/1900 Quicken repaired some transaction information. No action required. "ACCT_811" 0/0/1900 ) The number 59 may also be the number of times I have run One Step Update since the last time I ran Validate and Repair. I am now keeping a log of every time I run One Step Update to see If my assumption is correct.
  • Came across this thread i am having the same exact issues Don described. any resolution? Quicken HB&R R30.14
  • more details... file had passed validation before and after donwloading new transactions and accepting one by one, got the below

    QDF:
    Validating your data.
    Quicken repaired damaged transaction index. No action required.
    Quicken found an invalid transaction and removed it. "ACCT_814" 0/ 0/1900
    Quicken repaired some transaction information. No action required.
    "ACCT_814" 0/ 0/1900
    Quicken found an invalid transaction and removed it. "ACCT_814" 0/ 0/1900
    Quicken repaired some transaction information. No action required.
    "ACCT_814" 0/ 0/1900
    Quicken found an invalid transaction and removed it. "ACCT_814" 0/ 0/1900
    Quicken repaired some transaction information. No action required.
    "ACCT_814" 0/ 0/1900

    Summary:
    Quicken repaired 1 accounts. No action required.


    QEL:
    No read errors.

    QEL:
    All internal consistency checks passed.

    [Wed Dec 30 12:18:44 2020]
    Analyzing securities.

    Number of old style Buy/Cash investment transactions updated: 475/0
    No out-of-range security references found.

    Validation has completed.
  • Don Awalt
    Don Awalt Member ✭✭✭✭
    FYI @Quicken_Tyka, this problem still exists in R31.6, 6 months later. I have submitted as you requested above, as have others I am sure. Can you give us an update on this problem? It is still as easy to duplicate, corrupts the file, takes two Super Validates to clean it up. Does someone need another sanitized file submitted? Is it being researched still? Please fix this, we can't do anything with banking/credit card transactions other than accept all and then edit them to avoid corruption. Thanks..
  • quick20
    quick20 Member ✭✭✭
    I have the same exact issue as well. After the 2nd validate all errors go away. But, the next day when you update and accept downloaded transactions the same invalid transactions and repair information is listed in Validate/Super Validate. I reported to Quicken as well, but this seems like an ongoing issue. I wonder if it is even being addressed by Quicken?
Sign In or Register to comment.