Home Quicken for Mac Registers & Transactions (Mac)
Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Hide hidden payees from showing up as autofill names in Payee field (Q Mac)

Scott RoseScott Rose Mac Beta Beta
When we're typing up a new transaction in Quicken Mac, hidden payees don't show up in the drop-down menu of "Best Matches" that appears underneath the Payee field.

This is fantastic. This is perfect. This is exactly the behavior that we want. :)

However, hidden payees STILL SHOW UP in the Payee field as an autofill (type-ahead) option within the payee field itself. We would love for hidden payees to be hidden from this area as well.

The reason for this is because we simply don't have a need for old, unused, never-to-be-used-again payee names from showing up within the payees field.

Furthermore, some of these old payee names even have emotional baggage connected with them as well, which we would like to not be reminded of. For example, we type "Parking" into the Payee field multiple times per week, but every time we type in the word "Parking", Quicken Mac's autofill type-ahead feature shows us "Park Veterinarians", which sadly reminds us of our beloved furry friends who are no longer with us anymore. :( 

Yes, we could simply rename the old "Park Veterinarians" payee to a completely different name, but that actually would change the integrity of our past data. And this payee is just one example out of 5,000 hidden payees, so we wouldn't want to change the names for dozens/hundreds of payees from the past that we don't need to see anymore.

In general, if a payee is never going to be used again in the future, we would like to hide that payee and have it hidden from ALL parts of the user interface when we are creating/editing transactions.

Thanks! :)
Tagged:

Comments

  • jacobsjacobs SuperUser, Mac Beta Beta
    I agree that it makes sense for Hidden Payees not to show up to auto-complete in the Payee field. Good suggestion!

    ----

    Worse, I'm finding that Hidden Payees not only auto-complete, but shows up in the Best matches pop-up list if this Hidden Payee has a QuickFill rule.

    If a Hidden Payee contains the text you enter, and if there is no QuickFill rule for the Payee, then the Payee does not show up in the Best Matches list. This is the expect behavior.

    Example: I have a Payee called "My Test Payee" which has one transaction in the database and is marked as a Hidden Payee. I create a new transaction and type "test" in the Payee field, and "My Test Payee" does not show up in the Best matches list. Good.

    If a Hidden Payee contains the text you enter, and there is a QuickFill rule of for the Payee, then the Payee shows up in the Best Matches list as if it were not hidden, showing both the "naked" Payee name and also the Payee name plus the QuickFill rule. This is not what we would expect/want.

    Example: I have a Payee called "My Test Payee" which has one transaction in the database, has one QuickFill rule for Category=Groceries, and is marked as a Hidden Payee. I create a new transaction and type "test" in the Payee field, and the Best Matches list shows "My Test Payee" twice: by itself, and with the Category=Groceries. This is not the expected behavior because this Payee is Hidden.

    This seems like a bug to me. The existence of a QuickFill rule should not override the Hidden status of the Payee.
    Quicken Mac Subscription • Quicken user since 1993
  • Hello all,

    This is being changed from an Idea to a Discussion-- what you are experiencing is a bug that has been acknowledged.

    I would take a moment to review and bookmark the previous discussion on the topic, available here.

    The ongoing thread for this bug and will be updated as soon as more information becomes available. 

    Thank you,
    -Quicken Tyka
    ~~~***~~~
  • jacobsjacobs SuperUser, Mac Beta Beta
    @Quicken_Tyka  Thanks for noting that this is a known bug. (It's a little unusual that it has gone a few releases with out being fixed.)

    But could you clarify whether the bug report you were describing pertains only to the part Scott mentioned above, e.g. that Hidden Payees auto-complete in the Payee field when entering a transaction?

    Because my post above describes a second bug which I don't think is mentioned in the other thread, and I don't know if I've seen noted before. Namely: if a Hidden Payee has a QuickFill rule, it shows up in the Best matches list, exactly as it would if the Payee were not Hidden. Is this a part of the bug report you referred to in the other thread as CTP-775? If not, it should be added to that bug, or a new bug report added. I did a bunch of test with this, so if you read my post, I think you'll find it easy to replicate, but let me know if you don't.
    Quicken Mac Subscription • Quicken user since 1993
  • Hello @jacobs

    Thank you for the response, I apologize for the lack of clarity.

    The CTP-775 is in regards to hidden payees showing up as an autofill option and does not include any details regarding QuickFill.

    I was able to successfully recreate the second issue and I have submitted a second bug ticket for the issues with Quickfill and hidden payees.

    I will be sure to provide any updates regarding both tickets as soon as more information becomes available.

    -Quicken Tyka
    ~~~***~~~
  • Hello @Scott Rose and @jacobs

    You have not done so already, may I ask if you still see this issue after updating to the new 5.18. release?



    I no longer see this issue so it should be resolved, please let me know if you see otherwise! 

    -Quicken Tyka
    ~~~***~~~
  • Scott RoseScott Rose Mac Beta Beta
    Yes, this is now fixed for me in 5.18. Fantastic! :) Thank you! :)
  • jacobsjacobs SuperUser, Mac Beta Beta
    edited September 2020
    Yup, fixed -- and both instances of the bug. (The release notes for some reason don't mention any of the bug fixes in 5.18.)
    Quicken Mac Subscription • Quicken user since 1993
  • Scott RoseScott Rose Mac Beta Beta
    edited October 2020
    @Quicken_Tyka

    Unfortunately, this feature now has a **BRAND NEW BUG** in it:

    QuickFill no longer works at all for transfers. :( 

    If you have a QuickFill Rule where the category is set to Transfer to another account (in other words, the category name is "Transfer:[Account Name]"), the transfer category will no longer automatically QuickFill on any new transactions. :( 

    This was working fine before 5.18, but now it is broken. I am currently running 5.18.2, and the same bug exists.

    How can I officially file this as a bug with the Quicken Mac team? And I really hope that you guys can fix this soon, because I use transfers all the time. :)
  • Quicken_TykaQuicken_Tyka Moderator mod
    Hello @Scott Rose

    Thank you for the response and the additional details.

    This behavior has been reported previously in the thread here.

    The thread above will be updated when more information is available.

    -Quicken Tyka
    ~~~***~~~
  • Scott RoseScott Rose Mac Beta Beta
    Hi @Quicken_Tyka,

    Fantastic, thanks so much! :) Do you know if this problem has been officially submitted as a bug to the Quicken team, or if I need to go through the "Report A Problem" process that you outlined in that other thread?

    Thanks,
    Scott
  • Quicken_TykaQuicken_Tyka Moderator mod
    Hello @Scott Rose

    I have not gotten a ticket number just yet, so I would go ahead and Report a Problem.
     
    The more information the better!

    ~~~***~~~
  • Scott RoseScott Rose Mac Beta Beta
    Great, thank you!
  • Frank O'NeilFrank O'Neil Member ✭✭
    Hi,
    My issue is a bit different but related. With the new release, many of my Payees that should autofill are now marked as hidden. These are payees that have been used often and recently. I appreciate the ability to hide old, unused payee autofills, but wondering if there is a criteria that resulted in them being hidden without my action?
This discussion has been closed.