Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Bank of America 2FA

BradC
BradC Member ✭✭
Is there any way to keep from having to do the 2FA code for Bank of America every time I download transactions?

Personally I find this really annoying and have completely stopped using some banks because of it.

Comments

  • Hello @BradC

    Thank you for taking the time to visit the Community to report this issue, although I apologize that you have not received a response.

    I have a few questions to help me better understand what could be happening. First, how are you updating transactions in Quicken?

    Do you run a One Step Update or Update now from the gear in the register? If you have not run an update now, will please do so and see if you are still prompted for the 2FA?

    Last, have you visited the Bank of America website to confirm that the requirement for 2FA has been disabled?

    Please let me know!

    -Quicken Tyka
    ~~~***~~~
  • BradC
    BradC Member ✭✭
    > Do you run a One Step Update or Update now from the gear in the register? If you have not run an update now, will please do so and see if you are still prompted for the 2FA?

    Either one produces the same result.

    > Last, have you visited the Bank of America website to confirm that the requirement for 2FA has been disabled?

    The requirement cannot be disabled on their website.
  • BK
    BK Member ✭✭✭✭
    BradC said: The requirement cannot be disabled on their website.
    Just as an FYI, on my BofA I am able to disable 2FA and instead enable "Remember this device" option.  I do that in Profile > Security Center.  Perhaps their security implementation is slightly different from state to state or they are in the process of making changes?
    - Q Win Deluxe user since 2010, US Subs R32.12
    - I don't use Sync, Cloud, Mobile, Web, Bill Pay/Mgr, Tax
    - Techie, Win10 Pro x64 20H2
  • BradC
    BradC Member ✭✭
    This is how mine is setup.

    The "problem" is that on the Quicken side they should be preserving the cookies so the "device" in their cloud looks like the same device all the time, just like it does on my computer.
  • BK
    BK Member ✭✭✭✭
    This is strange since our BofA security setups are 100% identical and yet I have never encountered an issue (nor other Quicken BofA users apparently?).  My BofA is setup as Express Web Connect (EWC).  Long shot: Any way you are clearing your cookies?  Such as using CCleaner or a browser setup to clean cookies upon exit?  I have added '*.bankofamerica.com' in my cookies to save.  Worth investigating.
    - Q Win Deluxe user since 2010, US Subs R32.12
    - I don't use Sync, Cloud, Mobile, Web, Bill Pay/Mgr, Tax
    - Techie, Win10 Pro x64 20H2
  • BradC
    BradC Member ✭✭
    It's not the browser settings. Everything works fine in my browser. Only Quicken has an issue.
  • Hello @BradC,

    Thank you for reaching out to the Community and telling us about your issue and I'm sorry to see that this has not been resolved yet.

    If you haven't already I suggest you start by trying to reset the account connection. I do recommend saving a backup first (just in case) and then following steps 1, 2, and 4 in this support article. For step 4, I recommend following the section titled To reset or repair the connectivity of an online account, first before trying the other 2 options found in step 4. 

    Let us know how it goes!
    -Quicken Anja
  • BradC
    BradC Member ✭✭
    > @Quicken Anja said:
    > Hello @BradC,
    >
    > Thank you for reaching out to the Community and telling us about your issue and I'm sorry to see that this has not been resolved yet.
    >
    > If you haven't already I suggest you start by trying to reset the account connection. I do recommend saving a backup first (just in case) and then following steps 1, 2, and 4 in this support article. For step 4, I recommend following the section titled To reset or repair the connectivity of an online account, first before trying the other 2 options found in step 4. 
    > Let us know how it goes!


    That was a terrible idea. Not only did the reset process generate two 2FA challenges during the process but it broke the connection when it was done. The troubleshooter fixed it but it's still doing challenges on every update.
  • pairof9s
    pairof9s Mac Beta
    I'm right there with you BradC...every time I run sync on my desktop Quicken (for Mac) or open the Quicken Mobile app, I get asked to authenticate our BOA accounts. I have my personal c/s accounts w/ another bank and several credit cards and none of those ask for further authentication.

    In searching the BOA security settings of our accounts, the closest I could find to something related was about their special data protocol, and noticed Quicken was not shown as a (current) 3rd party using our BOA accounts with it.
  • I recently became a BOA customer, and I also would like to remove the two-factor-authentication from Quicken<->BOA. It's a real pain.

    None of my other banks or credit cards use 2FA with Quicken except Kohl's credit card periodically.
  • Dave316
    Dave316 Member ✭✭
    Wondering if there is any update to this thread? I too have grown very tired of entering 2FA (or skipping) my BofA account every time I open the mobile app to add a transaction, and when updating via One Step Update in my Quicken Mac application. As pairof9s mentioned above, it appears Quicken is still not an authorized 3rd party app to bypass 2FA.
  • slowery
    slowery Member
    I'm having this same issue with the latest version of Quicken on Mac. It's getting more and more infuriating.
  • Boatnmaniac
    Boatnmaniac SuperUser ✭✭✭✭
    IMO there is something that is very wrong/broken with Quicken's or the aggregator's 2FA process with some FIs.  I don't have any BofA accounts so I can't speak to that but there are 2 other accounts I have had issues with:  Austin Telco FCU and Kohl's credit card. 
    The Austin Telco FCU issue suddenly stopped prompting me for entry of a 2FA code about a month ago but for several months before that whenever I'd be prompted to enter the 2FA code (which was most of the time when running OSU) Quicken wouldn't accept it and OSU failed to update this account.  But if I did Update Now, Quicken would accept the code and update the account.
    Kohl's has been prompting me for 2FA codes for most OSUs for nearly a year now.  Sometimes it accepts the codes and updates the account and sometimes it doesn't.  When it doesn't, if I run Update Now the 2FA code will be accepted and the account updates. 
    Now here's the crazy part about 2FA with Kohl's (I am not the only person posting in the forum to report this):  I've found that if I simply ignore the 2FA prompt (do not close or cancel it) and then wait maybe 1-2 minutes longer for OSU to complete, my Kohl's account will be successfully updated.
    It's a long shot, but has anyone in this thread tried ignoring the 2FA prompt for BofA and letting OSU run for a minute or two longer to see if the update process for BofA completes properly?
    (QW Premier Subscription: R32.12 on Windows 10)
  • BK
    BK Member ✭✭✭✭
    edited November 2020
    I have bookmarked this post from day one since BofA has been my primary FI for a long time with four different banking accounts and therefore curious and concerned, but no issues.  Even when this post came up, I tested it on a new test file, entered my 2FA code once and that was the end of it, no issues after that - similar behavior to "remember this computer".  FYI:
    * My Quicken connection to BofA is EWC as I didn't get grandfathered-in with their former DC setup.  
    * I don't use Quicken's bill pay, sync, cloud, web, mobile etc.  I just download using OSU or download now.
    * Edit: I have remained on R28.24 as it has been solid for me with no need/plans to update at this time

    So given the inconsistency that BofA is working fine for perhaps most Q users but not all, my theory on this issue is one of three:
    - Quicken has some different setup for our respective user IDs/communication that acts like a cookie, not on purpose but by accident (and I am not referring to FDS/QCS)
    - BofA has some different setup for our user IDs/communication that they wouldn't be able to explain
    - Some setup on our computers is different
    - Q Win Deluxe user since 2010, US Subs R32.12
    - I don't use Sync, Cloud, Mobile, Web, Bill Pay/Mgr, Tax
    - Techie, Win10 Pro x64 20H2
  • QWBrad
    QWBrad Member ✭✭
    I have the same issue with the 2FA on BofA. Tagging this thread in hopes that someone figures out the resolution to this error.
This discussion has been closed.