Spending tab register not changing

ScottH
ScottH Member ✭✭
Hi, I'm trying to dive deeper into my spending on the "Spending" tab on the top bar but the behavior doesn't match what I found here: https://help.quicken.com/pages/viewpage.action?pageId=3216359

In Step 3, it states that I should be able to click on the graph and narrow the transactions shown to just what I am interested in. I believe this used to work, but I've had many recent upgrades and I don't know when it stopped working or if there's a new setting somewhere.

Now when I click on an expense category, like "Home" I see my two sub-categories and the amounts in total for each of those, but the register portion at the bottom of the screen never changes. I'm looking at "All accounts" and "Last 30 days" and "Spending" in the pull-downs at the top of the page for "Transactions".

There are a lot of transactions in the 30 days, and I thought this was how I used to quickly narrow in to find the transactions without doing some kind of more involved report. But it's showing every transaction in every category now and doesn't seem to match what I remember or what the help page mentioned.

It seemed to originally work this morning, except in my "Home" category, I have "Home:Mortgage Interest" as a sub-category which is a split item on the mortgage payment I make. When the report narrowed, the default view showed the "Payment" column which was the full payment on my mortgage. I clicked the gear and checked the box to show "Amount" as a column and at that point the register went to all transactions for the 30 days.

I have removed the "Amount" column and it did not return to the prior behavior. I even restarted Quicken and cannot find transactions when I drill into other categories now, it just gives me everything all the time now.

Is there some way to reset or configure this behavior? Or how can I get the category-specific information when the original transaction was a split transaction with multiple categories involved?
«1

Answers

  • Rich_M
    Rich_M SuperUser ✭✭✭✭✭
    @ScottH You seem to have discovered some problems with this view, its clearly not working properly, have you tried using the Reset button to see if that helps?
    Quicken 2017 Premier - Windows 10 Pro
  • ScottH
    ScottH Member ✭✭
    @Rich_M, I did try both the "reset" near the top of the page and if you click on the gear at the top right of the register, then the 2nd gear at the bottom to the left of the "Done" button where it has the option to "reset to default columns".

    Unfortunately, neither seemed to have any impact on the behavior.
  • Rich_M
    Rich_M SuperUser ✭✭✭✭✭
    @ScottH You can use report a problem under help and/or call support to find out if there's a workaround.

    Please post the version you're using under help about Quicken.
    Quicken 2017 Premier - Windows 10 Pro
  • ScottH
    ScottH Member ✭✭
    Thanks @Rich_M I have 2020 R29.22 (build 27.1.29.22) I was originally wanting to just send an email question, but the only options I could find were to post on the community or try chat & phone, both of which were closed. I'll see if I can report the problem in the app.
  • Rich_M
    Rich_M SuperUser ✭✭✭✭✭
    edited October 2020
    @ScottH Someone else may be able to confirm this is a new bug or have a workaround in the meantime.

    I'm still using older version of Quicken and don't have this issue.
    Quicken 2017 Premier - Windows 10 Pro
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    I'm using R29.22 and don't see this problem so about the only thing I can suggest is running Validate & Repair and see if that makes a difference.
    File -> File Operations -> Validate and Repair -> select Validate file -> OK
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • ScottH
    ScottH Member ✭✭
    hi Chris, I ran Validate & Repair. It found two entries it said needed to be deleted and re-created. So I fixed those two, ran V&R again, exited and re-loaded and there was no change. It's still showing all transactions in the last 30 days no matter what I drill down into in the graphic at the top.
  • Rich_M
    Rich_M SuperUser ✭✭✭✭✭
    @ScottH Does it make any difference whether you try to drill into the pie chart or one of the top 8 categories to the right?

    A possible workaround for now would be the Spending by Category report, which has the same pie chart at the top, unless that is also affected by this problem.
    Quicken 2017 Premier - Windows 10 Pro
  • Bob_L
    Bob_L SuperUser ✭✭✭✭✭
    You could also try super validating.  Do that by holding down CTL and SHIFT when clicking validate and repair.
    Quicken Premier Subscription, Windows 10 Home
  • ScottH
    ScottH Member ✭✭
    @Rich_M no difference between clicking on the chart or the categories. I noticed also that if I change the 3rd pull-down from "Spending" to "Spending without taxes" nothing actually changes, and if I keep clicking sub-categories to drill down it changes back to "Spending" on it's own. My Spending by Category report already is broken down into the sub-categories, so other than a few large items it shows most of the totals under "other". It's very useful without trying to customize it.

    @Bob_L didn't know about super validating, but tried it and it came back completely clean. No impact on this behavior.
  • Rich_M
    Rich_M SuperUser ✭✭✭✭✭
    @ScottH So your saying the chart in the Spending by Category report does work correctly?
    Quicken 2017 Premier - Windows 10 Pro
  • ScottH
    ScottH Member ✭✭
    @Rich_M unfortunately not. From the same "Spending" tab, I'm selecting "Reports" in the upper right corner and clicking "Spending by Category" on the pull-down menu.

    At this point, I get a graph and text report (similar, but not the register view on the Spending tab). It's defaulting to "Year to date" when the other was "Last 30 days". I'm selecting "Last 30 days" hoping to get similar information, but I'm not.

    On the Spending tab (All accounts, Last 30 days, Spending) my top four items on the right side are Tax, Food & Dining, Shopping, Home. For the Spending by Category report, it's already fully "drilled down" and shows the top four categories as Depreciation, Tax:Fed, Tax:Soc Sec, Home:Mortgage:Interest.

    The report at the bottom seems to be pre-selected to "Expand All", so I guess it's OK, but a little more jumbled. It looks like I can tweak some of the report/graph settings. I preferred the Spending tab with the register because the graph at the top would give me the high-level overview of the last 30 days so if something like "Auto" was higher than average, I could easily click on fuel and tell that we had an extra fill-up where we'd been averaging 2 per month in the pandemic to 3 in the last 30 days. The report just gives me the subtotal and I'd have to look somewhere else to see transactions.

    Maybe I should be better about using the budgets, but I don't really follow a budget and just understand what our typical month looks like. Generally, our numbers are fairly stable but now I can't eliminate the noise and things like the Spending tab are no longer more effective than just scrolling through the individual registers for the active accounts.
  • Rich_M
    Rich_M SuperUser ✭✭✭✭✭
    edited October 2020
    @ScottH Selecting Last 30 Days in the report should give you the same spending total as the view if it's working properly, this is how it works in my version.  I do see that the report expands all the sub categories instead of showing the top level like the view.

    You can click the collapse all button to get the same top level categories as the view and see all the transaction detail by either clicking the pie chart or double clicking on any sub category in the report below.

    You can click on the little bar graphic within each category to display a bar chart for the last 12 months, hover over any bar to see the actual dollar amount.
    Quicken 2017 Premier - Windows 10 Pro
  • Rich_M
    Rich_M SuperUser ✭✭✭✭✭
    edited October 2020
    @ScottH Back to the view I have another suggestion.  Have you tried removing it from the home tab and adding it back again with customize, to see if that resolves your issue?
    Quicken 2017 Premier - Windows 10 Pro
  • ScottH
    ScottH Member ✭✭
    @Rich_M I do have a "Last 30 Days" option I created under the "Home" tab, but when I click that graph for "examine your spending", it goes to the "Spending" tab on the row above that. Under the View menu, I did try toggling Spending on/off and a couple of others just to see if something would reset, but there's no change. Maybe there's no way to get the combination of the summary chart & table along with the register for me any longer.
  • Rich_M
    Rich_M SuperUser ✭✭✭✭✭
    edited October 2020
    @ScottH Sorry, I mixed up your issue with another discussion about a view on the Home tab, forget that. 

    I do think the report gives you the same information as the view, this would be a temporary workaround until the view gets fixed.

    Have you contacted support about this?
    Quicken 2017 Premier - Windows 10 Pro
  • LzyNerd227
    LzyNerd227 Member ✭✭
    Bump. I'm having the same problem now too with my Spending tab register not being filtered by category! It was working fine a week or so ago. Another thing I may add to the above is that if I drill down far enough into the category, the view will still filter the register by Payee. I've also tried to uninstall, delete program folder then reinstall but there was no resolve. I'm on build 27.1.31.20. Have I been over zealous with my optional Windows updates? My OS build is 19042.844.
    Regularly look back to move forward in the present. o:)
  • LzyNerd227
    LzyNerd227 Member ✭✭
    Additionally, the topmost view of the Spending tab register is now showing transfers to other accounts which it did not do before.
    Regularly look back to move forward in the present. o:)
  • LzyNerd227
    LzyNerd227 Member ✭✭
    I bit the bullet and synced my file to the cloud and the Spending report is effective there.
    Regularly look back to move forward in the present. o:)
  • LzyNerd227
    LzyNerd227 Member ✭✭
    Note that there seems to be a slight loss of translation between the Cloud Spending report and the local version. Please bring back the category filters for the local version! Thanks in advance.
    Regularly look back to move forward in the present. o:)
  • LzyNerd227
    LzyNerd227 Member ✭✭
    The category filters for the corresponding Spending registers underneath the chart, that is. The filters work for the list to the right of the pie chart still.
    Regularly look back to move forward in the present. o:)
  • LzyNerd227
    LzyNerd227 Member ✭✭
    After these few days, I'll claim that the Cloud Spending reports are complementary but no substitute for the local review.
    Regularly look back to move forward in the present. o:)
  • LzyNerd227
    LzyNerd227 Member ✭✭
    Could my Spending Tab register be awry because I employed the Year-End-Copy function for the first time and cut off the year 2010?
    Regularly look back to move forward in the present. o:)
  • LzyNerd227
    LzyNerd227 Member ✭✭
    @ScottH , did you ever find the solution to this issue?
    Regularly look back to move forward in the present. o:)
  • ScottH
    ScottH Member ✭✭
    @LzyNerd227, No, mine still has this behavior. There have been several small updates, but nothing has impacted this particular problem.
  • merna88
    merna88 Member ✭✭
    I have been having this same issue for months and can not figure out why. Anybody solve this yet?
  • LzyNerd227
    LzyNerd227 Member ✭✭
    Not me, @merna88 .
    Regularly look back to move forward in the present. o:)
  • Quicken_Tyka
    Quicken_Tyka Moderator mod
    Hello @merna88 and @LzyNerd227

    Thank you for taking the time to visit the Community to post your issue, although I apologize that you have not received a resolution here on the Community.

    At this time I would recommend contacting support directly for advanced troubleshooting steps.

    https://www.quicken.com/support#contact-support

    Quicken Care has the tools to initiate a screen share to view the issue in real-time.

    Thank you,

    -Quicken Tyka

    ~~~***~~~
  • merna88
    merna88 Member ✭✭
    @Quicken_Tyka I just saw your reply. The link you posted takes me to the support page, but when I click the "Talk To Support" but it doesn't work. Can you post a number I can call to resolve this?
  • UKR
    UKR SuperUser ✭✭✭✭✭
    merna88 said:
    @Quicken_Tyka I just saw your reply. The link you posted takes me to the support page, but when I click the "Talk To Support" but it doesn't work. Can you post a number I can call to resolve this?

    Quicken Support:


Sign In or Register to comment.