Speed Up Accepting Transactions

I would like to see accepting transactions (especially in investment accounts) sped up.

Accepting new transactions can take a long time. It takes about 5 seconds for me to accept a transaction, and when there are hundreds of transactions to accept, that adds up to a long time clicking accept. I notice it most in investment accounts, but it occurs everywhere. When I search for the word "slow" in the forums, I see >400 issues. When I look at some of those issues, they suggest that having >10000 transactions in an account can be a problem, but real accounts can have that many transactions.
5
5 votes

New · Last Updated

Comments

  • jprommel
    jprommel Member
    edited July 22
    I couldn't agree more. This is something that must be fixed. I have multiple mutual accounts. I can usually "accept all", but sometimes it requires that I do things individually - - in order to accept/not accept a lot number. I don't care! I only care about the $ amount. I've used Quicken forever and have requested this change so many times, but nothing happens.
  • davidmarketing
    davidmarketing Member ✭✭✭
    Thanks for the comment!  I totally agree.  I reconcile almost all my accounts, but it takes a long time like you said when you click the transaction on the reconcile wizard for it to process.  It's really annoying and time consuming.  I think it's only looking for the transaction and putting a "c" next to it.

    Great suggestion!
  • UKR
    UKR SuperUser ✭✭✭✭✭
    All of you, please tell me:
    How many transactions do you have in the "slow" investment register?
    How many securities are in your Securities List?
    How many of these securities do you currently own?

    If you're an active trader and/or your current investment account has many transactions pertaining to sold securities you may want to consider this:

    Archive Investment Transactions

    For about a year now, a new function has been available in Quicken, Archive Transactions. It will split your investment account register into two parts, leaving only those securities' transactions where you currently hold >0 shares in the active register. The rest is moved to a new Archive register within the current data file.

    Having less transactions in your active register might improve performance.

    Please read and carefully follow instructions here: https://www.quicken.com/support/how-archive-investment-transactions
    Eventually, after a couple of years, you might consider splitting your data file in two, with all the archived investment transactions moving to an archive data file and none remaining in the active data file.

  • davidmarketing
    davidmarketing Member ✭✭✭
    Some of my accounts have many transactions and I probably have 200 securities.  I don't think it's the size of each account since it is universally slow.  I think it's the size of my qdf file which is 533MB.

    I am not a fan of separating.  I like all the data together for reporting purposes.
  • davidmarketing
    davidmarketing Member ✭✭✭
    I also will buy a new computer early next year and hoping a faster processor will help.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    Have you checked your investment registers for Placeholder transactions? They tend to cause calculation issues.
    Have you validated your data file, selecting both "Validate File" and "Rebuild investing lots"?

    About Placeholders (Quicken Windows)

    "N/A" in certain fields of an investment transaction indicates that you have Placeholder transactions in your account that need to be deleted and replaced with the correct Buy / Sell / etc. transaction that should have been recorded here.
    For more about Placeholders please go into Quicken Help (press the F1 key from anywhere in Quicken) and perform a Contents search for "placeholder".
    Alternatively or in addition to the above, please read https://help.quicken.com/pages/viewpage.action?pageId=3216694

  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    For what it is worth, this isn't a new problem for investment accounts, and a new computer is most likely not going to solve the problem.  This is an inherent problem in the design of the investment registers and their implementation.

    On the other hand, if this happening non-investment account, most likely you have some kind of problem with your data file.

    The mention of 10,000 transaction for non-investment accounts is usually centered on the fact that there seems to be some strange behavior that starts happening when the accounts exceed about 32,000 transactions, but it isn't directly related to speed.
    Signature:
    This is my website: http://www.quicknperlwiz.com/
  • davidmarketing
    davidmarketing Member ✭✭✭
    How do you see how many transactions are in an account?
  • UKR
    UKR SuperUser ✭✭✭✭✭
    edited October 29
    How do you see how many transactions are in an account?
    To see them all in one place: Go into Tools, Account List.
    Click the Options tab. Click to select the optional column "Show number of transactions"
    Banking account registers, when not filtered, show the total transaction count at the bottom of the register in the line with all the balances.

  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    How do you see how many transactions are in an account?

    Ctlr+A.  If the # Transactions field isn't displayed, turn it on by selecting the Options button.
    Signature:
    This is my website: http://www.quicknperlwiz.com/