Security XLK (NYSE) is shown as in Canadian Dollars (field not editable). How to fix?

This security is not linked to any transactions (I pressed "report" on Security List. Since I cannot change the currency field (greyed out/not editable), I thought I should delete the currency and recreate it, except the delete button is greyed out and does not show up on right-click as an option. How can I fix this?
Tagged:

Answers

  • ePeggyH
    ePeggyH Member
    OK, I sorted it out: Even though the report showed no transactions using this security, when I deleted all the holdings within the account and deleted the account itself, the delete button appeared for this security and I was able to delete it and recreate it in the correct currency.
Sign In or Register to comment.