Security still show up in my list despite been mark to be hidden. How to fix?

Despite having a couple of my securities in security list mark to be hidden they still show up in my holdings. I have not been able to find a solution. Anyone with this same problem.

Answers

  • YingDave
    YingDave Member ✭✭✭✭
    Hi Miguel. Go to the Portfilio view Ctrl+U, on the right side Cog - Options, Customise Current View, In the dialog box there are three tabs, go to the last "Securities". Down under the selection window what does the setting " Show (Hidden Securities)" have a tick next to it? Sound like you want it unticked?

    David
  • Thank you
    When viewing securities under Investing/Portfolio area those hidden securities do not show but when I go to the account and go to Holdings view those hidden securities that were associated with the account still show up.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    In the Holdings view as well as the Portfolio views, there is an option to Show closed lots.
    If that is checked, you will see securities for which you no longer hold any shares. Is that what's messing up your view?

  • UKR
    UKR SuperUser ✭✭✭✭✭
    I forgot to ask, if those unwanted securities show up under the heading (account name) of Watch List. Do they?
Sign In or Register to comment.