Security Detail View shows security no longer in portfolio.

This has been a problem for some twenty years! Back in the 1990's I sold 100% of a security. I checked "hide". However, even though it is "hidden" and has a zero balance it will occasionally show up in the "Security Detail View" drop down list of securities. It can go months without it showing in the list and then suddenly it starts showing up again! I know with all the problems in the world this is not high on the list but it is still annoying. There should not be some hidden tiny fractional shares somewhere since I bought 100 shares and after a two-for-one split I sold 200. Nice round numbers so I don't believe that is the problem. The only thing I can think of is some strangely corrupted file. However the security does not always show up. I would appreciate any thoughts on the matter.

Answers

  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    When we open a Security Detail View while Show hidden securities is checked on the Security List window, all hidden securities are included in the pull-down list.
  • Sherlock, That is not quite the problem. I have the "show hidden" box UN-checked in the "Security list" since I do not want to see any hidden securities. The problem is ONE (always the same one) of the hidden securities is included in the Detail View drop down. This security is always at the top of the drop down since it is alphabetically the first security of all my securities.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    glfiedler said:
    Sherlock, That is not quite the problem. I have the "show hidden" box UN-checked in the "Security list" since I do not want to see any hidden securities. The problem is ONE (always the same one) of the hidden securities is included in the Detail View drop down. This security is always at the top of the drop down since it is alphabetically the first security of all my securities.
    Well, you can always rename the security so it'll sort to the bottom of the list if it does appear.
  • Since there is only one corrupted security I will simply ignore it rather than rename to move it down to the bottom of the list. It is really no big deal; it just is not right. My old engineering brain does not like things that are not "right". Although you did bring up an interesting point. Perhaps renaming it would actually hide the new name. I'll give that a try.
  • This is beyond odd! I changed the name by adding the preface "zz". It no longer showed in the drop down list. That sounds great but now the security that was second in the "hidden security list" shows up in the drop down "Detail View" list. So it is not the security data that is corrupted but the algorithm that creates the drop down list that is screwed up. Note that all other hidden securities are in fact NOT included in the drop down list; only which ever one is at the top of the "hidden" list. Oh well, life goes on.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited December 2020
    glfiedler said:
    This is beyond odd! I changed the name by adding the preface "zz". It no longer showed in the drop down list. That sounds great but now the security that was second in the "hidden security list" shows up in the drop down "Detail View" list. So it is not the security data that is corrupted but the algorithm that creates the drop down list that is screwed up. Note that all other hidden securities are in fact NOT included in the drop down list; only which ever one is at the top of the "hidden" list. Oh well, life goes on.
    If it were simply the algorithm, we should all see it. I have 16 hidden securities ahead of the first unhidden security and the issue is not reproduced.  I have no recollection of ever seeing this issue or hearing about it.  It does sound like an indexing issue but perhaps specific to the Quicken file.

    If you haven't already, I suggest you apply the Copy and Validate instructions decribed in: https://www.quicken.com/support/advanced-data-file-troubleshooting-correct-problems-quicken-windows
  • Thank you Sherlock for taking the time and showing interest in my problem. Validation found no errors or any corrupted data etc... Really I am quite used to the issue since it has been around for years. After opening the Detail View I only have to press the down cursor key to start looking at my portfolio. Thanks, again.
  • Quicken_Tyka
    Quicken_Tyka Moderator mod
    Hello @glfiedler

    Thank you for taking the time to visit the Community to report your issue, although I apologize for the frustration. 

    If you have not done so already, I would also recommend navigating to Help > Report a Problem to report this issue.

    This report will not receive a direct response but the information will be used to investigate and research purposes to better understand this issue.

    Thank you,
    -Quicken Tyka
    ~~~***~~~
  • NotACPA
    NotACPA SuperUser, Windows Beta Beta
    @glfiedler, When you say that you sold "100% of a security", how did you record that?
    Did you input the number of shares ...  or did you use the "Sell All Shares" feature?
    Under a variety of circumstances, there can be an tiny fractional share (0.000001) remaining in the account ...  which could result in the situation that you're describing.
    AND, it can still be a fractional share issue ...  since the PC records data in binary and not in decimal.
    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • NotACPA, Thanks for taking time to respond. This sale was back in 1998 so I really don't remember how I entered it. I retrieved the "sale" dialog box and cleared the 200 in the "quantity" text box and checked the "all shares" box. Clicking "done", I assume, re-entered the sale. I did not delete the transaction first, I only edited the transaction, which may not be technically the same thing. Anyway, this re-entry did not solve the problem. Quite honestly I do not believe fractional shares (for this security) would be a problem.

    This is where it gets interesting. The offending security is the first security in the "hidden" list. Earlier in this thread I said that after I renamed the security by adding "zz" to it's name that renamed security disappeared from the Detail View list (as it should have since it was hidden). HOWEVER, then the second "hidden" security was at the top of the drop down Detail View list. Of course the "second" one is really the "first" one now because I sent the first one to the bottom by adding "zz". Okay, I know that may be a bit confusing so...

    Simply stated, it appears that my data file/program puts the first "hidden" security in the Detail View drop down list.

    My extremely simple work-around is to press the cursor-down-arrow key immediately after the Detail View opens.
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    AHH.  I see the path.  Classic menus / Investing / Investing Tools / Security Detail View.  (Also accessible as a tool bar icon).  Yes, for that path I too see the program opening to a single hidden security. 

    That is, that path opens to the first security in the Security List without regard to its hidden status.  Beyond that first entry, the pull down abides by the "Show Hidden securities" check box on the Security List (Ctrl-Y).

    Until this evening, I have never tried to open the Security Detail View except from the Security List, or a portfolio view (Ctrl-U), or similar. 

    I would note this as another (apparently) long-standing bug in the program.

    This is all unrelated to whether that 'first' security has any value by any measure.              
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited December 2020
    q_lurker said:
    AHH.  I see the path.  Classic menus / Investing / Investing Tools / Security Detail View.  (Also accessible as a tool bar icon).  Yes, for that path I too see the program opening to a single hidden security. 

    That is, that path opens to the first security in the Security List without regard to its hidden status.  Beyond that first entry, the pull down abides by the "Show Hidden securities" check box on the Security List (Ctrl-Y).

    Until this evening, I have never tried to open the Security Detail View except from the Security List, or a portfolio view (Ctrl-U), or similar. 

    I would note this as another (apparently) long-standing bug in the program.

    This is all unrelated to whether that 'first' security has any value by any measure.              
    I'm not able to reproduce the issue selecting Investing > Investing Tools > Security Detail View.  In my case, Quicken open's the 5th unhidden security and 38th overall by default.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    Sherlock said:
    q_lurker said:
    AHH.  I see the path.  Classic menus / Investing / Investing Tools / Security Detail View.  (Also accessible as a tool bar icon).  Yes, for that path I too see the program opening to a single hidden security. 

    That is, that path opens to the first security in the Security List without regard to its hidden status.  Beyond that first entry, the pull down abides by the "Show Hidden securities" check box on the Security List (Ctrl-Y).

    Until this evening, I have never tried to open the Security Detail View except from the Security List, or a portfolio view (Ctrl-U), or similar. 

    I would note this as another (apparently) long-standing bug in the program.

    This is all unrelated to whether that 'first' security has any value by any measure.              
    I'm not able to reproduce the issue selecting Investing > Investing Tools > Security Detail View.  In my case, Quicken open's the 5th unhidden security and 38th overall by default.
    The default security that opens when we select Investing > Investing Tools > Security Detail View appears to have some stickiness and context sensitivity.

    I've been able to reproduce the issue using the Security List to prime the default over some views but not others.  For example with Show hidden securities unchecked, if I press Ctrl + Y with the My Money Home view open, left-click on the first security, close the Security Detail View window, close the Security List window, select Investing > Investing Tools > Security Detail View, the first unhidden security appears in the Security Detail View window.  If I close the Security Detail View window, switch to View 1 Home view, select Investing > Investing Tools > Security Detail View, the first hidden security appears in the Security Detail View window.  If I close the Security Detail View window, press Ctrl + Y, left-click on the first security, close the Security Detail View window, close the Security List window, select Investing > Investing Tools > Security Detail View, the first unhidden security appears in the Security Detail View windowIf I close the Security Detail View window, switch back to the My Money Home view, select Investing > Investing Tools > Security Detail View, the first hidden security appears in the Security Detail View window.


  • Sherlock and q_lurker, thanks for verifying my issue. I always, by habit, open the Detail View by clicking the tool bar icon. I too can get a "clean" drop down list by double clicking a security in the "investing portfolio" view or left-clicking a security and selecting "security view". This explains why sometimes the hidden security is there and sometimes not. I never mentally connected the path to the Detail View with whether or not the hidden security was shown. Thanks for clearing this up.
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    @Quicken Sarah -- It appears we have confirmed a bug in the opening of Security Detail views.  The exact scope is not yet identified, though it seems we are pretty close to it.  Not a deal-breaker, but something that should be passed on to the developers to have 'on their list'. 

    I believe for all three of us, a significant common trait is that the first security (alphabetically) in the Security List is a hidden security.  We are seeing this first security appear when unexpected (Show hidden securities NOT selected).  @Sherlock reports, and I can confirm, that there may be something associated with the Home screen View playing a role.  

    If you can confirm passing this on to developers, I would appreciate it.  Let us know if you need further details.
  • tnmats
    tnmats Member ✭✭
    I've seen this identical bug/flaw in Quicken since at least Q2014 Premier. It's the exact same bug/flaw as others describe, the first security in my securities list (if unhidden) ist but I have that security hidden that still shows in the pull-down list but then vanishes from the drop-down list occasionally. Like others, I have the hidden securities option box unchecked (no other hidden securities show, just the one). I've run validate and super-validate more than once, no errors found in my Quicken file.

    This isn't a one-off, it's been in the code for years and never was fixed.
Sign In or Register to comment.