Old timer with a new quicken file slower than me

I've been a Quicken user since the 90s and started over from scratch a few times after my file slowed down too much. My current file is only a few years old, however, so I thought I'd reach out for help.

The problem is that the program will effectively timeout (spinning wheel) and I need to wait for it to settle before navigating any further. This happens between simple mouse clicks to open a register or select a downloaded transaction. The waiting time can often be over 10 mins. I try not to force-quit the program and it will usually clear itself if I wait it out. But then it can happen again on the very next mouse click. Then some days, no problems at all. I usually try to super validate as soon as I can, close the program, and re-open. This works sometimes, sometimes not. Seems quite random.

Quicken Deluxe Subscription R35.31 Build 27.1.35.31 Windows 10 Enterprise
R35.31 has some issues, but the slow problem has been happening for months on other versions as well. R35.31 is no worse/better.

This is what I've tried:
--Have only Quicken open; no other programs. CPU usage seems stable. High-end laptop.
--Super validate - note below that I get one "old style" buy transaction.
--Tried to reduce/clean up the databases - memorized payees, renaming rules
--Renamed/consolidated a bunch of transactions to slim that database of names
--Tried using both GPUs (integrated Intel 530 and discrete NVidia Quadro M3000M).
--I have never automatically accepted or categorized transactions. Zero attachments.
--Before R35.31, I would try "file-operations-copy" the file after super-validating, but this procedure does not appear in R35.31 (program simply suggests making a full backup). I had read about that trick on this forum.

Super-validating runs clean except for the one "old style" buy transaction. Ah ha! Is there a particular transaction type that has been deprecated? I perhaps chose it on accident and can go back and change it. I have a lot of "bought" and a few "added" security transactions in my investment registers, but don't see a similar word to those that I have only one of. It's hard to imagine it would be that simple though...

Any insights would be greatly appreciated!

=-=-=-=-=-=-=
QDF:
Validating your data.
No errors.
QEL:
No read errors.
QEL:
All internal consistency checks passed.
[Fri Sep 03 21:35:27 2021]
Repair price history: 0 price(s) repaired.
[Fri Sep 03 21:35:30 2021]
[Fri Sep 03 21:35:30 2021]
Rebuilt investing lots.
Analyzing securities.
Number of old style Buy/Cash/Transfer investment transactions updated: 1/0/0
No out-of-range security references found.
Super validation has completed.
=-=-=-=-=-=-=
File Stats:
Size 87MB
Accts 67
Categories 249
Mem Payees 3
Renaming Rules: 25
Sec/Max ref: 34/37
Transactions: 28k
-==-=-=-=-=-=

Answers

  • Quicken Paloma
    Quicken Paloma Alumni ✭✭✭✭
    edited September 2021
    Hello @kengo

    Thank you for reaching out to Quicken Community. I apologize you are having this issue. To better assist you I need a few more details. For instance, what Windows version are you running? Are all updates completed for Windows? Where are your main/active file(s) stored (cloud-based service, external hard drive, local hard drive)? 

    Additionally, I would recommend that you un/reinstall your Quicken. Upon reinstalling it will also run a QClean which may be beneficial in this particular instance. For instructions on uninstall Quicken please visit the link below. 

    https://www.quicken.com/support/how-do-i-uninstall-quicken-windows

    Once more information is provided we can move forward in diagnosing the issue at hand. 

    -Quicken Paloma 
  • kengo
    kengo Member
    I'm running Windows 10 Pro (21H1 build 19043.1202) fully updated.
    The Quicken program is installed in the default location on my C drive.
    My data file is on my ssd D drive, however, but not in a cloud-serviced folder.
    I un/reinstalled Quicken a few months ago, but just did it again now.
    It appears to be working fine the last few days but I was getting the prolonged delays as recent as last week.
  • kengo
    kengo Member
    The graphics behavior is very similar to those described in the "higher res monitor" posts from few years ago, and the post below is probably the same issue:

    https://community.quicken.com/discussion/7894882/quicken-premier-r33-erratic-behavior-slow-performance-screen-flashes-to-desktop-and-back/p1

    My "waiting" problem almost always happens after I download transactions though. So, while it appears to be a graphics issue, that just might be a symptom. It could still be a database issue. Or, what's Quicken trying to do after you download transactions and click on a register to see them? It's thinking about sumpthin. For instance, is it searching through payee rules?

    Graphics behavior:
    --The cursor randomly switches between the arrow, hand, and spinning wheel, while the Quicken window tries to repaint itself.
    --Usually, it is the bottom 1/4 of the window that tries to repaint itself, slowly, over and over, while the cursors changes.
    --But the title and menu bars will also disappear and then reappear over and over.
    --The entire window will sometimes disappear (minimize), then reappear.
    --The window will jiggle or move left/right for a few seconds.
    --Resolves itself after 5 minutes between mouse clicks.

    While trouble shooting, I will only do one mouse click at a time until it fully settles down. This might take 5 minutes or more between clicks. For instance, I download transactions, and then click on an account to see its register. That usually starts the spinning wheel / repainting issue. I'll wait for that account to load before clicking on a particular transaction. I can then usually accept all the transactions one at a time, but then, when I click on another account, I need to wait the 5 or so minutes. That's why I initially thought it could be a database issue (as it searched for payee rules, for instance). The graphics issue might be a secondary symptom.

    Tried fixing:
    --I've tried locking the Quicken program into the Intel Graphics Adaptor, as well as the Nvidia adaptor.
    --I've tried changing the resolution from its native 4k to normal HD.
    --I've tried the Quicken program full screen, as well as windowed.