Firefox won't render Quicken for Windows Pop-Ups or very slowly

I have a couple of issues with Quicken for Windows Pop-Ups not being rendered by FireFox.

1 - When resetting a link to a bank. The login process wouldn't work. However, on my laptop which has MS Edge (chrome version) as default browser it worked fine.
2 - Quicken ID - It took about 5 minutes to render. I was busy searching the Quicken forum rather than killing the quicken process and when I came back it had finally rendered.

Has anyone else seen this behavior?

Key Facts:
Windows 10 Home v 20H2 19042.1237
Quicken for Windows Home & Business v R35.31
Firefox 92.0.1 (64-bit)

Comments

  • Quicken Francisco
    Quicken Francisco Alumni ✭✭✭✭

    Hello @bmackey55

    Thank you for reaching out to the Community regarding your issue, although I am sorry to hear that you are experiencing issues with your program. I was taking a look to see if I could replicate some of the issues you're having but was unable to with firefox as my default browser. Since the issues you're having seem to be when you're trying to grab information from Quickens servers I'm wondering if that's what might be having a difficult time. Let's see if we might be able to speed up the process by signing out and back in. Steps will be listed down below

    1. Go to Edit
    2. Preferences
    3. Quicken ID & Cloud accounts
    4. Sign in as a different user (or it might say Sign in using a different Quicken ID)
    5. Follow the prompts to Sign Out
    6. Sign back in using your Quicken ID (email) and password (this screen is not a pop-up box)

    Once you get a chance to try these steps, please let us know what you find.  From there we'll better understand our next steps/options.

    Thanks,

    Quicken Francisco