Default Windows regional currency replaces selected Quicken account currency (Q Win Canada)

Hussarman2000
Hussarman2000 Member
When I try to set-up a new account in Quicken that involves a currency other than the default one in my Windows regional settings, Quicken changes the selected currency back to the Windows default one. In this case, my Windows regional settings are to the UK but I am trying to set-up a new account in Canadian Dollars: when I finish setting-up the new account after selecting Canadian Dollar for its currency, Quicken has reset the currency to UK Pounds. This is a new bug as I was previously able to set-up account using different currencies in Quicken without this reset occurring - i.e. I already have many Quicken accounts in both Canadian & US Dollars, as well as UK Pounds. I am using the Quicken Canada Subscription version (currently R33.7 build 27.1.33.7) - having lived previously in Canada when I bought Quicken and now living in the UK (hence the Windows settings).

Comments

  • Update: this appears to only happen with the "Investing and Retirement" accounts - setting-up a Chequing, Savings or Credit Card account appears to accept the selected currency.
  • Hello @Hussarman2000,

    Thank you for reaching out to the Community and telling us about your issue, though I apologize that you are experiencing this.

    I am curious if you have tried this in a new file (test file). When we start to see strange behaviors, a good place to start is by opening a new Quicken file and seeing if we get the same behavior there. This can help to determine where an issue is occurring, so we can offer the best suggestion toward resolution. 

    If you have not tried this, here are some steps to walk you through the process. 

    1. Go to File in the top left of your Quicken

    2. Select New Quicken File

    3. Select New Quicken File and click Ok 

    4. Type in Test and click Save

    5. Select Don't use mobile & web and then click Next

    6. Click Add Account

    7. Add a few accounts with different currencies.

    Are you seeing the same issue?



    Quicken Alyssa

  • Hi Alyssa - thanks, that has resulted in the currency I wanted (Canadian Dollar) remaining the same for the account after creating it. I tested it three times using the three different Investing & Retirement account types - all the same. So what could this mean for my existing account file that I want to add these new investment accounts to, where the currency problem is occurring?
  • Hello again,

    Thank you for the update and I apologize for the delayed response.

    This would indicate that the issue is in the original file. I would first check to see where your data file is located on your computer. You can easily check this by going to File>Show This File On My Computer. the file should be locally stored. It should not reside on a cloud or any external/secondary drives.

    Also, check to see if it is being actively backed up by any third-party apps or cloud-based storage services. If it is you will need to exclude it from those backups or move it to a location that does not get actively backed up, as this can cause damage to your file. 

    The default location of a data file is This PC>C:>Users>Your user name>Documents>Quicken. 

    Let us know what you find and we will go from there. Thank you.



    Quicken Alyssa

  • Hi Alyssa, the file was stored locally and is backed-up to a cloud solution (Dropbox) - so I have removed it from this backup now. After doing that, I can now create both a Brokerage and TFSA account in the currency I want (Canadian Dollar) but when I try to create a Retirement account, it defaults back to UK Pounds even though I select Canadian Dollar for currency. I have checked this 3x and it's the same every time, even when I vary the details I input in setting-up the account. Please advise - thanks!
  • Hello and thank you for the update!

    Glad to hear that you were able to make some progress with this. 

    Can I have you validate your file? 

    To do this;
    1. Go to File and select Validate & Repair File from the menu options.
    2. Check off the first box for Validate File and click Ok.
    3. Close the datalog that populates after the validation has been completed.
    4. Go back to File, this time hold down Ctrl+Shift and click on Validate & Repair File
    5. Check off the first box for Super Validate File and click Ok.
    6. Close the datalog that populates after the super validation has been completed. 
    7. Close and reopen Quicken and try adding the retirement account again. 

    Do let us know if this resolves your issue or not, thanks!



    Quicken Alyssa

  • Hi Alyssa - thanks, did all of that and I'm afraid no change: Retirement account still defaults to UK Pounds, not Canadian Dollars as I specify in the account set-up. Please advise further steps to resolve - thanks!
This discussion has been closed.