Erratic mouse behavior in register windows

I'm suddenly experiencing jerky and inaccurate mouse movement within my registers. Moving the pointer with the register, the pointer hangs a bit then jumps forward to new location. Without smooth movement, there's no way to control where the pointer winds up. I've already reinstalled the program, restarted machine, switched from wireless to wired mouse. Nothing changes. Interestingly, if I open the "action" drop-down and then move the mouse within the register window, it's smooth as butter. Anybody else had this happen recently? This is subscription product, current Windows release.

Comments

  • UKR
    UKR SuperUser ✭✭✭✭✭
    ScottR said:
    ... This is subscription product, current Windows release.
    Windows 10 or 11?
    Just a shot in the dark ...

    Font size problems? Display issues? (Windows)

    If you are using a version of Quicken at the Quicken 2019 US R 19.44 patch level or newer and you have previously made the following Compatibility change, please undo the change.
    Users of other Quicken versions please try the following:

    • Close Quicken !!! (This process won't work while Quicken is running!)
    • Check the Compatibility tab settings in your Quicken Desktop program icon:
    • In the Windows Start Menu right-click the Quicken icon. Select "Open File Location". This brings up a Windows File Explorer window. Right-click the highlighted Quicken shortcut line item.
      or
    • Go to the traditional Windows Desktop and right-click the Quicken program icon.
    • Now click Properties.
    • Select the Compatibility tab.
    • Uncheck all settings.
    • Windows 7, 8.1: Check "Disable display scaling on high DPI settings". 
      Windows 10:  Check "Override high DPI scaling behavior. Scaling performed by:" and select "Application"  (also try the other available options repeating the entire procedure!)
    • Be sure to uncheck the "Run this program in compatibility mode for [older Windows version]" setting.
    • Click the "Change settings for all users" button.
    • Click Apply and exit.
    • Now start Quicken and see if that makes a difference.

    Some additional tuning suggestions:

    • Try this workaround for 4k monitors
      https://www.quicken.com/support/work-around-display-issues-high-resolution-monitors
    • Unless absolutely required, try not to use "View / Use large fonts"
    • Try setting the bank account registers to use a different font style or size: go to Edit / Preferences / Register, click the Fonts button and try different fonts.
    • Try adjusting the bank account registers' row height: go to Edit / Preferences / Register, choose among the available Row Height choices: Compact, Comfortable or Standard
    • If all else fails, try changing Windows Control Panel / Display options for "Make text and other items … smaller or larger" to use a different scaling level, but try not to exceed 125%


  • ScottR
    ScottR Member
    Thanks UKR, it's Windows 10.

    I did try the suggestions you provided, none helped.

    I recently migrated from Q2015 and confirmed that the problem does not appear in the earlier software.

    But I found a solution, not ideal but at least it works.

    What eliminated the problem was switching the registers to 2-line display. For whatever reason, the one-line display isn't handling the mouse correctly.

    Can't prove it's not unique to my machine, but I got the same effect on my laptop, so I suspect it's the Quicken software.
  • ScottR
    ScottR Member
    Also don't know where all the extra spacing came from in the above comment. Didn't appear that way when I typed it.
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser ✭✭✭✭✭
    edited November 2021
    ScottR said:
    What eliminated the problem was switching the registers to 2-line display. For whatever reason, the one-line display isn't handling the mouse correctly.
    About a year ago, it was discovered that moving the mouse in 1-line registers results in extra disk access. As far as I know, this has never been explained or remedied.
    ScottR said:
    Also don't know where all the extra spacing came from in the above comment. Didn't appear that way when I typed it.
    It's a bug in the forum software. I get the same effect using Firefox on Win10. I have to remember that pressing Enter is a paragraph break. On iOS Safari, this doesn't happen and I have to remember that Enter is a line break.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
This discussion has been closed.