RRSP in USD does not seem to work in the canadian version of Quicken

andre113
andre113 Member ✭✭
Although my local currency is CAD (as I am a canadian citizen using the canadian version of Quicken), Quicken gives me the opportunity of managing adequately the currencies in my Brokerage accounts. Great !!

During my RRSP account creation, Quicken also gives me the opportunity of choosing the RRSP currency, which is perfect. Then I chosen USD as my RRSP account is in that currency. However as soon as the creation process is completed, Quicken erroneously changed my currency to CAD (I had no transaction yet in that new Quicken RRSP account at that moment).

How to solve it other than creating a "taxable" brokerage account instead of using my "non taxable" RRSP account?

Thanks in advance
Tagged:

Comments

  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    The big problem with all of this is that everything has to line up properly and it is clear that it doesn't.

    In other words, you create the account in USD, and then you go to sync, and the financial institution sends the data, but the currency set in the data says that the currency is CAD.  That is what causes Quicken to change the currency in the account.  In reality it shouldn't do that, it should just flag an error.  But the point is it is clear that all the "players" in the data flow don't have their act together.

    What's more Quicken's multiple currency support is lacking.  The support of it in the Canadian version is better than what is in the US version, but it is far from perfect.

    As for your account not that I think it will matter with regard to the currency, but there shouldn't be any reason you can't create a "nontaxable" brokerage account.  In the account details there should be a setting like this (for an account created as a brokerage account): 

    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • andre113
    andre113 Member ✭✭
    As I mentioned, no transactions have been entered yet. I just did the first step of adding a new account
    (Tools, Add Account, Offline Account, Retirement, Complete Investing, Currency choosing "US Dollar", Create account without security, Done).

    Once I click "Finished", I go to the Account Details to see the "Account Currency" field erroneously showing "CAD" !!! Weird, isn't it?
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Thanks, I thought it had changed when you updated.  Yes, that is weird.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
This discussion has been closed.