Quicken Update switched my installed app to the Canadian version

MVY
MVY Member ✭✭
Long-time user here (since 2000).

Long story short, last week's automatic update switched my installed Quicken/Windows to the Canadian version of the app. I got support via chat and, after some troubleshooting, they told me to log off and log back on again, and that seems to have fixed it. They never told me why it happened, but I didn't care because the suggested fix worked.

Fast-forward to today, and I found out that I can't enter any credit card payment on my checking account without an annoying "Foreign Currency Transfer" window appearing and asking me to convert any amount to USD before posting.

Back on chat with support, the rep did a remote desktop session to watch the problem, and then proceeded with the standard steps: verify file, etc. After a long time and lots of steps, the rep ran out of ideas. Basically I was told to export every account to a QIF file and re-import them into a new file, because it "could be a bug".

Needless to say, I'm not trusting the current data file and situation at all, and I don't think this "fix" is actually fixing anything. Besides, I tried to import all my transactions they way I was told, and ended up with a checking account with a $989,000 balance -- which would be great but is absolutely not correct. So I don't trust the export-import "solution" either.

Here's what I tried already:

1) Created a backup and restored it into a new file.
2) Uninstalled and reinstalled Quicken
3) Tried to uncheck "Multicurrency Support" in Preferences (won't let me do it until I delete all "foreign accounts and securities" which I don't have)
4) Asked support if there's a way to identify which accounts are not in USD (answer: no)
5) Asked support if there's a way to list transactions not in USD (answer: no)
6) Tried to delete "Canadian Dollar" from the list of currencies, but it says it's my "home currency" and cannot be deleted.

So, I'm running out of options, and I really didn't want to lose all my transactions from years past by having to create a new file and start over. Does anyone know of a way to fix this? Or a different approach, other than "wait until Intuit's programmers fix the bug" which could take weeks/months or even never?

Answers

  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    If you haven't already, I suggest you restore a Quicken file backup saved before the issue occurred last week.
  • MVY
    MVY Member ✭✭
    @Sherlock: Tried that, same result. I'm convinced it's not the file itself that's wrong, but the application and/or my account.

    Here's some progress I made in the past few minutes: I was able to set my "home" currency to USD, but that didn't make the problem go away. What helped, though, is when I set the Canadian dollar to have the same value as the dollar (so 1CAD = 1USD). These 2 things combined made the stupid "Foreign Currency Transfer" window stop appearing for my CC transactions.

    However, something must still be wrong because Quicken won't let me delete the Canadian dollar option from the list of currencies (I wanted to do this just to make sure). It also won't let me uncheck "Multicurrency support" because it insists I have an account of security using a foreign denomination. It just won't tell me which one, exactly.

    Since I haven't created a new account in years, and I'm sure I've never used a foreign currency in Quicken, plus the fact that an earlier backup still shows the issue... all of these point to an application issue, not the file itself, IMHO.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited February 13
    MVY said:
    @Sherlock: Tried that, same result. I'm convinced it's not the file itself that's wrong, but the application and/or my account.

    Here's some progress I made in the past few minutes: I was able to set my "home" currency to USD, but that didn't make the problem go away. What helped, though, is when I set the Canadian dollar to have the same value as the dollar (so 1CAD = 1USD). These 2 things combined made the stupid "Foreign Currency Transfer" window stop appearing for my CC transactions.

    However, something must still be wrong because Quicken won't let me delete the Canadian dollar option from the list of currencies (I wanted to do this just to make sure). It also won't let me uncheck "Multicurrency support" because it insists I have an account of security using a foreign denomination. It just won't tell me which one, exactly.

    Since I haven't created a new account in years, and I'm sure I've never used a foreign currency in Quicken, plus the fact that an earlier backup still shows the issue... all of these point to an application issue, not the file itself, IMHO.
    It should be easy to check the application: select Help > About Quicken

    The latest Canadian release is R33.7
    The latest US release is R38.29

    Note: We're still using R36.38.

    You should also be able to check your account: select Help > My Quicken Account
  • MVY
    MVY Member ✭✭
    @Sherlock: All that was checked. I spent over an hour with tech support on chat. They remoted in and checked everything. I reinstalled the app while on chat. The version is correct for the US: R38.29 (27.1.38.29).

    Here's one more development since yesterday: I tried restoring from an older backup (December), and in this older backup the "Multicurrency support" is unchecked and there is no "Currency List" option under the Tools menu.

    So now it looks again like the culprit is the data file, not the application. And the Canadian version switcharoo was caused by some bug introduced in a January auto-update (and not the one on Feb 2nd).

    I will just use this file from now on, and reload all my changes/transactions/payments YTD, and forget this very unpleasant situation. It's not the first time Intuit developers released something raw and untested (again, been at this for over 20 years, I've seen things...)
This discussion has been closed.