Transaction Errors - Quicken for Windows Canadian Home and Business Version - Retirement Accounts

kh57smth
kh57smth Canada Beta Beta

1. After manually entering interest income and reinvesting interest payments in my RRSP and TFSA accounts, the database assigns these entries to the _Intinc category instead of the _IntincTaxFre category.  This erroneous result shown in the Investment Income YTD report.  I am using the Canadian Home and Business Windows version of Quicken.  Looking up my categories list shows an Interest Income category but no Tax-Free Interest Income category.  Can the database coding be fixed so the transactions are correctly recorded in the right categories?

2.  The same problem exists for the _RlzdGain category.  There is no _RlzdGainTaxFree category for Retirement (RRSP and TFSA) accounts. 

3. The problem is different for dividend transactions.  For TFSA accounts dividend transactions are shown in the _DivincTaxFree category and for RRSP accounts dividend transactions are shown in the _Divinc category.

4. Can the investment Income YTD report have the Income into taxable and tax-free categories so we can keep track of our taxable income.  This would help us make a better guess at how much income tax to pay by quarter to the Canadian Gov't.

Thank you for your attention to this matter.  Ken Smith

Comments

  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    The “tax free” categories are for when you have a security that is tax free and is in a taxable account.

    For tax deferred accounts the tax deferred setting in the account details should be selected.  The category for the transaction isn’t changed.

    The effect of this is to leave the account out of tax reports by default.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • kh57smth
    kh57smth Canada Beta Beta
    Chris, thanks for your insight.  The challenge becomes when you hold the same stock/ETF/mutual fund in a tax-free and taxable investment account.  When you set up the security details, you should not enable the tax-free box.  Hence all dividends or disbursements get reported as "taxable" in the Investment YTD report rather than split correctly into taxable and non-taxable earnings.  Ken
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    The tax report is filtered by the accounts selected, and by default the tax deferred ones aren't included, and therefore they don't get "reported".  Tax reports aren't broken down in taxable and nontaxable.  By definition only taxable transactions should be included in them.  The filter is twofold, first the account and second the category.  It doesn't matter that there are transactions with a taxable category in a nontaxable account because that account shouldn't be in the report in the first place.

    For instance, I have several IRA accounts, but only one taxable brokerage account, and I have sold securities in both types of accounts since the beginning of the year.  Here is the Capital Gains report:


    Notice isn't broken out between taxable and nontaxable, it broken out between short term and long term.  I don't know if the applies to the Canadian laws, but the point is that the nontaxable accounts have been left out by default.

    I can go into the customizing and include an IRA account like this:


    But doing so doesn't make any sense because I'm not tax on these accounts and therefore don't have to report capital gains on them.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    P.S. I have no idea what tax reports the Canadian version has, but even if it had non, one could always just make sure that they only include those taxable accounts in a report that they are going to use for their taxes.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/