Issue with my account regarding the date of the last empty row of each account set up.

I just realized that when I put a new transaction with a specific date (a few days or a few months before today that I forgot to enter) and then want to put a new transaction at today's date, the last empty row I use to enter the new transaction is not returning the today's date but keeps the last date entered. Why is that? It is creating many problems for me. It would be great if the last row (empty) could always reset to today's date by default.

Thank you
1 votes

New · Last Updated


  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    My guess would be that this behavior is by design.

    If a user is entering a series of transactions manually, it is more likely that the next entry will be on the same date as the last one rather than today.

    You can return to today's date by clicking the calendar icon then Today, or from the keyboard by typing a t in the date field. To see other keyboard shortcuts, go to Help > Quicken help then click on Global search and search for keyboard shortcuts. In addition to those listed, - and + go to the previous and next day.
    QWin Premier subscription
  • Funtrading
    Funtrading Member ✭✭
    Thank you very much, but it is not working for me, and if the default is set to today's date, it is much easier to spot the issue. I entered and corrected an entry dating two years before today, and I entered a new transaction for today sent two years ago because I did not pay attention to the default date and assumed it was today. Hopefully, this flaw will be corrected as soon as possible.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    When you say "not working for me," did you try typing the letter t in the date field of the blank transaction? That should change the date to today.

    I suppose that is not what you want, but it should be a useful work-around. I doubt that Quicken will change this long-standing behavior, which works well for the more common use case of entering a series of transactions in date order.

    Also to help prevent the issue you describe, Quicken has an optional warning that pops up if you are entering a transaction more than one year away. If you have selected "Don't show again" for this warning and want to restore it, you can go to Edit > Preferences > Alerts and messages and click on Reset Quicken warnings. This will reset all the warnings to their default states.
    QWin Premier subscription