Hypen vanishes when printing Inv. Perf. report with Custom dates

Can anyone duplicate this or is it just me?

I save Investment Performance reports and name them as "Investment Performance Report - All Accounts", .... - Brokerage, .....- HSA, ....- 401K, etc.

When I print each of these reports to a PDF using Custom Dates it removes any text after the hypen. If I choose another date option, like Last Year, it prints the file name out just fine, including the hyphen.

I use only custom dates so using the preformated date choices is not an option.

Yes. I could remember what report I'm printing and modify the file name to reflect the correct file I'm printing out.

Yes. I could use an underscore, leave space, or use dots, but I like the hyphen. I think it displays better for family members that I'm printing them out for.

Again, is this just me or can this problem be duplicated?

Quicken for Windows
Version: R46.12
Build: 27.1.46.12
Windows 10 Pro Ver: 10.0.19044 Build: 19044