How to get expense categories from subcategory drop down bos.

When setting up new category in expenses the subcategory drop down box only shows income categories. Where are the expense catagories?


  • Quicken Anja
    Quicken Anja Moderator mod
    Hello @fosmat,

    Thank you for reaching out to the Community and telling us about your issue, though we apologize that you are experiencing this.

    Could you please provide a screenshot of the issue you described above? If needed, please refer to this Community FAQ for instructions on how to attach a screenshot. Alternatively, you can also drag and drop screenshots to your response if you are not given the option to add attachments.

    Thank you!
    -Quicken Anja
  • UKR
    UKR SuperUser ✭✭✭✭✭
    fosmat said:
    When setting up new category in expenses the subcategory drop down box only shows income categories. Where are the expense catagories?
    Are you trying to create a main (or parent) category or a subcategory to an existing parent category?
    You cannot create an Expense subcategory to an Income parent category.
    If you would, please show us what you're trying to do. Create an image snapshot to a JPG, PNG or GIF file. Drag and drop the file from Windows File Explorer into your new comment on this webpage.

  • bc04745
    bc04745 Member
    I've experienced the same issue. If the screen-shot comes through, you can see that I've tried to add a subcategory for Utilities. In the subcategory drop-down, the sorted list ends with "unllocatdIncome" - the list does not include ANY of my expenses, much less my "Utilities" category.
  • UKR
    UKR SuperUser ✭✭✭✭✭

    If you haven't done so already, please do the following actions:

    • Reboot Windows.
    • Validate and Supervalidate your Quicken data file.


    Validate and Supervalidate instructions

    First save a backup file prior to performing these steps


    1. Click File
    2. Select Validate and Repair File...
    3. Select Validate File
    4. If the data file contains investment accounts also select "Rebuild investing lots". If you suspect that a damaged Quotes Price History causes your problems, also select "Correct investing price history" functions "Delete" or "Repair and Rebuild".
    5. Click OK
    6. Close the Data Log
    7. Close Quicken (leave it closed for about 30 secs)
    8. Reopen Quicken and see if the issue persists.

    Super Validate:

    1. Click File
    2. Press and hold both CTRL and Shift keys while you click Validate and Repair File...
    3. Select Supervalidate File
    4. Click OK
    5. Close the Data Log
    6. Close Quicken (leave it closed for about 30 secs)
    7. Reopen Quicken and see if the issue persists.
  • bc04745
    bc04745 Member
    Hello, thanks for your follow-up. I've applied the patch but no difference. I just did a "super validate" two days ago with Quicken Support, so am not going to spend time doing that again. I've added another screen-shot though. This demonstrates that even an existing sub-category, when edited, does not reflect the category for which it is a "child", in my case "Utilities". I cannot make any edits to the sub-category, as I have no way to select "Utilities" in the drop-down. Hope this is helpful.
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser ✭✭✭✭✭
    @bc04745 are there any clues in the validation log? Show us every line in that file for the last validation.
    Depending on what's in that log, your file may be corrupted beyond validation's ability to repair.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription (US) on Win10 Pro.
  • bc04745
    bc04745 Member
    No, the tech's response to the content was "...this is a very clean file... your file is very good..." By the way, I am running Quicken Home, Business & Rental Property, Version R47.7, Build I'll add that I probably haven't tried to add a new category/sub-category in a number of months, so this issue may not be new, but introduced some time ago.
  • Sammy A
    Sammy A Member ✭✭
    I just noticed the same problem. I have Version R46.12 Build on Windows. For the life of me I can't create a subcategory of an expense. I can do it for an income, the dropdown list of parent categories doesn't show a single expense, only income categories. I tried multiple entry points to get the code to do it but no success, i.e., I tried from the account register by making up a new category while entering the expense transaction, I also tried it from the Category List using the right mouse button on an expense and executing the command "New Subcategory" but no luck in either case. Please help!
  • JeffKeef
    JeffKeef Member
    I also have Version R46.12 Build on Windows and I don't have the option to create a subcategory of an Expense category--only of Income categories.
  • JeffKeef
    JeffKeef Member
    :( I had Version R46.12 Build on Windows and then I installed the latest Mondo patch as instructed above. I've also ran a validation. No change. When trying to add a new expense subcategory, I'm only offered Income main categories in the dropdown--no Expense main categories.
This discussion has been closed.