Rename Payee, Edit Memo, ReTag Transaction from report does not make changes

Camelot_One Member ✭✭
I'm not sure when this started, but it's been recently. I am unable to rename the Payee, Retag, or edit the Memo on any transaction from a report. Steps to reproduce:
1. Run a Spending - Itemized Payees report (seems to be with any report though)
2. Right click on one or more transactions, select Rename Payee. (or Retag, Edit memo)
3. Rename box appears, enter new name and press OK.
4. Rename box goes away, but nothing is changed on the transaction.

This used to work. I usually go through the payee list every few months to consolidate names for the same place that have a slight mismatch. Example, "Office Bar & Grill" and "Office Bar and Grill". But renaming any Payee from the report is no longer working. I can still go to each transaction in the register and rename them one at a time, so it's not like they are locked. (though I would actually like to have the option to lock things)

"Recategorize Transaction" does work. But Rename Payee, ReTag Transaction, and Edit Memo all fail to make any changes to the transaction.

Quicken for Windows - Home, Business & Rental Property
Version: R47.7

Update/edit: This seems to be related to a known issue, though as of this writing, that issue thread doesn't mention Payees being a problem as well.


  • LarBear360
    LarBear360 Member ✭✭
    Exact issue experienced just this morning. Re-Naming Payee no longer does anything.
  • Camelot_One
    Camelot_One Member ✭✭
    My Quicken was automatically updated when I opened it this morning. (as in, no prompt to update, it just did it) The problem still exist.

    I am now on:
    Quicken Home, Business, & Rental Property
    Version R47.11
  • galahad
    galahad Member
    edited February 2
    This is an ongoing problem [Removed - Speculation]. The other issue I encounter each new month is the amounts I enter into my PLANNING budget CHANGE to amounts that have no logic to my past or present budget amounts.
  • LarBear360
    LarBear360 Member ✭✭
    Yes, problem persists. I don't understand why they have to keep "fixing" things that are not broken. Now they're broken and no fix.
  • Camelot_One
    Camelot_One Member ✭✭
    edited February 6
    For anyone else needing an immediate solution that allows you to rename/retag/memo, etc., you can install an older version to make your changes, and then patch back to current. The download page for older versions is here:

    Scroll down to November 2022 and grab 'Release R45.7 (11/9/2022)'
    Direct download link:

    I tested each version from R47.11 (current) going backwards, and R45.07 seems to be the newest version that doesn't have this bug. The patch file is all you need, it will install over your existing version.

    Note - the older patch files were poorly coded, and can't handle a space in the path to your temp folder, which happens if your Windows user name contains a space. The patch will error out with: "An error occurred - Unable to check for updates, the server file failed to load"
    To work around the issue, you can extract the installer to a folder path without any spaces first (I used Winrar) and run "patch.exe" inside it to get it to install correctly.
  • I'm so glad to have found this thread, because I thought I was doing something wrong. I run a register report every year during tax season and "clean up" the register using this feature to batch change payess, categories, etc. But this year, it doesn't work. Thanks for the advice, Camelot_One. I'm going to give that a try.
  • Gennadi
    Gennadi Member ✭✭
    I'm experiencin the same issue. (Edit Memo, ReTag Transaction)
  • nbkmzjm
    nbkmzjm Member

    Retag with multiple tags still work. As workaround, I created a generic tag named * tag, then pick that first and click on multiple tags button, add a 2nd tag with the tag of your choice and it should do the job.

  • daqs
    daqs Member ✭✭
    edited March 22
    Broken for me as well. Seriously Quicken your reporting a critical feature of any financial software is a joke. Your quality control around bugs is going down hill. Stop added new features most people dont need and clean up the reporting. It always display horribly, random issues like this. I feal like quicken is just milking its current user base at this point. I really need to start looking for another option. Seriously Quicken bad timing with tax time. This bug you are aware of has been opened for over a few months like you could care less. On the older version retag does not work.
  • Pixxal
    Pixxal Member

    Thought I should add my voice to this thread, I am having the same issue and finding it quite annoying. Running Canada Home and Business version R45.18

    Thought I was going crazy trying to do something I have routinely done in the past. Looking back through several threads this problem has been ongoing for several months and has yet to be solved.


    Tried the procedure suggested in this thread with no luck: