Home Quicken for Windows Errors and Troubleshooting (Windows)

Quicken 17 R4 - Program moves Mouse cursor

skeske Member
The program keeps throwing my mouse cursor up in the left hand corner of the screen. Driving me crazy. Why do they have to mess with that?

Comments

  • UKRUKR SuperUser ✭✭✭✭✭
    edited September 2018
    Please read https://getsatisfaction.com/quickencommunity/topics/mouse-properties-snap-to for a recent discussion on this issue.
    You apparently have set a Windows Mouse Properties option and not all Quicken windows seem to properly support it.

    I don't know if and when this will get fixed, the next patch release level or the next year's version or ...
    Meanwhile, I recommend you turn off this Mouse Properties setting. I've done so and I'm really not missing it from any other application either.
  • thecreatorthecreator SuperUser ✭✭✭✭✭
    edited December 2018
    Hi @ ske ,

    Is this a Laptop or Desktop Computer?
    thecreator - User of Quicken Subscription R27.42 & Quicken 2017 HBRP R20.5
                       Windows 10 Pro 32 & 64-Bit Build 20175.1000

    Information: https://community.quicken.com/discussion/7871028/quicken-bill-pay-discontinues-on-5-31-20-introducing-quicken-bill-manager

    View: https://community.quicken.com/discussion/7859218/work-with-copies-of-your-actual-quicken-data-files/p1?new=1

  • skeske Member
    edited December 2018
    I don't understand what mouse properties need to be disabled. I have a Logitech wireless mouse with standard features; nothing custom. I have no issues with any other programs on Windows 10. And yes I am on a desktop computer. This is more of a mild aggravation and not a function problem. Everytime I think I know where my cursor is, it's not there and been put up in the left hand corner of the screen. Never seen this in 30 yrs of windows.
  • thecreatorthecreator SuperUser ✭✭✭✭✭
    edited January 2017
    ske said:

    I don't understand what mouse properties need to be disabled. I have a Logitech wireless mouse with standard features; nothing custom. I have no issues with any other programs on Windows 10. And yes I am on a desktop computer. This is more of a mild aggravation and not a function problem. Everytime I think I know where my cursor is, it's not there and been put up in the left hand corner of the screen. Never seen this in 30 yrs of windows.

    Hi @ ske ,

    Do you have Logitech's Setpoint program installed?

    http://support.logitech.com/en_us/downloads  Scroll down until you see SetPoint.

    Now select 32-Bit or 64-Bit version, based on your operating system.

    The Mouse Properties is located in the Control Panel.
    thecreator - User of Quicken Subscription R27.42 & Quicken 2017 HBRP R20.5
                       Windows 10 Pro 32 & 64-Bit Build 20175.1000

    Information: https://community.quicken.com/discussion/7871028/quicken-bill-pay-discontinues-on-5-31-20-introducing-quicken-bill-manager

    View: https://community.quicken.com/discussion/7859218/work-with-copies-of-your-actual-quicken-data-files/p1?new=1

  • UnknownUnknown Member
    edited January 2017
    ske said:

    I don't understand what mouse properties need to be disabled. I have a Logitech wireless mouse with standard features; nothing custom. I have no issues with any other programs on Windows 10. And yes I am on a desktop computer. This is more of a mild aggravation and not a function problem. Everytime I think I know where my cursor is, it's not there and been put up in the left hand corner of the screen. Never seen this in 30 yrs of windows.

    You have a choice live with the cursor being jerked around like this or disable the feature.

    This is bug in Quicken 2017, and until it gets fixed (if it gets fixed) there isn't much more to say on the subject (other than what has already been said in the thread that UKR pointed to)
  • skeske Member
    edited January 2017
    Thanks for your attention to this. I disconnected my wireless mouse and plugged in a generic usb mouse and the results are the same. So, guess we'll just have to wait for a Quicken update.
  • UKRUKR SuperUser ✭✭✭✭✭
    edited September 2018
    If the mouse movement irritates you, turn off the "Snap to" feature in Windows.
    Go into the Windows Control Panel / Mouse.
    Click the Pointer Options tab.
    Click to remove the checkmark from "Snap to".

    image

    Easy peasy, as my British friends would say.
  • skeske Member
    edited December 2018
    AMAZING! That fixed it. Thanks. Never would have thought of that.
  • UnknownUnknown Member
    edited January 2017
    ske said:

    AMAZING! That fixed it. Thanks. Never would have thought of that.

    I can't believe I did this.  I read this:
    "I don't understand what mouse properties need to be disabled. "

    And my mind said " I don't understand why that mouse property needs to be disabled...."

    Sorry, thought it was understood of what mouse setting was doing this.
  • UnknownUnknown Member
    edited February 2017
    ske said:

    AMAZING! That fixed it. Thanks. Never would have thought of that.

    I don't get it. Let's put pressure on Quicken to fit this problem. It is a Windows feature. You just advised a user to disable a system wide option, that will have an impact on every program he has installed on his system. Perhaps he doesn't realize this but you do; I know you do. Even if Quicken doesn't LIKE this option they can implement it on a per person basis by placing the option in PREFERENCES just as they do for cut and paste. Your response and Quicken's unwillingness to address this issue is appalling.
  • skeske Member
    edited February 2017
    ske said:

    AMAZING! That fixed it. Thanks. Never would have thought of that.

    I agree. The culprit causing this problem is the "Snap to" feature in the mouse properties. When I disabled this feature, Quicken stopped misbehaving, but why should any user have to disable a windows feature to satisfy Quicken.
  • thecreatorthecreator SuperUser ✭✭✭✭✭
    edited February 2017
    ske said:

    AMAZING! That fixed it. Thanks. Never would have thought of that.

    Hi @ All ,

    Quicken is not at fault, so Quicken is not going to fix it. My Mouse pointer was jumping even with Snap To unchecked.

    I replaced the Mouse Receiver and that helped.

    The Mouse was jumping with Quicken not installed, so where is that Quicken's problem with Quicken not installed?
    thecreator - User of Quicken Subscription R27.42 & Quicken 2017 HBRP R20.5
                       Windows 10 Pro 32 & 64-Bit Build 20175.1000

    Information: https://community.quicken.com/discussion/7871028/quicken-bill-pay-discontinues-on-5-31-20-introducing-quicken-bill-manager

    View: https://community.quicken.com/discussion/7859218/work-with-copies-of-your-actual-quicken-data-files/p1?new=1

  • skeske Member
    edited February 2017
    ske said:

    AMAZING! That fixed it. Thanks. Never would have thought of that.

    That's really strange. All I know is that I've been using Quicken since 1998 and this version has been my only beef. Of course, if Intuit cared about customers, they would address their concerns instead of shrugging them off. Just sayin...
  • thecreatorthecreator SuperUser ✭✭✭✭✭
    edited February 2017
    ske said:

    AMAZING! That fixed it. Thanks. Never would have thought of that.

    Hi @ ske ,

    Try a different Mouse and Receiver.

    You mentioned Windows 10. What is the Build?

    You find it, see this Article:  https://getsatisfaction.com/quickencommunity/topics/add-your-quicken-information-to-your-posts-plus-...
    thecreator - User of Quicken Subscription R27.42 & Quicken 2017 HBRP R20.5
                       Windows 10 Pro 32 & 64-Bit Build 20175.1000

    Information: https://community.quicken.com/discussion/7871028/quicken-bill-pay-discontinues-on-5-31-20-introducing-quicken-bill-manager

    View: https://community.quicken.com/discussion/7859218/work-with-copies-of-your-actual-quicken-data-files/p1?new=1

  • skeske Member
    edited February 2017
    ske said:

    AMAZING! That fixed it. Thanks. Never would have thought of that.

    Windows 10 Home - 64bit
    vers 1607
    OS build: 14393.693
  • thecreatorthecreator SuperUser ✭✭✭✭✭
    edited February 2017
    ske said:

    AMAZING! That fixed it. Thanks. Never would have thought of that.

    Hi @ ske ,

    You might wish to tell Microsoft what is happening via the Feedback Hub, Application. It should call their attention to this problem.
    thecreator - User of Quicken Subscription R27.42 & Quicken 2017 HBRP R20.5
                       Windows 10 Pro 32 & 64-Bit Build 20175.1000

    Information: https://community.quicken.com/discussion/7871028/quicken-bill-pay-discontinues-on-5-31-20-introducing-quicken-bill-manager

    View: https://community.quicken.com/discussion/7859218/work-with-copies-of-your-actual-quicken-data-files/p1?new=1

  • UnknownUnknown Member
    edited February 2017
    ske said:

    AMAZING! That fixed it. Thanks. Never would have thought of that.

    First of this is a Quicken problem.  Second this isn't a randomly jumping cursor.
    If your cursor is jumping randomly certainly check the battery and the hardware.

    What is happening is that in any given window/dialog the programmer can designate a button to the be "default".  And so when the user has the snap to feature enabled and the window/dialog comes up the mouse cursor will jump to that button.

    Quicken 2017 has a hidden window that has that attribute turned on, and it is in the upper left of the screen.  The results is when Quicken starts or quits the cursor jumps to that spot.

    This is not random cursor movement.

    As for putting pressure on Quicken Inc to fix it.  Feel free if you can, it is just one of many, many bugs in Quicken, and they will get to it when they get to it.
    Note the priority they are going to set for this is going to depend on the number of people it affects (which is pretty low since you have to have the snap to feature on), and how hard it is to workaround it (quite easy to do), and what kind of affect (it isn't even close to being in the realm of say a crash).
  • skeske Member
    edited February 2017
    ske said:

    AMAZING! That fixed it. Thanks. Never would have thought of that.

    Exactly. I didn't know about the hidden window thing, but it all makes sense. I have had a love/hate relationship with Quicken for about 8 years. Every time Intuit releases an update, I hold my breath and hope it works. Wish I could go back to 2010 version, but they won't have any of that. The last 2-3 years seem like the worse. If another program would come along to match Quicken, I would quit and move on.

    Anyway, thanks for taking the time to answer my post.
  • thecreatorthecreator SuperUser ✭✭✭✭✭
    edited February 2017
    ske said:

    AMAZING! That fixed it. Thanks. Never would have thought of that.

    Hi @ ske ,

    Out of Curiosity, if you take your hand off the mouse, does the Mouse Pointer move or it is stationary, with Quicken Close and not in memory.
    thecreator - User of Quicken Subscription R27.42 & Quicken 2017 HBRP R20.5
                       Windows 10 Pro 32 & 64-Bit Build 20175.1000

    Information: https://community.quicken.com/discussion/7871028/quicken-bill-pay-discontinues-on-5-31-20-introducing-quicken-bill-manager

    View: https://community.quicken.com/discussion/7859218/work-with-copies-of-your-actual-quicken-data-files/p1?new=1

  • skeske Member
    edited February 2017
    ske said:

    AMAZING! That fixed it. Thanks. Never would have thought of that.

    No it is stationary. Only moves to upper left hand corner when using Quicken. Killing the Quicken process there is nothing strange with the mouse.
  • thecreatorthecreator SuperUser ✭✭✭✭✭
    edited February 2017
    ske said:

    AMAZING! That fixed it. Thanks. Never would have thought of that.

    Hi @ ske ,

    Okay. On one of my Desktop Computers, it is Rock steady. The other one, it moves without me touching it, That's why I posted / stated what I stated.
    thecreator - User of Quicken Subscription R27.42 & Quicken 2017 HBRP R20.5
                       Windows 10 Pro 32 & 64-Bit Build 20175.1000

    Information: https://community.quicken.com/discussion/7871028/quicken-bill-pay-discontinues-on-5-31-20-introducing-quicken-bill-manager

    View: https://community.quicken.com/discussion/7859218/work-with-copies-of-your-actual-quicken-data-files/p1?new=1

  • Larry4Larry4 Member ✭✭
    edited November 2017
    ske said:

    AMAZING! That fixed it. Thanks. Never would have thought of that.

    Agreed not a critical issue but quite annoying and still unresolved in Quicken 2018 R2.3, build 27.1.2.20.  
  • UnknownUnknown Member
    edited November 2017
    ske said:

    AMAZING! That fixed it. Thanks. Never would have thought of that.

    ...Quicken 2018 R3 .... if nothing else they are consistent.
  • UnknownUnknown Member
    edited July 2018
    ske said:

    AMAZING! That fixed it. Thanks. Never would have thought of that.

    Disabling a windows feature to avoid a poor design choice is not a fix.  Quicken software developers please notice how many times people detect and report this problem.  It IS a problem that needs to be fixed.
  • UnknownUnknown Member
    edited December 2018
    Quicken R10.10 issues build 27.1.10.10

    These are issues noticed under Quicken R10.10 issues build 27.1.10.10 that was downloaded just a few minutes prior to leaving this feedback.


    Mouse stealing occurs at startup, shutdown and at several points in one-step update.  My mouse is moved to the top left corner on launching and exiting quicken.  Quicken should not be repositioning my mouse.  It prevents me from using MY computer while quicken is performing a background operation.  For example if I happen to be dragging a Different - non-Quicken window on my desktop, it will be repositioned when the mouse is moved.
This discussion has been closed.