Launch FCU,Florida - ERROR: SSL_VERSION_OR_CIPHER_MISMATCH

While trying to download my account information from the above credit union I get the following message. "[ERROR:SSL_VERSION_OR_CIPHER_MISMATCH].
Tagged:

Comments

  • UKRUKR SuperUser ✭✭✭✭✭

    In case of transaction download problems

    Please provide more details.

    What version and release of Quicken are you using? Click Help / About Quicken (Mac: Quicken / About Quicken) to determine year/version and release.  You must be on the latest release (patch) level for your supported Quicken version. If you're missing patches, update your software first.
    What version of Windows or Mac OS are you using?
    What error codes, error messages, symptoms do you get?
    What bank(s) are you having issues with?
    What account types (checking, savings, etc.) are you having issues with?
    Does this problem occur when you run One Step Update from your desktop or when you initiate a download using the Quicken Mobile App or Quicken on the Web?
    What have you tried so far to resolve the issue?


  • markus1957markus1957 SuperUser ✭✭✭✭✭
    I suspect your credit union is requiring a higher level of encryption than your operating system or browser can deliver.  Most/All banks do not accept SSL level connections. TLS is required.
  • jman100419jman100419 Member
    I'm using 2014 Quicken Deluxe, Release R10(23.1.10.4
  • markus1957markus1957 SuperUser ✭✭✭✭✭
    QW2014 is no longer supported for downloads partly for the reasons stated above and also Quicken policy.  You will need to update to the subscription product if you want to download from financial institutions. 
This discussion has been closed.