Home Quicken for Mac Download, Add/Update Accounts (Mac)

Interest and Dividends from Retirement Accounts should be Tax Free

I have several IRA accounts (properly set up as IRA's). When transactions are downloaded, the Interest and Dividends from these accounts are classified as regular interest and dividends, not tax free. Is there any way to force Q Mac to categorize these correctly?

Comments

  • chitownhockeychitownhockey Member ✭✭✭✭
    The dividends and interest from IRA's are NOT tax free.  They are tax deferred.  You pay ordinary income tax when you make withdrawals from the IRA for those amounts.  

    For them to be considered tax deferred, you need to edit the IRA account and make sure that the account type selected is "IRA".

    And then, depending on which report you select, you'll need to exclude that IRA account from the report to report on taxable dividends, interest and capital gains.  

    I use a Tax Schedule report...and that only reports on my taxable accounts.  My IRA and 401K accounts, which are tax deferred, are not shown in that report.

    I also created and saved TWO Category Reports...selecting ONLY the categories Interest, Dividends, Short term Capital Gains and Long term Capital Gains...one report is customized to include ALL taxable and non-taxable investment accounts...the other one is just taxable accounts.

    You might consider those. 


  • Ducksoup_SDDucksoup_SD Member ✭✭
    Roth IRA's ARE tax free and Quicken has always ignored this. You never pay tax on Roth accounts once you reach 59 1/2. If you convert from a Traditional IRA to a Roth, it is a taxable event so you pay taxes then. You never have to pay taxes again and there are no minimum distributions required for a Roth by the original account owner.

    Since the Roth IRA has been around for over 20 years, it's time for Quicken to finally acknowledge they exist!
  • jacobsjacobs SuperUser ✭✭✭✭✭
    @Ducksoup_SD Quicken Mac does have Roth IRA in the accounts type list:



    QMac 2007 & QMac Subscription • Quicken user since 1993
  • Ducksoup_SDDucksoup_SD Member ✭✭
    https://community.quicken.com/profile/jacobs - if they aren't going to recognize that Roth IRAs have tax free withdrawals (after 59 1/2) and no RMDs for their planning tools (unlike Traditional IRAs), then it really doesn't matter what the account type is - it could just as well be labeled Bank Account, since their reports and planning tools will continue to give poor results. I use the Windows version and they've never come close to getting the Roth rules correct.
  • TriconeTricone Member ✭✭
    I ran into the same issue as the OP, and I do not believe any replies (as of yet), have solved the problem. I, too, would like to reclassify downloaded MUNICIPAL BOND INTEREST as Tax-Free Interest. In particular, the bonds are invested in the state that I live, and therefore are truly double-tax free! I believe that the main question is how to change the the classification. For some reason, in my investment (brokerage) account register, it does not allow me to.


    > @chitownhockey said:
    > The dividends and interest from IRA's are NOT tax free.  They are tax deferred.  You pay ordinary income tax when you make withdrawals from the IRA for those amounts.  
    >
    > For them to be considered tax deferred, you need to edit the IRA account and make sure that the account type selected is "IRA".
    >
    > And then, depending on which report you select, you'll need to exclude that IRA account from the report to report on taxable dividends, interest and capital gains.  
    >
    > I use a Tax Schedule report...and that only reports on my taxable accounts.  My IRA and 401K accounts, which are tax deferred, are not shown in that report.
    >
    > I also created and saved TWO Category Reports...selecting ONLY the categories Interest, Dividends, Short term Capital Gains and Long term Capital Gains...one report is customized to include ALL taxable and non-taxable investment accounts...the other one is just taxable accounts.
    >
    > You might consider those. 
  • jacobsjacobs SuperUser ✭✭✭✭✭
    Tricone said:
    I ran into the same issue as the OP, and I do not believe any replies (as of yet), have solved the problem. I, too, would like to reclassify downloaded MUNICIPAL BOND INTEREST as Tax-Free Interest. In particular, the bonds are invested in the state that I live, and therefore are truly double-tax free! I believe that the main question is how to change the the classification. For some reason, in my investment (brokerage) account register, it does not allow me to.
    If the security is tax-free, in a non-retirement brokerage account, that's a setting you need to make on the security, not the account. Go to Window > Securities, find the security in question, click the pencil icon to edit, and check the "Tax-free" check box to the right of the security name.

    Now, on the Tax Schedule report, dividend income from that security will show up under Schedule B, but separated out under a heading of "Div. Income, Non-Taxable."

    I think it's worth noting that Quicken is not tax software. It doesn't know how old you are, for instance, so expecting it to know the ins and outs of IRA withdrawals, which are treated differently at different ages, is wishing for something that Quicken just doesn't tackle. It doesn't know where you live, and the difference between tax-free investments that are taxable for your state versus those that are state-tax free. All you can hope to do is identify things within Quicken so you can enter them properly in your tax program. (And for that, I still defer to what's on the 1099's I get for my investments, not the Quicken tax report.) 
    QMac 2007 & QMac Subscription • Quicken user since 1993
This discussion has been closed.